Microsoft Excel

Herbers Excel/VBA-Archiv

Datumsformel gesucht

Betrifft: Datumsformel gesucht von: Claudia
Geschrieben am: 04.10.2007 12:10:57

Hallo alle zusammen,

ich benötige eine Formel fürs Datum und verzweifel schon langsam.
Ich habe in Zelle B22 ein Datum stehen. Ausgehend von diesem Datum benötige ich in der darunterliegenden Zelle (C22) das gleiche Tagesdatum aber einen Monat weiter.

Beispiel 15.08.2008 dann 15.09.2008

Das ganze soll dann nach unten weiter gehen, (15.10.2008, 15.11.2008 usw) also immer den 15 des kommenden Monats.

Kriege das mit Datumsrechnen plus 30 Tage usw nicht hin. Das ganze benötige ich für eine Tabelle im Bereich Kreditrechnung.

Wer hat eine Idee oder gar eine fertige Formel für so etwas.
Danke für Eure Hilfe im voraus.
Gruß
Claudia

  

Betrifft: AW: Datumsformel gesucht von: Rudi Maintaire
Geschrieben am: 04.10.2007 12:12:40

Hallo,
=datum(Jahr(B22);Monat(B22)+1;Tag(B22))

Gruß
Rudi

Eine Kuh macht Muh, viele Kühe machen Mühe


  

Betrifft: Vielen dank das wars was ich suchte o.T. von: Claudia
Geschrieben am: 04.10.2007 13:13:53




  

Betrifft: AW: Datumsformel gesucht von: rlenz
Geschrieben am: 04.10.2007 18:21:35

Hallo Claudia,
einmal nicht kaufmännisch betreffend deinen Wünschen zur Kreditberechnung.

 
 BCDEFGHI
21mit Funktionen MIN, DATUM und ZEILE- Funktionen, keine Analyse- Funktion erforderlichmit Funktionen EDATUM und ZEILE    
2231.01.2007verbessert31.01.2007verbessert31.01.200728.02.200731.01.200728.02.2007
2328.02.200728.02.200728.02.200728.02.200703.03.200728.03.200728.02.200728.03.2007
2431.03.200731.03.200731.03.200731.03.200703.04.200728.04.200728.03.200728.04.2007
2530.04.200730.04.200730.04.200730.04.200703.05.200728.05.200728.04.200728.05.2007
2631.05.200731.05.200731.05.200731.05.200703.06.200728.06.200728.05.200728.06.2007
2730.06.200730.06.200730.06.200730.06.200703.07.200728.07.200728.06.200728.07.2007
2831.07.200731.07.200731.07.200731.07.200703.08.200728.08.200728.07.200728.08.2007
2931.08.200731.08.200731.08.200731.08.200703.09.200728.09.200728.08.200728.09.2007
3030.09.200730.09.200730.09.200730.09.200703.10.200728.10.200728.09.200728.10.2007
3131.10.200731.10.200731.10.200731.10.200703.11.200728.11.200728.10.200728.11.2007
3230.11.200730.11.200730.11.200730.11.200703.12.200728.12.200728.11.200728.12.2007
3331.12.200731.12.200731.12.200731.12.200703.01.200828.01.200828.12.200728.01.2008
3431.01.200831.01.200831.01.200831.01.200803.02.200828.02.200828.01.200828.02.2008
3529.02.200829.02.200829.02.200829.02.200803.03.200828.03.200828.02.200828.03.2008
3631.03.200831.03.200831.03.200831.03.200803.04.200828.04.200828.03.200828.04.2008
Formeln der Tabelle
B23 : =MIN(DATUM(JAHR($B$22); MONAT($B$22)+ZEILE()-22;TAG($B$22)); DATUM(JAHR($B$22); MONAT($B$22)+ZEILE()-22+1;0))
C23 : =WENN(ISTZAHL($B$22); MIN(DATUM(JAHR($B$22); MONAT($B$22)+ZEILE()-22;TAG($B$22)); DATUM(JAHR($B$22); MONAT($B$22)+ZEILE()-22+1;0)); "")
D23 : =EDATUM($D$22;ZEILE()-22)
E23 : =WENN(ISTZAHL($D$22); EDATUM($D$22;ZEILE()-22); "")
F23 : =DATUM(JAHR(F22); MONAT(F22)+1;TAG(F22))
G23 : =DATUM(JAHR(G22); MONAT(G22)+1;TAG(G22))
H23 : =EDATUM(H22;1)
I23 : =EDATUM(I22;1)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

MfG
Rüdiger Lenz


  

Betrifft: Alternative: =EDATUM(A1;1) bzw. =EDATE(A1;1)... von: NoNet
Geschrieben am: 04.10.2007 14:46:38

Hallo Claudia,

wenn Du per "Extras - AddIns-Manager" die "Analyse Funktionen" (bzw. "Analysis ToolPak") installierst, steht dafür die Funktion =EDATUM(A1;1) (bzw. =EDATE(A1;1) in der multilingualen Version) zur Verfügung.

Allgemeiner ist jedoch die Lösung von Rudi !

Gruß, NoNet


  

Betrifft: =A1+32-TAG(A1+17) von: FP
Geschrieben am: 04.10.2007 20:24:42

Hallo Claudia,

soferne Du wirklich nur von einem 15. ausgehend den nächsten 15. suchst...

Servus aus dem Salzkammergut
Franz