Microsoft Excel

Herbers Excel/VBA-Archiv

Zufallszahl mit Wahrscheinlichkeit

Betrifft: Zufallszahl mit Wahrscheinlichkeit von: Broadcast
Geschrieben am: 14.01.2008 08:57:10

Hallo,

ich brauche eine Funktion, die mir mit einer Wahrscheinlichkeit von 95% eine 1 und zu 5% eine 0 zurückgibt.

Soweit bin ich: =runden(zufallszahl()*(1-0)+0;0)

Viele Grüße,

Broadcast

  

Betrifft: AW: Zufallszahl mit Wahrscheinlichkeit von: Harry
Geschrieben am: 14.01.2008 09:28:36

Hallo Broadcast

in VBA müsste es sein

Option Explicit

Function Zufall95() As Byte
Dim sgHelper As Single

sgHelper = Rnd()

    If sgHelper < 0.05 Then
        Zufall95 = 0
    Else
        Zufall95 = 1
    End If

End Function



in Excel

=WENN(ZUFALLSZAHL()<0,05;0;1)



Gruß

Harry


  

Betrifft: =GANZZAHL(ZUFALLSZAHL()+0,95) von: WF
Geschrieben am: 14.01.2008 09:34:08

.


  

Betrifft: AW: Zufallszahl mit Wahrscheinlichkeit von: Renee
Geschrieben am: 14.01.2008 10:02:08

Hi Broadcast,

=VERGLEICH(MAX(B16;0.05);{0.05;0.0511})-1


GreetZ Renée


  

Betrifft: AW: Zufallszahl mit Wahrscheinlichkeit von: Renee
Geschrieben am: 14.01.2008 11:37:46

Hi

Sorry, ich hatte da ein Durcheinander mit 2 verschiedenen Threads..

Renée

Nimm WF's =GANZZAHL(ZUFALLSZAHL()+0,95)


 

Beiträge aus den Excel-Beispielen zum Thema "Zufallszahl mit Wahrscheinlichkeit"