Microsoft Excel

Herbers Excel/VBA-Archiv

ANZAHL DER NEUEINTRÄGE 2008

Betrifft: ANZAHL DER NEUEINTRÄGE 2008 von: christian neu
Geschrieben am: 28.03.2008 06:48:17

GUTEN MORGEN

kurze frage wie kann ich die anzahl der neuen einträge im jahr 2008 in einer db ermitteln?
wobei keine namens einträge mitgezählt werden dürfen die es schon im vorjahr 2007
gegeben hat.

spalte A: NAME
spalte:E DATUM

sinnn des ganzen :
ich möchte den zuwachs pro jahr an neuen namen herausfinden die nicht doppelt sind.

vielen dank
gruss
christian neu

  

Betrifft: =ZÄHLENWENN(JAHR(E:E)=2008;A:A) von: David
Geschrieben am: 28.03.2008 08:01:24




  

Betrifft: AW: =ZÄHLENWENN(JAHR(E:E)=2008;A:A) von: christian neu
Geschrieben am: 28.03.2008 08:57:12

SERVUS DANIEL
danke für deine anwort.
aber ich erhalte immer eine fehlermeldung wenn ich die formel eingebe.
was mache da falsch??
bitte hilf mir nochmal.

danke
christian neu


  

Betrifft: AW: Ups... ;-) von: David
Geschrieben am: 28.03.2008 09:21:32

Da hab ich wohl was verwechselt und mit SUMMEWENN zusammengeschmissen. Man sollte halt vorher testen bevor man postet.

So sollte es aber gehen:

=ZÄHLENWENN(E:E;">31.12.2007")



Gruß

David

PS: Ich bin NICHT Daniel. ;-)


  

Betrifft: AW: Ups... ;-) von: christian neu
Geschrieben am: 28.03.2008 09:31:46

HI
david danke nochmal, anscheinend habe ich mich falsch ausgedrückt.
die formel funktioniert, zählt aber alle einträge die 2008 drinnen sind .
egal ob der name maier 3x drinnen steht.
die formel soll keine doppelten namens einträge mit zählen.

beispiel mit dieser formel zähle ich wieviele gesamt einträge ich in der db habe, aber nur namen die nicht doppelt vorkommen.
vieleicht kann mann da noch das datum 2008 einbauen?????

=SUMME(1/WENN(ZÄHLENWENN(B6:B996;B6:B996)=0;1;
ZÄHLENWENN(B6:B996;B6:B996)))-ANZAHLLEEREZELLEN(B6:B996)-1
am anfag und ende sind aryäa zeichen drinnen.

danke
christian neu


  

Betrifft: Neueinträge 2008 ohne Doppler von: WF
Geschrieben am: 28.03.2008 11:00:17

Hi Chris,

das hab ich jetzt erstmal nur mit Hilfsspalte C hinbekommen:
in C1 steht:
=WENN(SUMMENPRODUKT((A$1:A$999=A1)*(JAHR(B$1:B$999)<2008))=0;A1;"")
runterkopieren

Das Ergebnis liefert dann die Arrayformel:
{=SUMME(WENN(C1:C999<>"";1/ZÄHLENWENN(C1:C999;C1:C999)))}

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.

trapp, trapp, trapp, trapp, trapp, brrrrr
WF

http://www.excelformeln.de/
die ultimative Formelseite


 

Beiträge aus den Excel-Beispielen zum Thema "ANZAHL DER NEUEINTRÄGE 2008"