Microsoft Excel

Herbers Excel/VBA-Archiv

Uhrzeitangabe auswerten (Zeitspanne)

Betrifft: Uhrzeitangabe auswerten (Zeitspanne) von: Andi
Geschrieben am: 01.07.2008 13:27:09

Hallo zusammen,

ich verzweifle gerade bei folgender Sache:

Eine Uhrzeitangabe im Format hh:mm:ss soll in einer Zelle als Zeitspanne widergegeben werden.

Bsp: 07:12:00
soll als "7-8 Uhr" wiedergegeben werden, wobei die Zeitspannen folgendermassen aussehen:

0-1 Uhr
1-2 Uhr
2-3 Uhr
3-4 Uhr
4-5 Uhr
5-6 Uhr
6-7 Uhr
7-8 Uhr
8-9 Uhr
9-10 Uhr
10-11 Uhr
11-12 Uhr
12-13 Uhr
13-14 Uhr
14-15 Uhr
15-16 Uhr
16-17 Uhr
17-18 Uhr
18-19 Uhr
19-20 Uhr
20-21 Uhr
21-22 Uhr
22-23 Uhr
23-0 Uhr

Meine Versuche über eine wenn-dann Funktion blieben erfolglos:
=WENN(UND($E8>=Q$5;$E8=r$5;$E8=s$5;$E8=t$5;$E8=u$5;$E8=v$5;$E8=w$5;$E8=x$5;$E8=y$5;$E8=z$5;$E8=aa$5;$E8=ab$5;$E8=ac$5; $E8=ad$5;$E8=ae$5;$E8=af$5;$E8=ag$5;$E8=ah$5;$E8=ai$5;$E8=aj$5; $E8=ak$5;$E8=al$5;$E8=am$5;$E8=an$5;$E8
Vielen Dank vorab für die Unterstützung!!!
Andi

  

Betrifft: AW: =STUNDE(A1) & "-"&STUNDE(A1)+1& " Uhr" von: Chris
Geschrieben am: 01.07.2008 13:40:19

Servus Andi,

probier mal das (s.Betreff).

Gruß

Chris


  

Betrifft: AW:kleine Nachbesserung von: Chris
Geschrieben am: 01.07.2008 13:48:07

Servus Andi,

für 23-0 Uhr muss es so heißen:

=WENN(STUNDE(A1) = 23;STUNDE(A1) & "-"&"0 Uhr";STUNDE(A1) & "-"&STUNDE(A1)+1& " Uhr")

sonst schreibt die Formel 23-24.

Gruß

chris


  

Betrifft: AW: AW:kleine Nachbesserung von: UweD
Geschrieben am: 01.07.2008 14:01:44

Hallo Chris, hallo Andi


richtig wäre sogar 23-24 Uhr


0 Uhr fängt ja auch erst ganz kurz hinter 24 Uhr an... :-)

Gruß UweD


  

Betrifft: AW: AW:@UweD von: Chris
Geschrieben am: 01.07.2008 14:03:56

Servus UweD,

that's right, but...

er wollte ja nun mal 23-0 Uhr haben.

Gruß

Chris


  

Betrifft: AW: AW:@UweD von: Andi
Geschrieben am: 01.07.2008 14:24:51

Hallo Chris, Hallo UweD,

habt beide vielen Dank für Euren Input!
Manche Dinge können so einfach sein...

Auch dafür: 23-24h! macht wirklich viel mehr Sinn!!!

Vielen Dank und beste Grüße
Andi


  

Betrifft: AW: Uhrzeitangabe auswerten (Zeitspanne) von: UweD
Geschrieben am: 01.07.2008 13:40:50

Hallo

reicht das??

 
 E
107:12:00
27-8 Uhr
Formeln der Tabelle
E2 : =STUNDE(E1)&"-"&STUNDE(E1)+1&" Uhr"
 




oder soll tatsächlich aus der Tabelle gewählt werden?

Wenn ja, dürfen die Zeiten auch in 2 benachbarten Zellen getrennt stehen? z.B. in A1 und B1???


Gruß UweD


  

Betrifft: AW: Uhrzeitangabe auswerten (Zeitspanne) von: UweD
Geschrieben am: 01.07.2008 13:59:56

Hier noch die andere Lösung

bei der 2. Lösung kannst du die Grenzen auch unterschiedlich wählen...

 
 ABCD
100:0001:00 12:12:00
201:0002:00 12:00-13:00 Uhr
302:0003:00  
403:0004:00  
504:0005:00  
605:0006:00  
706:0007:00  
807:0008:00  
908:0009:00  
1009:0010:00  
1110:0011:00  
1211:0012:00  
1312:0013:00  
1413:0014:00  
1514:0015:00  
1615:0016:00  
1716:0017:00  
1817:0018:00  
1918:0019:00  
2019:0020:00  
2120:0021:00  
2221:0022:00  
2322:0023:00  
2423:0024:00  
Formeln der Tabelle
D2 : =TEXT(SVERWEIS(D1;A:B;1;1); "hh:mm")&"-"&TEXT(SVERWEIS(D1;A:B;2;1); "hh:mm") &" Uhr"
 
 
 FGHI
100:0001:00 04:15:00
201:0002:00 04:00-12:00 Uhr
302:0003:00  
403:0004:00  
504:0012:00  
612:0013:00  
713:0014:00  
814:0015:00  
915:0016:00  
1016:0022:00  
1122:0023:00  
1223:0024:00  
Formeln der Tabelle
I2 : =TEXT(SVERWEIS(I1;F:G;1;1); "hh:mm")&"-"&TEXT(SVERWEIS(I1;F:G;2;1); "hh:mm") &" Uhr"
 




  

Betrifft: AW: habe die [Klammern] um hh vergessen von: UweD
Geschrieben am: 01.07.2008 14:04:23

=TEXT(SVERWEIS(I1;F:G;1;1);"hh:mm")&"-"&TEXT(SVERWEIS(I1;F:G;2;1);"[hh]:mm") &" Uhr"


  

Betrifft: AW: Uhrzeitangabe auswerten (Zeitspanne) von: Erich G.
Geschrieben am: 01.07.2008 13:48:28

Hallo Andi,
oder so?

 AB
107:11:007-8 Uhr
223:15:2023-0 Uhr

Formeln der Tabelle
ZelleFormel
B1=STUNDE(A1) & "-"&REST(STUNDE(A1)+1;24)& " Uhr"
B2=STUNDE(A2) & "-"&REST(STUNDE(A2)+1;24)& " Uhr"

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Uhrzeitangabe auswerten (Zeitspanne) von: Andi
Geschrieben am: 01.07.2008 14:29:37

Hallo Erich,

auch Dir vielen Dank für die Ausarbeitung.
Werde die Formeln auch für andere Auswertungen nutzen können.

Viele Grüße
Andi


 

Beiträge aus den Excel-Beispielen zum Thema "Uhrzeitangabe auswerten (Zeitspanne)"