Microsoft Excel

Herbers Excel/VBA-Archiv

summewenn

Betrifft: summewenn von: Andreas
Geschrieben am: 09.07.2008 11:47:59

Hallo zusammen,

ich habe folgendes Problem. in Zeile 9 stehen das Jahr und in Zeile 10 der Monat. Nun möchte ich, dass ich die Summe der in Zeile 12 stehenden Werte erhalte, wenn Zeile 9 und Zeile 10 mit dem Suchkriterien in B14 bzw. b15 übereinstimmen. Ich hoffe, ich habs halbwegs verständlich rübergebracht.

Folgende Formel hab ich schon probiert. Leider ohne Erfolg.
{=SUMME(WENN(($B9:$IV9=B15)+($B10:$IV10=B14);$B12:$IV12))}

Danke für jede Hilfe
Andy

  

Betrifft: nicht ... ; ... sondern ... *(B12:IV12)) (kwT) von: neopa
Geschrieben am: 09.07.2008 11:57:53

Gruß Werner
.. , - ...


  

Betrifft: AW: nicht ... ; ... sondern ... *(B12:IV12)) (kwT) von: Andreas
Geschrieben am: 09.07.2008 12:01:53

Hi Werner,

danke für Deine Antwort. Leider erhalte ich eine Fehlermeldung beim Bestätigen der Formel, wenn ich das
; durch * ersetze. Woran kann das liegen?

Danke und Gruß
Andy


  

Betrifft: sieh mal ... von: neopa
Geschrieben am: 09.07.2008 12:09:34

Hallo Anfdy,

... hier:

 BCDEFGHIJ
7   110     
8         
920072007200720072008200820082008 
10MaiMaiSeptemberDezemberMaiMaiSeptemberDezember 
11         
121020304050607080 
13         
14Mai        
152008        

Formeln der Tabelle
ZelleFormel
E7{=SUMME((B9:IV9=B15)*(B10:IV10=B14)*B12:IV12)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...



  

Betrifft: noch ein nicht ganz unwichtiger Hinweis ... von: neopa
Geschrieben am: 09.07.2008 12:23:04

Hallo Andy,

... wenn Du mit der ODER (bzw. +) -Funktion arbeitest, kann die Formel natürlich analog aufgebaut sein.

Jedoch beachte, dass dann Werte evtl. auch doppelt berechnet werden können. Ersetze z.B. mal in meinem Beispeil in B14="Juni" duch "Dezember", dann siehst Du was ich meine.

(Dabei ist es egal ob mit {Summe() } oder SUMMENPRODUKT() gearbeitet wird. Beides sind MATRIXFormeln. Da SUMMENPRODUKT() von Haus aus eine MATRIXFunktion ist, braucht man hier dem Formelteil bloß nicht gesondert mitzuteilen, das der "innere" Formelteil entsprechend auch so ausgewertet werden soll)

 BCDEFGHI
7   160    
8        
920072007200720072008200820082008
10MaiMaiSeptemberDezemberMaiJuniSeptemberDezember
11        
121020304050607080
13        
14Juni       
152007       

Formeln der Tabelle
ZelleFormel
E7{=SUMME(((B9:IV9=B15)+(B10:IV10=B14))*B12:IV12)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: AW: summewenn von: David
Geschrieben am: 09.07.2008 12:04:15

Hi.

Mit Summenprodukt kannst du ohne Matrix-Formel arbeiten, z. Bsp. so:

https://www.herber.de/bbs/user/53682.xls

Gruß

David


  

Betrifft: AW: summewenn von: Andreas
Geschrieben am: 09.07.2008 12:18:55

Hi David,

leider bekomme ich als Ergebnis eine 0, obwohl es ein Ergebnis geben müßte.
Hab die Datei mal abgelegt: https://www.herber.de/bbs/user/53683.xls

Gruß Andreas


  

Betrifft: AW: Texte und Zahlen von: Erich G.
Geschrieben am: 09.07.2008 12:47:12

Hi Andreas,
mit deinen Daten gibt es ein Problem:

In den Zeilen 2 und 3 (KW und Jahr) stehen nur Texte, keine Zahlen.

Der Vergleich der Jahre in Zeile 9 mit den Einträgen in Zeile 3 ergibt deshalb immer "ungleich",
und dann kommt 0 raus.

Du siehst, das in den Zeilen 2 und 3 Texte stehen, wenn du in diesen Zeilen die horizontale Ausrichtung
auf Standard stellst. Die Texte werden dann linksbündig dargestellt.

Eine andere Möglichkeit: Formatier doch mal alle Zellen in Spalte D mit 2 Nachkommastellen.
In Zeile 2 und 3 wird sich nichts ändern, die Texte werden unverändert angezeigt.

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Texte und Zahlen von: Andreas
Geschrieben am: 09.07.2008 12:55:31

Hallo Erich,

danke für Deine Antwort. Hast Du einen Lösungsansatz für mich. Ich hab nun alle "Texte" umformatiert, aber es ändert sich am Ergebnis nichts.

LG Andreas


  

Betrifft: AW: Texte und Zahlen von: Erich G.
Geschrieben am: 09.07.2008 17:54:39

Hi Andreas,
durch Formatieren ändern sich die Werte nicht - Texte bleiben Texte.
Das hatte ich doch auch geschrieben:
"In Zeile 2 und 3 wird sich nichts ändern, die Texte werden unverändert angezeigt."

Bern hat schon geschrieben, wie du aus den Jahrestexten Jahreszahlen machen kannst.

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: summewenn von: David
Geschrieben am: 09.07.2008 13:49:55

vielleicht solltest du mal darauf achten, Äpfel nicht mit Birnen zu vergleichen:

du hast in B15 stehen:

=SUMMENPRODUKT((Jahr=B$8)*(Monat=B$9)*Wert)

B8 ist aber der Monat und B9 das Jahr, wenn du die beiden vertauschst, funzt die Formel auch!

Gruß

David


  

Betrifft: AW: summewenn von: Andreas
Geschrieben am: 09.07.2008 16:43:37

Hi David,

Du hast natürlich Recht. Aber selbst wenn ich Monat und Jahr tausche, ergibt sich bei mir immer noch als Ergebnis eine "0". Anbei das Beispiel: https://www.herber.de/bbs/user/53694.xls

Gruß Andreas


  

Betrifft: AW: summewenn von: Bernd
Geschrieben am: 09.07.2008 17:29:18

Hallo, Andreas!

In Deiner Datei sind die Jahres"zahlen" in Zeile 3 keine Zahlen!!! Nimmst Du die Formatierung (Ausrichtung mittig) heraus, stehen diese links ... Zahlen stehen unformatiert aber rechts in der Zelle.

In einer leeren Zelle trage eine 1 ein. Kopiere diese 1 und markiere dann Deine Jahres"zahlen"; rechte Maustaste und "Inhalte einfügen ..." anklicken; im sich öffnenden Fenster die Option "Multiplizieren" an klicken.

Jetzt sollte es funktionieren.

Gruß Bernd


  

Betrifft: AW: summewenn von: Andreas
Geschrieben am: 09.07.2008 19:14:57

Bernd, das war der richtige Tipp. Ich danke Dir. Es hat funktioniert.

LG Andreas


  

Betrifft: AW: summewenn von: Erich G.
Geschrieben am: 09.07.2008 12:06:02

Hallo Andreas,
hier 3 Möglichkeiten:

 BCDEFG
9200320052008200920082008
10222223
11      
12110100100010000100000
13      
142 101001010010100 
152008     

Formeln der Tabelle
ZelleFormel
D14=SUMMENPRODUKT((B9:IV9=B15)*(B10:IV10=B14)*B12:IV12)
E14{=SUMME(WENN(($B9:$IV9=B15)*($B10:$IV10=B14); $B12:$IV12))}
F14{=SUMME((B9:IV9=B15)*(B10:IV10=B14)*B12:IV12)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: summewenn von: Andreas
Geschrieben am: 09.07.2008 12:44:24

Hallo Erich,

leider erhalte ich auch hier jeweils nur die "0".

LG Andreas


  

Betrifft: AW: Ein * statt ein + von: Erich G.
Geschrieben am: 09.07.2008 12:17:21

Hi Andreas,
das Problem war nicht das Semikolon, sondern das "+" - das ergäbe ein ODER.

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Ein * statt ein + von: Andreas
Geschrieben am: 09.07.2008 12:42:10

Hallo Erich,

wenn ich anstatt des + ein * eingebe, dann ergibt das Ergebnis eine 0, obwohl ein Wert erscheinen müßte.

LG Andreas


 

Beiträge aus den Excel-Beispielen zum Thema "summewenn"