Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen wenn Frage | Herbers Excel-Forum


Betrifft: Zählen wenn Frage von: KlausK
Geschrieben am: 15.10.2008 17:10:43

Guten Abend,

in einer Tabelle sind Funkrufnamen von Fahrzeugen versorgt und sollen gezählt werden. Problem für mich besteht darin, dass die Funkrufnamen wie folgt aufgebaut sind 20-81-1, 20-81-2, 20-84-6 usw. Es sollen nun gezählt werden, wieviel Fahrzeuge mit der Kennung 81 bzw 84 (in diesem Beispiel) eingetragen sind. Kann man auch mit Platzhaltern zählen ?

Vielen Dank und viele Grüße

Klaus

  

Betrifft: =SUMMENPRODUKT((TEIL(A1:A99;4;2)="81")*1) von: WF
Geschrieben am: 15.10.2008 17:17:53

.


  

Betrifft: AW: Zählen wenn Frage von: Rudi Maintaire
Geschrieben am: 15.10.2008 17:18:34

Hallo,

Kann man auch mit Platzhaltern zählen ?


sicherlich.

=ZÄHLENWENN(A2:A100;"*81*")

Gruß
Rudi


  

Betrifft: Vielen Dank an Euch o.T. von: KlausK
Geschrieben am: 15.10.2008 17:35:03




  

Betrifft: AW: Zählen wenn Frage von: FP
Geschrieben am: 16.10.2008 09:54:54

Hallo Klaus,

wenn die 81 immer an den Positionen 4 und 5 steht:

=ZÄHLENWENN("???81*";A:A)

Deine Kennungen stehen in diesem Fall in Spalte A

Servus aus dem Salzkammergut
Franz


  

Betrifft: Upps von: FP
Geschrieben am: 16.10.2008 09:56:42

Hallo Klaus,

sehr peinlich: natürlich muss es so heissen

=ZÄHLENWENN(A:A;"???81*")

Aber wirklich so - also mit den 3 Fragezeichen vorangestellt und nicht mit einem *, denn dann dürfte 81 irgendwo stehen...

Servus aus dem Salzkammergut
Franz