Microsoft Excel

Herbers Excel/VBA-Archiv

Zeitstrahl automatisch generieren | Herbers Excel-Forum


Betrifft: Zeitstrahl automatisch generieren von: Alexander
Geschrieben am: 20.10.2008 17:03:31

Hallo,

ich habe eine Tabelle mit Aktivitäten. Die Aktivitäten sind nochmals in Sub-aktivitäten heruntergebrochen und diese einer generischen Zeitlinie zugeordnet. Der Startzeitpunkt für jede Aktivität ist referenziert. Ich möchte die Aktivitäten nun auf einen Zeitstrahl automatisch verteilen.

Schwer zu erklären, daher ein kleines Beispiel.

https://www.herber.de/bbs/user/56145.xls

Kann mir hier jemand helfen?

Danke im Voraus!

Alexander

  

Betrifft: Gantt Diagramm von: Beate Schmitz
Geschrieben am: 20.10.2008 17:34:02

Hallo Alexander,

Guckst Du: Diagramm - speziell - Gantt Diagramm Projektverfolgung (1)

Guckst Du: Diagramm - speziell - Gantt Diagramm Projektverfolgung (2)

Gruß,
Beate


  

Betrifft: AW: Zeitstrahl automatisch generieren von: Erich G.
Geschrieben am: 20.10.2008 17:46:11

Hallo Alexander,
eine Möglichkeit:

 ABCDEFGHIJK
12AktM1M2M3M4M5M6M7M8M9M10
13AKT 1PREPEXECEXECCLO      
14AKT 2    PREPPREPEXECCLO  
15AKT 3      PREPEXECCLOCLO

Formeln der Tabelle
ZelleFormel
B13=WENN((SPALTE()<=$B6)+(SPALTE()>$B6+4); "";INDEX($B2:$K2;SPALTE()-$B6))
C13=WENN((SPALTE()<=$B6)+(SPALTE()>$B6+4); "";INDEX($B2:$K2;SPALTE()-$B6))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Zeitstrahl - Korrektur von: Erich G.
Geschrieben am: 20.10.2008 17:51:30

Hallo Alexander,
die Formel ging noch von genau 4 Einträgen aus. Das hier ist variabler:

 ABCDEFGHIJK
12AktM1M2M3M4M5M6M7M8M9M10
13AKT 1PREPEXECEXECCLO      
14AKT 2    PREPPREPEXECCLO  
15AKT 3      PREPEXECCLOCLO

Formeln der Tabelle
ZelleFormel
B13=WENN((SPALTE()<=$B6)+(SPALTE()>$B6+ANZAHL2($B2:$K2)); "";INDEX($B2:$K2;SPALTE()-$B6))
C13=WENN((SPALTE()<=$B6)+(SPALTE()>$B6+ANZAHL2($B2:$K2)); "";INDEX($B2:$K2;SPALTE()-$B6))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


Beiträge aus den Excel-Beispielen zum Thema "Zeitstrahl automatisch generieren"