Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Komplexe Suche nach Zuständigkeiten

Komplexe Suche nach Zuständigkeiten
Mat
Hallo Leute,
ich bräuchte Hilfe bei einer komplexen Suche/Abfrage. Ich habe eine Tabelle mit Zuständigkeitsbereichen. Über die Werte "Bezeichnung, Richtung und Bereich soll als Ergebnis der Index erscheinen. Die größte Schwierigkeit besteht darin, dass der Bereich aus Werten "von" und "bis" besteht.
Ich habe mal eine Beispielmappe hochgeladen. https://www.herber.de/bbs/user/65743.xls
Ich bin gespannt auf Eure Lösungsvorschläge.
Viele Grüße
Mat

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
Lösung per SUMMENPRODUKT()
10.11.2009 20:46:17
NoNet
Hallo Mat,
so "komplex" ist das gar nicht, das lässt sich sehr einfach per SUMMENPRODUKT() lösen, siehe Beispiel :
GHIJ
1
2
3

Funktionen der Tabelle :
Zelle Formel 
J2   =SUMMENPRODUKT(($B$4:$B$15=G2)*($C$4:$C$15=H2)*($D$4:$D$15<=I2)*($E$4:$E$15>=I2)*($A$4:$A$15)
J3   =SUMMENPRODUKT(($B$4:$B$15=G3)*($C$4:$C$15=H3)*($D$4:$D$15<=I3)*($E$4:$E$15>=I3)*($A$4:$A$15)

Gruß,NoNet
Anzeige
AW: Komplexe Suche nach Zuständigkeiten
10.11.2009 20:46:38
Josef
Hallo Mat,
http://www.excelformeln.de/formeln.html?welcher=34
Tabelle1

 ABCDE
1Datenbank Beispiel
2indexBezeichnungRichtungBereich
3vonbis
41B19a10,520,8
52B19d10,520,8
63B19a20,930
74B19d20,930
85B50a115,3
96B50d115,3
107B50a2034
118B50d2034
129B55a1020
1310B55d1020
1411B55a2133,5
1512B55d2133,5
16     
29     
30Abfrage 
31BezeichnungRichtungPositionErgebnis 
32B19d11,32 

Formeln der Tabelle
ZelleFormel
D32{=INDEX(A4:A15;KKLEINSTE(WENN((B4:B15=A32)*(C4:C15=B32)*(D4:D15<=C32)*(E4:E15>=C32); ZEILE(1:12)); 1))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp

Anzeige
AW: Komplexe Suche nach Zuständigkeiten
10.11.2009 21:08:26
Mat
Hallo ihr Beiden,
danke für die Formeln. Sind beide genau was ich suche. Ich werde mal testen mit welcher ich weitenmachen werde.
Bis Bald
Mat
Wenn in Spalte A Zahlen stehen...
10.11.2009 21:16:50
NoNet
Hey Mat,
wenn in Spalte A garantiert nur ZAHLEN stehen, ist meine Funktion vermutlich etwas einfacher (auch bzgl. der Eingabe), falls in Spalte A jedoch evtl. auch andere Werte außer ZAHLEN stehen (können), funktioniert meine Lösung nicht mehr, dann ist Sepps Vorschlag der bessere. Vielleicht hilft Dir das ein wenig ?
Gruß, NoNet
AW: Wenn in Spalte A Zahlen stehen...
10.11.2009 21:34:07
Mat
Hallo NoNet,
danke für den zusätzlichen Hinweis. Ich bin am überlegen ob ich die Spalte A einen Hyperlink setze mit dem ich die zuständige Adresse aufrufen kann.
Gruß Mat
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige