HERBERS Excel-Forum - das Archiv
Datensätze durch Zahlen gruppieren
Joachim

Hallo,
Ich habe in einem Sheet Datensätze, wo es immer ein Hauptdatensatz gibt und dazu Sub-Datensätze.
In einer Spalte möchte ich die Datensätze mit Ziffern gruppieren, damit ich schneller sehen kann was zusammen gehört.
ich habe hier ein Beispiel wie ich mir das vorstelle.
https://www.herber.de/bbs/user/66043.xls
Wenn möglich bitte per Makro, Danke
Gruss
Joachim

AW: Datensätze durch Zahlen gruppieren
Andre´

Hallo Joachim,
Bsp.: ohne Makro
Schreibe in K6 folgende Formel:
=ZÄHLENWENN($A$6:A6;"Bestellung")
und runter kopieren.
MFG Andre
AMit oder ohne Makro
Matthias5

Hallo Joachim,
anbei le eine Lösung mit und ohne Makro: https://www.herber.de/bbs/user/66045.xls
Gruß,
Matthias
AW: AMit oder ohne Makro
robert

hi,
vielleicht so ?
gruß
robert
Option Explicit
Sub tt()
Dim lz As Long
Dim i%, x%
x = 1
lz = Cells(Rows.Count, 1).End(xlUp).Row
For i = 6 To lz
If Cells(i, 1) = "Bestellung" Then
Cells(i, 11) = x
x = x + 1
Else
Cells(i, 11) = x - 1
End If
Next i
End Sub

Danke Euch drei für die Hilfe :-) owT
Joachim