Microsoft Excel

Herbers Excel/VBA-Archiv

Datensätze durch Zahlen gruppieren | Herbers Excel-Forum


Betrifft: Datensätze durch Zahlen gruppieren von: Joachim
Geschrieben am: 19.11.2009 09:18:01

Hallo,

Ich habe in einem Sheet Datensätze, wo es immer ein Hauptdatensatz gibt und dazu Sub-Datensätze.
In einer Spalte möchte ich die Datensätze mit Ziffern gruppieren, damit ich schneller sehen kann was zusammen gehört.

ich habe hier ein Beispiel wie ich mir das vorstelle.

https://www.herber.de/bbs/user/66043.xls

Wenn möglich bitte per Makro, Danke

Gruss
Joachim

  

Betrifft: AW: Datensätze durch Zahlen gruppieren von: Andre´
Geschrieben am: 19.11.2009 09:53:22

Hallo Joachim,

Bsp.: ohne Makro

Schreibe in K6 folgende Formel:

=ZÄHLENWENN($A$6:A6;"Bestellung")


und runter kopieren.

MFG Andre


  

Betrifft: AMit oder ohne Makro von: Matthias5
Geschrieben am: 19.11.2009 09:55:16

Hallo Joachim,

anbei le eine Lösung mit und ohne Makro: https://www.herber.de/bbs/user/66045.xls

Gruß,
Matthias


  

Betrifft: AW: AMit oder ohne Makro von: robert
Geschrieben am: 19.11.2009 09:57:09

hi,

vielleicht so ?

gruß
robert

Option Explicit

Sub tt()
Dim lz As Long
Dim i%, x%
x = 1
lz = Cells(Rows.Count, 1).End(xlUp).Row
For i = 6 To lz
If Cells(i, 1) = "Bestellung" Then
Cells(i, 11) = x
x = x + 1
Else
Cells(i, 11) = x - 1
End If
Next i
End Sub



  

Betrifft: Danke Euch drei für die Hilfe :-) owT von: Joachim
Geschrieben am: 19.11.2009 14:50:47




Beiträge aus den Excel-Beispielen zum Thema "Datensätze durch Zahlen gruppieren"