Microsoft Excel

Herbers Excel/VBA-Archiv

Zeitenrechnung | Herbers Excel-Forum


Betrifft: Zeitenrechnung von: Ralf
Geschrieben am: 26.11.2009 20:07:24

Hallo Forum,

ich habe zur Gaudi folgende Datei kreiert:
https://www.herber.de/bbs/user/66215.xls

Für mich sind nun folgende Dinge nicht lösbar:
1. Kann ich die Jahreszahl in J2 automatisch aus der Zelle A1 befüllen?
2. In den Zellen A10 und A12 gibt es ein Problem mit der Darstellung der Zeit aus A9 und A11 im Dezimalformat. Die Zellen sind meines erachtens richtig formatiert.
3. Für weitere Spaßberechnungen und Anregungen/Verbesserungen zu diesem Thema auf dem Tabellenblatt bin ich jederzeit zu haben.

Vielen Dank im voraus für Eure Mitarbeit.

Gruß

Ralf

  

Betrifft: AW: Zeitenrechnung von: IngGi
Geschrieben am: 26.11.2009 20:56:15

Hallo Ralf,

zu 1.:

Das geht mit der Formel =JAHR(A1)

zu 2.:

Die Formel in A9 muss lauten: =A4-ABRUNDEN(A4;0)-A3-A7

Grund: Die Funktion =JETZT() in Zelle A4 liefert nicht nur die Uhrzeit, sondern Datum und Uhrzeit. Da du nur auf die Uhrzeit abzielst, musst du den Vorkommaanteil der Zelle A4 abziehen (der Vorkommaanteil ergibt das Datum und der Nachkommaanteil die Uhrzeit).

Gruß Ingolf


  

Betrifft: AW: Zeitenrechnung von: Ralf
Geschrieben am: 26.11.2009 21:24:10

Hallo Ingolf,

zu 1.):
Prima, das passt.
zu 2.):
Da habe ich nun die Formel =WENN((A4-ABRUNDEN(A4;0)-A3-A7)>10;A5;(A4-ABRUNDEN(A4;0)-A3-A7))
geschrieben, damit nicht nach feierabend "Ungenauigkeiten" entstehen.
Diese Formel funktioniert aber leider nicht. Wenn der Wert in A9 größer als z. B. 10 Stunden ist, soll dort der Wert 08:00:00 angezeigt werden.

Kannst Du mir da noch mal helfen?

Danke.

Gruß

Ralf


  

Betrifft: AW: Zeitenrechnung von: IngGi
Geschrieben am: 27.11.2009 09:13:36

Hallo Ralf,

die Formel muss so aussehen:

=WENN((A4-ABRUNDEN(A4;0)-A3-A7)>10/24;A5;(A4-ABRUNDEN(A4;0)-A3-A7))

Gruß Ingolf


  

Betrifft: AW: Zeitenrechnung von: Ralf
Geschrieben am: 27.11.2009 09:47:31

Hallo Ingolf,

prima, dass passt jetzt.
Danke für die Unterstützung.

Gruß

Ralf


  

Betrifft: AW: Zeitenrechnung 2007 von: hary
Geschrieben am: 26.11.2009 21:28:11

Nabend allemann
Was passiert bei 2007? wenn ich eine Uhrzeit 'groesser 24 eingebe wird das Datum mit eingetragen. Egal was fuern Format. Wo kann man das einstellen, dass wenn ich groesser 24 Std eingeben will auch groesser 24 Std. drinsteht. War doch vorher nicht so oder taeusche ich mich?
gruss hary


  

Betrifft: AW: Zeitenrechnung 2007 von: werni
Geschrieben am: 26.11.2009 21:30:47

Hallo Hary

Formatiere die Zelle mit [hh]:mm

Gruss Werner


  

Betrifft: jepp erledigt.... von: hary
Geschrieben am: 26.11.2009 21:39:04

Hallo Werner
.... Irrtum von mir, liegt am Schlafentzug durch Nachtarbeit.
Gruss hary