Microsoft Excel

Herbers Excel/VBA-Archiv

speziell gezählt | Herbers Excel-Forum


Betrifft: speziell gezählt von: Mike
Geschrieben am: 01.12.2009 16:16:29


Hey Cracks,

.. oder nach dem Motto "Hilfsspalte wieder los werden", denn wenn man mit Zählenwenn()-Kombinationen nach verschiedenen Test nicht ans Ziel kommt, versucht man es erstmals mit Hilfsspalten. Doch die möchte ich nun wieder los werden.

Berechnungen

 CJCKCL
4Rang  Interpret
511Snow Patrol
6     
7     
821Snow Patrol
9     
10     
1131Linkin Park
12     
13     
1441Xavier Naidoo
15     
16     
1751Reamonn
18     
19     
2061Del Amitri
2171Bird York
22     
2381Depeche Mode

verwendete Formeln
Zelle Formel
CJ5 =CH5
CK5 =WENN(CL5<>""; 1; "")
CL5 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH5;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH5;$DK$5:$DK$3223;0)))
CJ6 =WENN(CK6<>"";SUMME(CK$5:CK6); "")
CK6 =WENN(CL6<>""; 1; "")
CL6 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH6;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH6;$DK$5:$DK$3223;0)))
CJ7 =WENN(CK7<>"";SUMME(CK$5:CK7); "")
CK7 =WENN(CL7<>""; 1; "")
CL7 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH7;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH7;$DK$5:$DK$3223;0)))
CJ8 =WENN(CK8<>"";SUMME(CK$5:CK8); "")
CK8 =WENN(CL8<>""; 1; "")
CL8 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH8;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH8;$DK$5:$DK$3223;0)))
CJ9 =WENN(CK9<>"";SUMME(CK$5:CK9); "")
CK9 =WENN(CL9<>""; 1; "")
CL9 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH9;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH9;$DK$5:$DK$3223;0)))
CJ10 =WENN(CK10<>"";SUMME(CK$5:CK10); "")
CK10 =WENN(CL10<>""; 1; "")
CL10 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH10;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH10;$DK$5:$DK$3223;0)))
CJ11 =WENN(CK11<>"";SUMME(CK$5:CK11); "")
CK11 =WENN(CL11<>""; 1; "")
CL11 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH11;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH11;$DK$5:$DK$3223;0)))
CJ12 =WENN(CK12<>"";SUMME(CK$5:CK12); "")
CK12 =WENN(CL12<>""; 1; "")
CL12 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH12;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH12;$DK$5:$DK$3223;0)))
CJ13 =WENN(CK13<>"";SUMME(CK$5:CK13); "")
CK13 =WENN(CL13<>""; 1; "")
CL13 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH13;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH13;$DK$5:$DK$3223;0)))
CJ14 =WENN(CK14<>"";SUMME(CK$5:CK14); "")
CK14 =WENN(CL14<>""; 1; "")
CL14 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH14;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH14;$DK$5:$DK$3223;0)))
CJ15 =WENN(CK15<>"";SUMME(CK$5:CK15); "")
CK15 =WENN(CL15<>""; 1; "")
CL15 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH15;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH15;$DK$5:$DK$3223;0)))
CJ16 =WENN(CK16<>"";SUMME(CK$5:CK16); "")
CK16 =WENN(CL16<>""; 1; "")
CL16 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH16;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH16;$DK$5:$DK$3223;0)))
CJ17 =WENN(CK17<>"";SUMME(CK$5:CK17); "")
CK17 =WENN(CL17<>""; 1; "")
CL17 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH17;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH17;$DK$5:$DK$3223;0)))
CJ18 =WENN(CK18<>"";SUMME(CK$5:CK18); "")
CK18 =WENN(CL18<>""; 1; "")
CL18 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH18;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH18;$DK$5:$DK$3223;0)))
CJ19 =WENN(CK19<>"";SUMME(CK$5:CK19); "")
CK19 =WENN(CL19<>""; 1; "")
CL19 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH19;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH19;$DK$5:$DK$3223;0)))
CJ20 =WENN(CK20<>"";SUMME(CK$5:CK20); "")
CK20 =WENN(CL20<>""; 1; "")
CL20 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH20;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH20;$DK$5:$DK$3223;0)))
CJ21 =WENN(CK21<>"";SUMME(CK$5:CK21); "")
CK21 =WENN(CL21<>""; 1; "")
CL21 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH21;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH21;$DK$5:$DK$3223;0)))
CJ22 =WENN(CK22<>"";SUMME(CK$5:CK22); "")
CK22 =WENN(CL22<>""; 1; "")
CL22 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH22;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH22;$DK$5:$DK$3223;0)))
CJ23 =WENN(CK23<>"";SUMME(CK$5:CK23); "")
CK23 =WENN(CL23<>""; 1; "")
CL23 =WENN(INDEX(CZ$5:CZ$3223;VERGLEICH($CH23;$DK$5:$DK$3223;0))=0;"";INDEX(CZ$5:CZ$3223;VERGLEICH($CH23;$DK$5:$DK$3223;0)))

Tabellendarstellung in Foren Version 4.28



In CJ als Rang sollen jeweils hochgezählt werden. Wie kann ich dies noch verbessern?

Danke und Gruss,
Mike


Die

  

Betrifft: AW: speziell gezählt von: Rudi Maintaire
Geschrieben am: 01.12.2009 16:22:06

Hallo,
meinst du so?
=WENN(CL5<>"";MAX(CJ$4:CJ4)+1;"")

Gruß
Rudi


  

Betrifft: Brilliant!! .. speziell gezählt von: Mike
Geschrieben am: 01.12.2009 16:26:18


Hey Rudi,

das ist brilliant einfach! Super gelöst, besten Dank!

Gruss
Mike