Microsoft Excel

Herbers Excel/VBA-Archiv

Matrixformel | Herbers Excel-Forum


Betrifft: Matrixformel von: winnimom
Geschrieben am: 03.12.2009 08:20:55

Hallo Freaks
ich habe folgendes Problem : in Spalte A stehen jede Menge Datumsdaten. In Spalte B stehen normale Zahlenwerte. In Spalte C stehen die 12 Monate des Jahres und daneben in Spalte D zu den Monaten entsprechende Faktoren. Ich möchte nun per Matrixformel die jeweiligen Werte aus B mit dem jeweiligen Monatsfaktor malnehmen jenachdem welcher Monat in Spalte A steht (in den jeweiligen Zellen). An und für sich kein großes Problem - dachte ich. Meine Matrix-Formel in Spalte E lautet z.B. {=WENN(MONAT(A1)=MONAT($C$1:$C$12);B1*$D$1:$D$12;"")} - das verrückte ist, dass sie nur für den Januar funktioniert, ab den Februarzellen geht die Wenn-Abfrage in den Sonstfall !!!
Was mache ich verkehrt ???
Vielen Dank im Voraus
Winnimom

  

Betrifft: AW: Matrixformel von: ede
Geschrieben am: 03.12.2009 08:56:09

hallo ,
warum über matrixformel,
solle auch so funktionieren:

=SVERWEIS(MONAT(A2);$C$2:$D$13;2;0)*B2
gruss


Beiträge aus den Excel-Beispielen zum Thema "Matrixformel"