Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Userform
BildScreenshot zu Userform Userform-Seite mit Beispielarbeitsmappe aufrufen

Mir fehlt die Idee | Herbers Excel-Forum


Betrifft: Mir fehlt die Idee von: Einzel
Geschrieben am: 10.01.2010 10:38:13

Hallo,
suche ne bessere Lösung aber mir fehlt die Idee.
Und zwar habe ich mir ne Excel Mappe gestrickt mit verschiedenen Tabellenblättern (40 Stück),
Rechnung, Kunde, Rechnungsnummer, Rechnungsbeträge usw.
Nun habe ich dazu auch ein Titel-Tabellenblatt (Verwaltung).
Da habe ich die Verschiedenen Tabellenblätter über Hyperlinks verknüpft.
Funktioniert einwandrei.
Nun meine Frage.
Brauche ne Idee um diese Seite umzustellen, da sie mir so nicht mehr gefällt.
Keine komplette Lösung das will ich wohl erst :-) selbst probieren aber mir fehlt irgendwie
die Idee wie man es halt noch anders Lösen könnte.
Über ein Menü oder so??
Könnte mir jemand da weiterhelfen?
Danke
MfG
Stephan

  

Betrifft: wenn man Deine Tabelle so sieht ... von: Matthias L
Geschrieben am: 10.01.2010 10:45:28

Hallo

... fällt mir auch nix ein, außer sie völlig umzugestalten ;-)

Vielleicht hilt ja schon ein schick gestaltetes Formular.

Gruß Matthias


  

Betrifft: AW: Mir fehlt die Idee von: Hajo_Zi
Geschrieben am: 10.01.2010 10:45:36

Hallo Stephan,

was ist das Problem?
möchtest Du das Inhaltsverzeichnis automatisch erstellen?

vorhandene Tabellen

 ABCD
1DatumVeranstaltung
2Tabelle1!a1     
3Tabelle2!a1     
4Webabfrage!a1     
5!a1     
6       
7  Hi Holger,   
8       
9  hatte diese Frage auch grad in einem anderen Forum (anderer Fragesteller) so beantwortet:   
10       
11  Einfügen -> Namen -> Definieren/Festlegen, Name: x   
12  bezieht sich auf:   
13  =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())   
14       
15  In irgendeine Zelle jetzt diese Formel und runterkopieren:   
16  =WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))   
17       
18  Grüße Boris   
19       
20       
21  Formel runter ziehen falls Mehr Tabellen   

verbundene Zellen
B1:D1

verwendete Formeln
Zelle Formel
A2 =HYPERLINK("#" & WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31)) & "!A1";WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))&"!a1" )
A3 =HYPERLINK("#" & WENN(ZEILEN($1:2)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:2));FINDEN("]";INDEX(x;ZEILEN($1:2)))+1;31)) & "!A1";WENN(ZEILEN($1:2)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:2));FINDEN("]";INDEX(x;ZEILEN($1:2)))+1;31))&"!a1" )
A4 =HYPERLINK("#" & WENN(ZEILEN($1:3)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:3));FINDEN("]";INDEX(x;ZEILEN($1:3)))+1;31)) & "!A1";WENN(ZEILEN($1:3)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:3));FINDEN("]";INDEX(x;ZEILEN($1:3)))+1;31))&"!a1" )
B4 =WENN(ISTFEHLER(INDIREKT(A4&"!B4:D4"));"";INDIREKT(A4&"!B4:D4"))
A5 =HYPERLINK("#" & WENN(ZEILEN($1:4)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:4));FINDEN("]";INDEX(x;ZEILEN($1:4)))+1;31)) & "!A1";WENN(ZEILEN($1:4)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:4));FINDEN("]";INDEX(x;ZEILEN($1:4)))+1;31))&"!a1" )
B5 =WENN(ISTFEHLER(INDIREKT(A5&"!B4:D4"));"";INDIREKT(A5&"!B4:D4"))
A6 =HYPERLINK("#" & WENN(ZEILEN($1:5)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:5));FINDEN("]";INDEX(x;ZEILEN($1:5)))+1;31)) & "A1";WENN(ZEILEN($1:5)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:5));FINDEN("]";INDEX(x;ZEILEN($1:5)))+1;31)) )
B6 =WENN(ISTFEHLER(INDIREKT(A6&"!B4:D4"));"";INDIREKT(A6&"!B4:D4"))
C6 =WENN(ISTFEHLER(INDIREKT(A6&"!E4"));"";INDIREKT(A6&"!E4"))
D6 =WENN(ISTFEHLER(INDIREKT(A6&"!F4"));"";INDIREKT(A6&"!F4"))
D7 =WENN(ISTFEHLER(INDIREKT(A7&"!F4"));"";INDIREKT(A7&"!F4"))
D8 =WENN(ISTFEHLER(INDIREKT(A8&"!F4"));"";INDIREKT(A8&"!F4"))
D9 =WENN(ISTFEHLER(INDIREKT(A9&"!F4"));"";INDIREKT(A9&"!F4"))
D10 =WENN(ISTFEHLER(INDIREKT(A10&"!F4"));"";INDIREKT(A10&"!F4"))
D11 =WENN(ISTFEHLER(INDIREKT(A11&"!F4"));"";INDIREKT(A11&"!F4"))
D12 =WENN(ISTFEHLER(INDIREKT(A12&"!F4"));"";INDIREKT(A12&"!F4"))
D13 =WENN(ISTFEHLER(INDIREKT(A13&"!F4"));"";INDIREKT(A13&"!F4"))
D14 =WENN(ISTFEHLER(INDIREKT(A14&"!F4"));"";INDIREKT(A14&"!F4"))
D15 =WENN(ISTFEHLER(INDIREKT(A15&"!F4"));"";INDIREKT(A15&"!F4"))
D16 =WENN(ISTFEHLER(INDIREKT(A16&"!F4"));"";INDIREKT(A16&"!F4"))
D17 =WENN(ISTFEHLER(INDIREKT(A17&"!F4"));"";INDIREKT(A17&"!F4"))
D18 =WENN(ISTFEHLER(INDIREKT(A18&"!F4"));"";INDIREKT(A18&"!F4"))
A19 =WENN(ZEILEN($1:18)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:18));FINDEN("]";INDEX(x;ZEILEN($1:18)))+1;31))
B19 =WENN(ISTFEHLER(INDIREKT(A19&"!B4:D4"));"";INDIREKT(A19&"!B4:D4"))
C19 =WENN(ISTFEHLER(INDIREKT(A19&"!E4"));"";INDIREKT(A19&"!E4"))
D19 =WENN(ISTFEHLER(INDIREKT(A19&"!F4"));"";INDIREKT(A19&"!F4"))
A20 =WENN(ZEILEN($1:19)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:19));FINDEN("]";INDEX(x;ZEILEN($1:19)))+1;31))
B20 =WENN(ISTFEHLER(INDIREKT(A20&"!B4:D4"));"";INDIREKT(A20&"!B4:D4"))
C20 =WENN(ISTFEHLER(INDIREKT(A20&"!E4"));"";INDIREKT(A20&"!E4"))
D20 =WENN(ISTFEHLER(INDIREKT(A20&"!F4"));"";INDIREKT(A20&"!F4"))
A21 =WENN(ZEILEN($1:20)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:20));FINDEN("]";INDEX(x;ZEILEN($1:20)))+1;31))
C21 =WENN(ISTFEHLER(INDIREKT(A21&"!E4"));"";INDIREKT(A21&"!E4"))
D21 =WENN(ISTFEHLER(INDIREKT(A21&"!F4"));"";INDIREKT(A21&"!F4"))

definierte Namen
Name Bezieht sich auf Tabelle Z1S1-Formel
x=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT()) =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())

Tabellendarstellung in Foren Version 5.3



GrußformelHomepage


  

Betrifft: woher nimmst Du diese Daten? von: Matthias L
Geschrieben am: 10.01.2010 10:53:56

Hallo Hajo

In der Ausgangsfrage waren keine Daten bzw. keine Datei angehängt.
Wenns da schon ne Vorgeschichte gibt,
ist das nicht gerade schön das Stephan diese nicht erwähnt.

Findest Du nicht auch ?
Oder habe ich Deinen Beitrag völlig mißverstanden?


Gruß Matthias


  

Betrifft: AW: woher nimmst Du diese Daten? von: Hajo_Zi
Geschrieben am: 10.01.2010 10:57:15

Hallo Matthias,

in minem Bitrag wird nur erklärt wie man automatisch ein Inhaltsverzeichnis erstelt. Dafür habe ich eine meiner Dateien benutzt. Da dieser Vorschlag in jeder Datei geht.
Aus Deinem Beitrag hätte ich gelesen das Du die Datei schon hast und jetzt schreibst Du das Du sie nicht hast.

Gruß Hajo


  

Betrifft: das war ja mit Augenzwinkern ... von: Matthias L
Geschrieben am: 10.01.2010 11:03:15

Hallo Hajo

... ok, das mit Deinen Daten ist mir jetzt klar.

Ich hatte das so an Stephan geschrieben, weil er ja eben keine Datei bzw. kein Bild vom Layout zeigt.
Wie soll man denn da einen vernünftigen Vorschlag machen.

Danke für Deine Antwort
Gruß Matthias


  

Betrifft: AW: das war ja mit Augenzwinkern ... von: Einzel
Geschrieben am: 10.01.2010 12:28:10

Hi,
habe mal mein Beispiel angehängt.

https://www.herber.de/bbs/user/67110.xlsx

So sieht es momentan aus.
Vielleicht hilft versteht man jetzt was ich meine.
MfG
Stephan


  

Betrifft: AW: Was ist denn das Problem mit diesem Blatt? von: fcs
Geschrieben am: 10.01.2010 14:53:38

Hallo Stephan,

die Grundidee ein Tabellenblatt zur Steuerung der Arbeitsabläufe zu verwenden ist ja nicht verkehrt.

Das Ganze ist evtl ein bischen sehr grau auf hellgrau. Das wäre aber mit ein paar Formatierungen in Griff zu kriegen. Ich würde noch die Hauptmenü-Punkte durch Fenster fixieren permanent oben im Fenster anzeigen.

Der radikale Umbruch wäre das Ganze auf ein Userformular umzustellen mit Multipageelement zur Anwahl der verschiedenen Hauptfunktionen bzw. jeweils ein Userform für jede Hauptfunktion. Das ist aber mit einigem Programmieraufwand verbunden.

Ansonsten gilt auch heute noch: Warum ein funktionierendes System umschmeissen?

Welche Funktionalitäten sind denn z.Zt, so, dass Änderungsbedarf besteht bzw. notwendig ist?

Gruß
Franz


  

Betrifft: AW: Was ist denn das Problem mit diesem Blatt? von: Einzel
Geschrieben am: 10.01.2010 20:15:03

Nun ja Stillstand ist Rückstand. Ich habe halt seid ca 2003 an dieser Mappe gearbeitet, damals kannte ich noch kein VBA deshalb ist sie so gewachsen.
Was ist denn mit Multipageelementen gemein?

Gruß
Stephan


  

Betrifft: AW: Was ist denn das Problem mit diesem Blatt? von: fcs
Geschrieben am: 11.01.2010 05:40:39

Hallo Stephan,

ein Multipage ist ein Steuerelement in einem Userformular. Es ermöglicht mehrere register auf einer Seite anzulegen, ähnlich wie anderen Excel Dialogfenstern mit mehreren Registern.

Ich hab dir hier mal eine eine kleine Beispieldatei angelegt, wie man deine Menues in ein Userform umbauen könnte. Einige der hinterlegten Aktionen dürften auch bei dir schon reibungslos funktionieren. Mit dem Öffnen der Datei (vorausgesetzt Makros werden aktiviert/sind aktiv) wird ein kleines Userform rechts oben eingeblendet, das ständig angezeigt bleibt. In diesem UF ist eine Schaltfläche mit der bei Bedarf das Hauptmenü eingeblendet werden kann.

Da Hyperlinks in Userforms nicht so einfach anzulegen sind (jedenfalls weiss ich im Moment nicht wie) ist etwas mehr Programmieraufwand nötig, um die den Schaltflächen zugeordneten Aktionen festzulegen. Dafür kann man natürlich auch entsprechend komplexere Aktionen definieren, wenn gewünscht.

Gruß
Franz
https://www.herber.de/bbs/user/67120.xlsm


  

Betrifft: AW: Was ist denn das Problem mit diesem Blatt? von: Einzel
Geschrieben am: 11.01.2010 19:27:06

Absolut gut. Das wäre ja mal was ganz anderes. erde ich gleich mal schauen was man damit noch so anfangen kann. Danke colle Idee.
MfG
Stephan