Microsoft Excel

Herbers Excel/VBA-Archiv

Formel = WENN(TEIL( | Herbers Excel-Forum


Betrifft: Formel = WENN(TEIL( von: Heinz H
Geschrieben am: 10.01.2010 10:00:17

Hallo Leute

Ich habe in L25 "Pflegeurlaub" und "Urlaub" und "Sonderurlaub" stehen.
Nun sollte in J25 wo die Formel steht, wenn in L25 das Wort "Urlaub"vorkommt das Ergebniss 0 stehen.

Der Fehler ist im Formelteil "WENN(TEIL(L25;6;6)="Urlaub";0;"

Könnte mir bitte jemand helfen.

Gruß
Heinz

WENN(TEIL(L25;6;6)="Urlaub";0;

=WENN(A25="";0;WENN(G25=H25:H25;0))+WENN(ISTFEHLER(VERGLEICH(A25;$W$64:$W$81;0));WENN(UND(C25=0; D25="";E25="";F25="";L25="");0;WENN(L25="Pflegefreistellung";0;WENN(L25="Krank";0;WENN(TEIL(L25;6;6) ="Urlaub";0;WENN(H25G25;H25-G25))))));0)

  

Betrifft: AW: Formel = WENN(TEIL( von: Reinhard
Geschrieben am: 10.01.2010 10:09:58

Hallo Heinz,

was soll Excel damit machen:

WENN(H25G25;H25-G25

Und welcher Fehler tritt denn auf?

Gruß
Reinhard


  

Betrifft: AW: Formel = WENN(TEIL( von: Ramses
Geschrieben am: 10.01.2010 10:11:36

Hallo

Probier mal

WENN(GROSS(RECHTS(L25);6))="URLAUB";0;Sonst-Anweisung

Gruss Rainer


  

Betrifft: AW: Formel = WENN(TEIL( von: Heinz H
Geschrieben am: 10.01.2010 10:19:45

Hallo Rainer & Reinhard

Ich möchte sobald das Wortteil "Urlaub" vorkommt das 0 els Ergebniss steht.

Es geht darum das ich nicht drei mal schreiben muss:

WENN(L25="Urlaub";0 WENN(L25="Sonderurlaub";0 Wenn(L25="Pflegeurlaub";0

Gruß
Heinz


  

Betrifft: AW: Formel = WENN(TEIL( von: Hajo_Zi
Geschrieben am: 10.01.2010 10:23:58

Hallo Heinz,


Tabelle2

 AB
16Sonderurlaubenthalten
17  nicht enthalten

verwendete Formeln
Zelle Formel
B16 =WENN(ISTZAHL(FINDEN("URLAUB";GROSS(A16)));"enthalten";"nicht enthalten")
B17 =WENN(ISTZAHL(FINDEN("URLAUB";GROSS(A17)));"enthalten";"nicht enthalten")

Tabellendarstellung in Foren Version 5.3



GrußformelHomepage


  

Betrifft: H25G25 gibt es nicht ! von: WF
Geschrieben am: 10.01.2010 10:17:14

.


  

Betrifft: AW: H25G25 gibt es nicht ! von: Heinz H
Geschrieben am: 10.01.2010 10:31:30

Habe mal die original Formel eingefügt.
Heinz


01.01.1979

 J
25 

Formeln der Tabelle
ZelleFormel
J25=WENN(A25="";0;WENN(G25=H25:H25;0))+WENN(ISTFEHLER(VERGLEICH(A25;$W$64:$W$81;0)); WENN(UND(C25=0;D25="";E25="";F25="";L25=""); 0;WENN(L25="Pflegefreistellung";0;WENN(L25="Krank";0;WENN(L25="Urlaub";0;WENN(H25<G25;H25-G25;WENN(H25>G25;H25-G25)))))); 0)




  

Betrifft: AW: H25G25 gibt es nicht ! von: hary
Geschrieben am: 10.01.2010 10:33:18

Hallo Heinz

Tabellenblattname: Tabelle1

 

A

B

C

1

Urlaub

 

0

2

Sonderurlaub

 

0

3

Pflegeurlaub

 

0

4

urlaubpflege

 

0

5

pflege

 

1


Benutzte Formeln:
C1: =WENN(ISTFEHLER(SUCHEN("urlaub";A1));1;0)
C2: =WENN(ISTFEHLER(SUCHEN("urlaub";A2));1;0)
C3: =WENN(ISTFEHLER(SUCHEN("urlaub";A3));1;0)
C4: =WENN(ISTFEHLER(SUCHEN("urlaub";A4));1;0)
C5: =WENN(ISTFEHLER(SUCHEN("urlaub";A5));1;0)
gruss hary


  

Betrifft: AW: H25G25 gibt es nicht ! von: Heinz H
Geschrieben am: 10.01.2010 10:41:46

Hallo Hary

Es geht um WENN(L25="Urlaub";0; in der Formel. Damit ich nicht 3 mal die Abfrage mit "urlaub" machen muss.

Gruß
Heinz


  

Betrifft: AW: H25G25 gibt es nicht ! von: Hajo_Zi
Geschrieben am: 10.01.2010 10:47:04

Hallo Heinz,

einfach die Vorschläge testen. Das hilft meist schon.

Gruß Hajo


  

Betrifft: AW: H25G25 gibt es nicht ! von: Heinz H
Geschrieben am: 10.01.2010 10:49:17

Hallo Hajo

Habe es jetzt in J7 getestet. (Siehe Formel) es sollte 0 als Summe rauskommen.

Gruß
Heinz


01.01.1979

 J
7-7,50

Formeln der Tabelle
ZelleFormel
J7=WENN(A7="";0;WENN(G7=H7:H7;0))+WENN(ISTFEHLER(VERGLEICH(A7;$W$64:$W$81;0)); WENN(UND(C7=0;D7="";E7="";F7="";L7=""); 0;WENN(L7="Pflegefreistellung";0;WENN(L7="Krank";0;WENN(ISTFEHLER(SUCHEN("urlaub";L7)); 0;WENN(H7<G7;H7-G7;WENN(H7>G7;H7-G7)))))); 0)


01.01.1979

 L
7Bildungsurlaub


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


  

Betrifft: AW: H25G25 gibt es nicht ! von: Hajo_Zi
Geschrieben am: 10.01.2010 10:51:11

Hallo Heinz,

die Formel hat keine ähnlichkeit mit der Formel von Hary und auch nicht mit meiner. Mit dem Vorschlag von Rainer habe ich das jetzt nich verglichen.

Gruß Hajo


  

Betrifft: Beispiel hochladen.... von: Ramses
Geschrieben am: 10.01.2010 10:57:18

Hallo

... oder du stellst auch den Rest der relevanten Tabelle dar.
Sonst ist keine Analyse möglich.

Gruss Rainer


  

Betrifft: AW: Beispiel hochladen.... von: Heinz H
Geschrieben am: 10.01.2010 11:04:58

Habe mal die Datei hochgeladen.

Beschreibung anbei.

Danke
Heinz

https://www.herber.de/bbs/user/67109.xls


  

Betrifft: AW: Beispiel hochladen.... von: Reinhard
Geschrieben am: 10.01.2010 11:18:20

Hallo Heinz,

anstatt:
...WENN(L25="Pflegefreistellung";0;WENN(L25="Krank";0;WENN(L25="Urlaub";0;WENN(H25G25;H25-G25)))))

...WENN(ODER(L25="Pflegefreistellung";L25="Krank";ISTFEHLER(FINDEN("URLAUB";GROSS(L25))>0));ABS( _
H25-G25);0)

Gruß
Reinhard


  

Betrifft: AW: Beispiel hochladen.... von: Heinz H
Geschrieben am: 10.01.2010 11:55:03

Hallo Reinhard

Das ist mir etwas zu hoch !!

Mit

...WENN(ODER(L25="Pflegefreistellung";L25="Krank";ISTFEHLER(FINDEN("URLAUB";GROSS(L25))>0));ABS( _
 _
H25-G25);0)
Wärst Du bitte so nett und könntest mir diese Formel in der hochgeladenen Datei in L25 einpflanzen ?

Gruß
Heinz


  

Betrifft: Hast du das ausprobiert ? von: Ramses
Geschrieben am: 10.01.2010 10:48:19

Hallo

Die Formel von mir, Hajo und WF machen doch genau das was du willst.
Warum probierst du es nicht einfach mal aus und baust das in Deine Formel ein !?

Gruss Rainer


  

Betrifft: AW: Danke an alle Helfer von: Heinz H
Geschrieben am: 10.01.2010 14:10:00

Hallo Leute



Erstmals recht herzlichen Dank für Eure Bemühungen,mir zu helfen.


Habe es nun so gelöst.

Habe in S88:S91 die Werte reingeschrieben.



=WENN(A6="";0;WENN(G6=H6:H6;0))+WENN(ISTFEHLER(VERGLEICH(A6;$W$64:$W$81;0));WENN(UND(C6=0;D6=""; E6="";F6="";L6="");0;WENN(ISTFEHLER(VERGLEICH(L6;$S$88:$S$91;0));WENN(H6G6; H6-G6) ))))


Gruß

Heinz


  

Betrifft: Das kann doch gar nicht funktionieren.... von: Ramses
Geschrieben am: 10.01.2010 14:18:26

Hallo

1. Es gibt keine Zelle "...WENN(H6G6; H6-G6) )))) ..."

2. Diese WENN-Anweisung ergibt grundsätzlich keinen Sinn.

3. Was bitte hat diese Formel nun mit "Urlaub" zu tun ?

Egal,... du wirst es schon wissen.

Gruss Rainer


  

Betrifft: AW: Das kann doch gar nicht funktionieren.... von: Heinz H
Geschrieben am: 10.01.2010 14:30:03

Hallo Rainer

Ich wollte nur das ich 3 zusätzliche WENN Abfragen mit "Urlaub" ,"Bildungsurlaub", "Sonderurlaub" in diese schon Mega Formel einfügen muss.


Danke Heinz

=WENN(A6="";0;WENN(G6=H6:H6;0))+WENN(ISTFEHLER(VERGLEICH(A6;$W$64:$W$81;0));WENN(UND(C6=0;D6=""; E6="";F6="";L6="");0;WENN(ISTFEHLER(VERGLEICH(L6;$S$88:$S$91;0));WENN(H6<G6;H6-G6;WENN(H6>G6; H6-G6)))))


  

Betrifft: AW: Das kann doch gar nicht funktionieren.... von: Reinhard
Geschrieben am: 10.01.2010 17:33:49

Hallo heinz,

die Gesamtformel lasse ich mal weg und nehme nur
WENN(H6G6; H6-G6)

Da ist ungeklärt (bzw. Excel klärt das schon *gg*) was bei H6=G6 geschehen soll.

Nimm, wie von mir gesagt:
Abs(H6-G6)
anstelle des Obigen

Gruß
Reinhard


  

Betrifft: AW: Das kann doch gar nicht funktionieren.... von: Heinz H
Geschrieben am: 10.01.2010 19:02:13

Hallo Rainer

Ich danke Dir für die Hartnäckigkeit mir zu helfen.

was bei H6=G6 geschehen soll.
H6 ist die tatsächlich geleistete Arbeitszeit
G6 ist soll Arbeitszeit
J6 soll die Plus oder Minus Stunden erechnen.

Stimmt nun die untere Formel ?

Danke Heinz


~f~=WENN(A6="";0;WENN(G6-H6:H6;0))+WENN(ISTFEHLER(VERGLEICH(A6;$W$64:$W$81;0));WENN(UND(C6=0;D6="";E6="";F6="";L6="");0;WENN(ISTFEHLER(VERGLEICH(L6;$S$88:$S$91;0));WENN(H6G6;H6-G6)))))~f~


  

Betrifft: AW: Das kann doch gar nicht funktionieren.... von: Reinhard
Geschrieben am: 10.01.2010 20:21:46

Hallo heinz,

tut mir leid, ich klink mich aus.

Dir wurde schon minimum 3mal gesagt daß WENN(H6G6; nicht geht.
Vieles andere auch.

Sorry, fühl mich veralbert.

Gruß
Reinhard


  

Betrifft: AW: Das kann doch gar nicht funktionieren.... von: Heinz H
Geschrieben am: 10.01.2010 20:48:30


Hallo Reinhard

Sorry aber beim hochladen der Formel kommt immer H6G6

Es steht aber
(H6>H6;H6-H6)

Ich weiss leider nicht woran es beim hochladen liegt.

Danke & Gruß
Heinz


  

Betrifft: Was du hier schreibst ist HTML und da... von: Luc:-?
Geschrieben am: 10.01.2010 23:33:55

...sind > und < Tags, Heinz!
Wenn du HWH's Benutzungshinweise gelesen hast, weißt du, was bei Fmln getan wdn kann.
3 Möglichkeiten:
1. HWH's Forumsfmlspezialtags verwenden ⇒ ~+f+~ (+ entfällt dabei), vor u.nach der Fml
2. Fml markieren und auf Button Zitat klicken bzw umgekehrt erst klicken und Fml dann zwischen die Tags schreiben — da steht dann auch der Cursor.
3. Diese Zeichen mit HTML-Namen maskieren — &+gt+; bzw &+lt+; (+ entfällt dabei) für >/<. Aber das scheinst du ja zu kennen! Was hindert dich also daran, das hier auch zu tun? Beim Kopieren ist es dann ohnehin wie angezeigt...
Gruß Luc :-?


  

Betrifft: AW: Was du hier schreibst ist HTML und da... von: Heinz H
Geschrieben am: 10.01.2010 23:45:11

Hallo Luc

Ich bin am Rande Wahnsinnig zu werden.

Bitte um Hilfe
Habe die Datei mal hochgeladen.
Es geht um die Spalte J6:J35

Hier soll die tatsächliche Arbeitszeit berechnet werden.

In A96:J100 stehen die normale Arbeitszeiten.
In S88:S91 steht wenn diese Zb in L6 vorkommt solte in J6 die Summe gleich null sein.

Wärst du bitte so Nett und hilfst mir weiter ?

Gruß
Heinz


https://www.herber.de/bbs/user/67117.xls


  

Betrifft: Das versteht wohl leider Keiner, sorry! orT von: Luc:-?
Geschrieben am: 11.01.2010 18:13:42

Gruß Luc :-?


  

Betrifft: AW: Das versteht wohl leider Keiner, sorry! orT von: Heinz H
Geschrieben am: 11.01.2010 20:37:24

Hallo Luc



Dennoch recht herzlichen DANK !!!



Gruß

Heinz


Beiträge aus den Excel-Beispielen zum Thema "Formel = WENN(TEIL("