Microsoft Excel

Herbers Excel/VBA-Archiv

automatisch Prozentwerte eintrgen | Herbers Excel-Forum


Betrifft: automatisch Prozentwerte eintrgen von: rudiflei
Geschrieben am: 10.01.2010 15:19:16

Kann jemand folgende Nuss knacken?

Im Feld mit dem Feldnamen: „MDIF“ steht ein Betrag in €
Aufgrund dieses Betrages soll Excel mir ins Feld mit dem Feldnamen: „MSP“
einen Prozentsatz nach folgender Vorgabe eintragen:

Bei einem positiven Wert von 0,00 bis 999999,99 =1,3% eintragen
Bei einem negativen Wert von -0,01bis -100,00 =1,1% eintragen
Bei einem negativen Wert von -100,01 bis -249,99 =1,0% eintragen
Bei einem negativen Wert von -250,00 bis -999999,99 =0,8% eintragen

Wenn möglich bitte zwei Lösungen anbieten:
1. WENN-Funktion
2. VBA

Danke

  

Betrifft: AW: automatisch Prozentwerte eintrgen von: Daniel
Geschrieben am: 10.01.2010 15:33:10

hi

schau dir mal die SVERWEIS-Funktion an, dann kannst du die Werte über eine Hilfstabelle zuweisen.
eine Beschreibung der SVERWEIS-Funktion findest du in der Hilfe oder hier:
http://www.online-excel.de/excel/singsel.php?f=9
die Wenn-Funktion ist in diesem Fall ungünstig, da die Formeln sehr aufwendig und unübersichtlich werden.
Gruß, Daniel


  

Betrifft: AW: automatisch Prozentwerte eintrgen von: Ramses
Geschrieben am: 10.01.2010 15:34:02

Hallo

meinst du so

Tabelle2

 ACDEFG
1MDIFMSP  WertSatz
221.30%  -999999.990.80%
3-11.10%  -249.991%
4-2401.00%  -1001.10%
5-3000.80%  01.30%
6    999999.991.30%
7      

Formeln der Tabelle
ZelleFormel
C2=SVERWEIS(A2;$F$2:$G$6;2;-1)
C3=SVERWEIS(A3;$F$2:$G$6;2;-1)
C4=SVERWEIS(A4;$F$2:$G$6;2;-1)
C5=SVERWEIS(A5;$F$2:$G$6;2;-1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruss Rainer


  

Betrifft: nix Hilfsspalte von: WF
Geschrieben am: 10.01.2010 15:52:12

Hi,

die Zahl steht in A1.

=VERWEIS(A1;{-999999999;-250;-100;0;9999999999};{0,8;1;1,1;1,3})

Salut WF


  

Betrifft: Wenn schon... von: Ramses
Geschrieben am: 10.01.2010 16:05:12

Hallo Walter

... dann so


=VERWEIS(A1;{-999999999;-250;-100;0;9999999999};{0,0008;1;0,011;0,013})

sonst klappt mit dem PROZENT nicht :-)
Trotzdem schön.

Gruss Rainer


  

Betrifft: AW: Wenn schon... von: rudiflei
Geschrieben am: 10.01.2010 17:44:43

funktioniert so aber nicht.
Trotzdem vielen Dank. Hast mich auf die richtige Spur gelenkt.


  

Betrifft: Wieso... von: Ramses
Geschrieben am: 10.01.2010 18:05:36

Hallo

sollte das nicht funktionieren ?

Tabelle1

 AB
7-80.011

Formeln der Tabelle
ZelleFormel
B7=VERWEIS(A7;{-999999999;-250;-100;0;9999999999};{0.0008;1;0.011;0.013})


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruss Rainer


  

Betrifft: 1 % ist 0,01 und nicht 1 von: WF
Geschrieben am: 10.01.2010 19:46:55

.


  

Betrifft: und: 0,8 % ist 0,008 und nicht 0,0008 von: WF
Geschrieben am: 10.01.2010 20:01:37

.


  

Betrifft: AW: nix Hilfsspalte von: rudiflei
Geschrieben am: 10.01.2010 16:07:25

ja das isses, schönen Dank an alle!
Bis auf ne winzige Kleinigkeit die ich mit der Darstellung von % in Excel öfters mal habe.

Ich habe das Feld in Prozent mit einer Kommastelle formatiert. Als Ergebnis erhalte ich 130,0 % statt 13,0%. Nun kann ich das ganze noch durch 100 subtrahieren dann passt das wieder.

Aber warum gibt mir Excel nicht gleich richtig die 13,0 % aus?

Also so funktionierts:
=VERWEIS(A1;{-999999999;-250;-100;0;9999999999};{0,8;1;1,1;1,3}/100)


  

Betrifft: AW: nix Hilfsspalte von: Hajo_Zi
Geschrieben am: 10.01.2010 16:31:26

Hallo rudi,

erst Zelle fomatieren, dann Eingabe.

GrußformelHomepage


  

Betrifft: AW: nix Hilfsspalte von: Daniel
Geschrieben am: 10.01.2010 16:33:05

Hi
naja 13 sind ja 130% und die Formatierung ändert nichts am Wert.
Nur wenn du bei der Eingabe gleich "13%" eintippst, erkennt Excel, daß du einen Prozentwert (also 0,13) dort eingeben willst und passt den Wert incl Formatierung an (und merkt sich das auch für spätere Eingaben)
eine nachträgliche Formatänderung bringt nichts. Wenn, dann müsstest du vor der Eingabe die Zelle als %-Formatieren.
Gruß, Daniel


  

Betrifft: Alle Beiträge lesen... von: Ramses
Geschrieben am: 10.01.2010 17:37:39

Hallo

https://www.herber.de/forum/messages/1128685.html

Dann hätte sich deine Frage nämlich erübrigt

Gruss Rainer


Beiträge aus den Excel-Beispielen zum Thema "automatisch Prozentwerte eintrgen"