Microsoft Excel

Herbers Excel/VBA-Archiv

Index Vergleich | Herbers Excel-Forum


Betrifft: Index Vergleich von: Murat
Geschrieben am: 12.01.2010 17:05:19

Hallo,

ich habe folgendes Probleme ich möchte diese Formel

=INDEX('Tabelle1 (2)'!$C$2:$C$4083;VERGLEICH($B$2;'Tabelle1 (2)'!$B$2:$B$4083;0); VERGLEICH(Tabelle1!$A3;'Tabelle1 (2)'!$A$2:$A$4083;0))

kopieren sobald ich diese Formel kopiere bekomme ich die Fehlermeldung #NV.

Basisdaten (Tabelle(1))

A B C
1 Adre Kat Eintrag
2 10 Auto aabc
3 10 LKW ser
4 10 Bus 5454s
5 10 Flugzeug 41545s
6 10 Fahrrad asdrf1
7 10 AUTO 2 asdf12
8 10 LKW 3 asdf12
9 10 AUT03 asdf12
10 10 LKW2 adsfsdf3
11 87 Auto 27
12 87 LKW 33397
13 87 Bus WIN XP SP 2
14 87 Flugzeug Intel P 4
15 87 Fahrrad 2272 Byte
16 87 AUTO 2 C: 3324 MB

Ich möcht die Daten in folgende Tabelle einfügen (Tabelle1)

A B C D E F G H I J k
1
2 Adre Auto LKW Bus Flugzeug Fahrrad AUTO 2 LKW 3 AUT03 LKW2
3 10 aabc
4 87
5 206
6 310
7 341
8 399
9 549
10 551

kann mir irgende jemand helfen?

Wollte das Problem mit der Pivot Tabelle lösen leider sind in der Spalte eintrag nicht nur Zahlen eingegeben.

Gruß & vielen Dank
murat

  

Betrifft: AW: Index Vergleich von: fcs
Geschrieben am: 13.01.2010 00:57:55

Hallo murat,

hier arbeitet man wegen des Doppelkriteriums (Adresse+Kategorie) besser mit SUMMENPRODUKT und ZEILE, um die Zeilennummer für den INDEX-Bereich zu ermitteln.

Den Bereich in den Summenprodukt-Bereichen kannst du natürlich auch auf die tatsächlichen Datenbereiche reduzieren, um ggf. die Berechnung etwas zu beschleunigen.
Die Formel in B2 kannst du nach rechts und unten kopieren.

Gruß
Franz

Tabellenblattname: Tabelle1

     A      B       C          D            E           F           G          H        I        _
  J       
1  Addr   Auto     LKW           Bus    Flugzeug     Fahrrad       AUTO 2    LKW 3    AUT03      _
  LKW2   
2    10   aabc     ser         5454s      41545s      asdrf1       asdf12   asdf12   asdf12    _
adsfsdf3   
3    87     27   33397   WIN XP SP 2   Intel P 4   2272 Byte   C: 3324 MB      ---      ---      _
   ---   

Benutzte Formeln:
B2:  =WENN(SUMMENPRODUKT(('Tabelle(1)'!$A:$A=Tabelle1!$A2)*
('Tabelle(1)'!$B:$B=Tabelle1!B$1)*ZEILE('Tabelle(1)'!$A:$A))=0;"---";
INDEX('Tabelle(1)'!$C:$C;SUMMENPRODUKT(('Tabelle(1)'!$A:$A=Tabelle1!$A2)*
('Tabelle(1)'!$B:$B=Tabelle1!B$1)*ZEILE('Tabelle(1)'!$A:$A))))
Tabellenblattname: Tabelle(1)

      A        B            C        
 1  Adre        Kat       Eintrag   
 2    10       Auto          aabc   
 3    10        LKW           ser   
 4    10        Bus         5454s   
 5    10   Flugzeug        41545s   
 6    10    Fahrrad        asdrf1   
 7    10     AUTO 2        asdf12   
 8    10      LKW 3        asdf12   
 9    10      AUT03        asdf12   
10    10       LKW2      adsfsdf3   
11    87       Auto            27   
12    87        LKW         33397   
13    87        Bus   WIN XP SP 2   
14    87   Flugzeug     Intel P 4   
15    87    Fahrrad     2272 Byte   
16    87     AUTO 2    C: 3324 MB   



Beiträge aus den Excel-Beispielen zum Thema "Index Vergleich"