Microsoft Excel

Herbers Excel/VBA-Archiv

Kopierfunktion von Tabellenbezeichnungen | Herbers Excel-Forum


Betrifft: Kopierfunktion von Tabellenbezeichnungen von: Harald Haldenwang
Geschrieben am: 13.01.2010 10:56:52

Hallo zusammen,

folgendes Problem:

Es gibt sehr viele Tabellen, z.B. KW1 - KW52. In jeder Tabelle gibt es eine bestimmte Zelle, z.b. A25, welche die Summe aus einer Tabelle hat. Nun soll ganz am Anfang eine Tabelle als "Übersicht" mit der Wiedergabe der einen Zelle aus jeder Tabelle stehen.

In der Tabelle Übersicht! soll A1 ungefähr so aussehen: A1=KW1!$A$25

Kann ich das jetzt irgendwie so kopieren oder halt die Formel ändern, dass man per Kopieren folgendes erreicht:

A1=KW1!$A$25
A2=KW2!$A$25
A3=KW3!$A$25
usw.

Gruß

Harald

  

Betrifft: AW: Kopierfunktion von Tabellenbezeichnungen von: Hajo_Zi
Geschrieben am: 13.01.2010 10:59:37

Hallo Harald,

vorhandene Tabellen

 ABCDEFG
2Tabelle1           
3Tabelle2           
4Webabfrage           
5             
6             
7  Hi Holger,         
8             
9  hatte diese Frage auch grad in einem anderen Forum (anderer Fragesteller) so beantwortet:         
10             
11  Einfügen -> Namen -> Definieren/Festlegen, Name: x         
12  bezieht sich auf:         
13  =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())         
14             
15  In irgendeine Zelle jetzt diese Formel und runterkopieren:         
16  =WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))         
17             
18  Grüße Boris         
19             
20             
21  Formel runter ziehen falls Mehr Tabellen         
22             

verwendete Formeln
Zelle Formel
A2 =WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))
A3 =WENN(ZEILEN($1:2)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:2));FINDEN("]";INDEX(x;ZEILEN($1:2)))+1;31))
A4 =WENN(ZEILEN($1:3)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:3));FINDEN("]";INDEX(x;ZEILEN($1:3)))+1;31))
B4 =WENN(ISTFEHLER(INDIREKT(A4&"!B4:D4"));"";INDIREKT(A4&"!B4:D4"))
E4 =WENN(ISTFEHLER(INDIREKT(A4&"!E4"));"";INDIREKT(A4&"!E4"))
F4 =WENN(ISTFEHLER(INDIREKT(A4&"!F4"));"";INDIREKT(A4&"!F4"))
G4 =WENN(ISTFEHLER(INDIREKT(A4&"!G4"));"";INDIREKT(A4&"!G4"))
A5 =WENN(ZEILEN($1:4)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:4));FINDEN("]";INDEX(x;ZEILEN($1:4)))+1;31))
B5 =WENN(ISTFEHLER(INDIREKT(A5&"!B4:D4"));"";INDIREKT(A5&"!B4:D4"))
E5 =WENN(ISTFEHLER(INDIREKT(A5&"!E4"));"";INDIREKT(A5&"!E4"))
F5 =WENN(ISTFEHLER(INDIREKT(A5&"!F4"));"";INDIREKT(A5&"!F4"))
G5 =WENN(ISTFEHLER(INDIREKT(A5&"!G4"));"";INDIREKT(A5&"!G4"))
A6 =WENN(ZEILEN($1:5)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:5));FINDEN("]";INDEX(x;ZEILEN($1:5)))+1;31))
B6 =WENN(ISTFEHLER(INDIREKT(A6&"!B4:D4"));"";INDIREKT(A6&"!B4:D4"))
C6 =WENN(ISTFEHLER(INDIREKT(A6&"!E4"));"";INDIREKT(A6&"!E4"))
D6 =WENN(ISTFEHLER(INDIREKT(A6&"!F4"));"";INDIREKT(A6&"!F4"))
E6 =WENN(ISTFEHLER(INDIREKT(A6&"!G4"));"";INDIREKT(A6&"!G4"))
D7 =WENN(ISTFEHLER(INDIREKT(A7&"!F4"));"";INDIREKT(A7&"!F4"))
E7 =WENN(ISTFEHLER(INDIREKT(A7&"!G4"));"";INDIREKT(A7&"!G4"))
D8 =WENN(ISTFEHLER(INDIREKT(A8&"!F4"));"";INDIREKT(A8&"!F4"))
E8 =WENN(ISTFEHLER(INDIREKT(A8&"!G4"));"";INDIREKT(A8&"!G4"))
D9 =WENN(ISTFEHLER(INDIREKT(A9&"!F4"));"";INDIREKT(A9&"!F4"))
E9 =WENN(ISTFEHLER(INDIREKT(A9&"!G4"));"";INDIREKT(A9&"!G4"))
D10 =WENN(ISTFEHLER(INDIREKT(A10&"!F4"));"";INDIREKT(A10&"!F4"))
E10 =WENN(ISTFEHLER(INDIREKT(A10&"!G4"));"";INDIREKT(A10&"!G4"))
D11 =WENN(ISTFEHLER(INDIREKT(A11&"!F4"));"";INDIREKT(A11&"!F4"))
E11 =WENN(ISTFEHLER(INDIREKT(A11&"!G4"));"";INDIREKT(A11&"!G4"))
D12 =WENN(ISTFEHLER(INDIREKT(A12&"!F4"));"";INDIREKT(A12&"!F4"))
E12 =WENN(ISTFEHLER(INDIREKT(A12&"!G4"));"";INDIREKT(A12&"!G4"))
D13 =WENN(ISTFEHLER(INDIREKT(A13&"!F4"));"";INDIREKT(A13&"!F4"))
E13 =WENN(ISTFEHLER(INDIREKT(A13&"!G4"));"";INDIREKT(A13&"!G4"))
D14 =WENN(ISTFEHLER(INDIREKT(A14&"!F4"));"";INDIREKT(A14&"!F4"))
E14 =WENN(ISTFEHLER(INDIREKT(A14&"!G4"));"";INDIREKT(A14&"!G4"))
D15 =WENN(ISTFEHLER(INDIREKT(A15&"!F4"));"";INDIREKT(A15&"!F4"))
E15 =WENN(ISTFEHLER(INDIREKT(A15&"!G4"));"";INDIREKT(A15&"!G4"))
D16 =WENN(ISTFEHLER(INDIREKT(A16&"!F4"));"";INDIREKT(A16&"!F4"))
E16 =WENN(ISTFEHLER(INDIREKT(A16&"!G4"));"";INDIREKT(A16&"!G4"))
D17 =WENN(ISTFEHLER(INDIREKT(A17&"!F4"));"";INDIREKT(A17&"!F4"))
E17 =WENN(ISTFEHLER(INDIREKT(A17&"!G4"));"";INDIREKT(A17&"!G4"))
D18 =WENN(ISTFEHLER(INDIREKT(A18&"!F4"));"";INDIREKT(A18&"!F4"))
E18 =WENN(ISTFEHLER(INDIREKT(A18&"!G4"));"";INDIREKT(A18&"!G4"))
A19 =WENN(ZEILEN($1:18)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:18));FINDEN("]";INDEX(x;ZEILEN($1:18)))+1;31))
B19 =WENN(ISTFEHLER(INDIREKT(A19&"!B4:D4"));"";INDIREKT(A19&"!B4:D4"))
C19 =WENN(ISTFEHLER(INDIREKT(A19&"!E4"));"";INDIREKT(A19&"!E4"))
D19 =WENN(ISTFEHLER(INDIREKT(A19&"!F4"));"";INDIREKT(A19&"!F4"))
E19 =WENN(ISTFEHLER(INDIREKT(A19&"!G4"));"";INDIREKT(A19&"!G4"))
A20 =WENN(ZEILEN($1:19)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:19));FINDEN("]";INDEX(x;ZEILEN($1:19)))+1;31))
B20 =WENN(ISTFEHLER(INDIREKT(A20&"!B4:D4"));"";INDIREKT(A20&"!B4:D4"))
C20 =WENN(ISTFEHLER(INDIREKT(A20&"!E4"));"";INDIREKT(A20&"!E4"))
D20 =WENN(ISTFEHLER(INDIREKT(A20&"!F4"));"";INDIREKT(A20&"!F4"))
E20 =WENN(ISTFEHLER(INDIREKT(A20&"!G4"));"";INDIREKT(A20&"!G4"))
A21 =WENN(ZEILEN($1:20)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:20));FINDEN("]";INDEX(x;ZEILEN($1:20)))+1;31))
C21 =WENN(ISTFEHLER(INDIREKT(A21&"!E4"));"";INDIREKT(A21&"!E4"))
D21 =WENN(ISTFEHLER(INDIREKT(A21&"!F4"));"";INDIREKT(A21&"!F4"))
E21 =WENN(ISTFEHLER(INDIREKT(A21&"!G4"));"";INDIREKT(A21&"!G4"))

definierte Namen
Name Bezieht sich auf Tabelle Z1S1-Formel
x=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT()) =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())

Tabellendarstellung in Foren Version 5.3



GrußformelHomepage


  

Betrifft: AW: Kopierfunktion von Tabellenbezeichnungen von: Harald Haldenwang
Geschrieben am: 13.01.2010 11:14:53

Hallo Hajo,

das funktioniert zwar, dass in der Zelle A2=tabelle2 steht, aber ich brauche ja immer wieder die selbe Zelle aus jeder Tabelle:

Tabelle1 heißt KW1 und A25=50,00 Euro
Tabelle2 heißt KW2 und A25=125,00 Euro
Tabelle3 heißt KW3 und A25=75,00 Euro
usw.

A1=KW1!$A$25 also 50,00 Euro sollte als Inhalt drin stehen
A2=KW2!$A$25 also 125,00 Euro sollte als Inhalt drin stehen
A3=KW3!$A$25 also 75,00 Euro sollte als Inhalt drin stehen
usw.

Ich brauche nicht die Tabellenbezeichnung in der Zelle sondern aus jeder Tabelle die eine Zelle :)
Und ob es da eine Kopierfuntion gibt?

Gruß

Harald


  

Betrifft: AW: Kopierfunktion von Tabellenbezeichnungen von: Hajo_Zi
Geschrieben am: 13.01.2010 11:23:09

Hallo Harald,

Du hast Dir die Indirekt Formel im hinteren Bereich schon angesehen?

GrußformelHomepage


  

Betrifft: AW: Kopierfunktion von Tabellenbezeichnungen von: Harald Haldenwang
Geschrieben am: 13.01.2010 11:51:53

danke sehr, es klappt :)


  

Betrifft: AW: Kopierfunktion von Tabellenbezeichnungen von: Reinhard
Geschrieben am: 13.01.2010 11:23:19

Hallo Harald,

=INDIREKT(WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x; _
ZEILEN($1:1)))+1;31))&"!A25")

Gruß
Reinhard


  

Betrifft: AW: Kopierfunktion von Tabellenbezeichnungen von: Harald Haldenwang
Geschrieben am: 13.01.2010 11:52:08

danke sehr, es klappt :)