Microsoft Excel

Herbers Excel/VBA-Archiv

Durchschnitt .... | Herbers Excel-Forum


Betrifft: Durchschnitt .... von: pheoby
Geschrieben am: 15.01.2010 14:54:36

Hallo Liebe Kollegen,
Ich benötige eine Formel:
Habe in der Spalte A Namen von 10 Verschiedenen Personen. In der Spalte D habe ich Preise. In der Spalte K habe ich alle 10 Namen aufgelistet. In der Spalte A trage ich immer diese Namen ein und möchte gerne das in der J Spalte diese Namen zusammenfügt. Zusätzlich benötige ich in der Spalte J einen Durchschnitt von den Preisen zu den Passenden Namen

SpalteA - SpalteD - SpalteK - SpalteJ
Name Preis Namen Durchschnitt
Peter 100,- Hans 20,-
Hans 20,- Peter 75,-
Peter 50,- Tom 0,-

Ich hoffe die Ansicht passt so. Also ich benötige die Formel zu Spalte J

Danke für die Hilfe und Grüsse

  

Betrifft: AW: Durchschnitt .... von: Björn B.
Geschrieben am: 15.01.2010 15:05:43

Hallo,

wenn werte in Zeile 2 beginnen, muss in J2 das stehen:

=WENN(ZÄHLENWENN($A$2:$A$4;K2)>0;SUMMEWENN($A$2:$A$4;K2;$D$2:$D$4)/ZÄHLENWENN($A$2:$A$4;K2);0)

Das kannst du dann nach unten kopieren.
Bereiche musst du natürlich noch anpassen.

Gruß
Björn B.


  

Betrifft: AW: Durchschnitt .... von: pheoby
Geschrieben am: 15.01.2010 15:13:00

Danke Bestens ,o) ihr seit spitze


  

Betrifft: =MITTELWERT(...) _oT von: NoNet
Geschrieben am: 15.01.2010 15:06:04

_oT = "ohne Text"


  

Betrifft: mit =MITTELWERT(...) geht das nicht... von: Björn B.
Geschrieben am: 15.01.2010 15:11:16

Hallo NoNet,

schön, aber erklär mir mal bitte, wie MITTELWERT hier ein Ergebnis bringen soll???

Gruß
Björn B.


  

Betrifft: AW: mit =MITTELWERT(...) geht das nicht... von: Klaus M.vdT.
Geschrieben am: 15.01.2010 15:23:37

Hallo Björn,

ich spring mal für NoNet ein:

in J2-J10 stehen die Namen.
in K2 {=mittelwert(wenn($A$2:$A$100=J2;$B$2:$B$100))}
Als Matrixformel, also mit STRG SHIFT ENTER abschließen statt die geschweiften Klammern einzugebe.

Grüße,
Klaus


  

Betrifft: Sorry : Falsch gelesen :-(( _oT von: NoNet
Geschrieben am: 15.01.2010 15:43:14

_oT