Microsoft Excel

Herbers Excel/VBA-Archiv

Summe Wenn | Herbers Excel-Forum


Betrifft: Summe Wenn von: Ralf
Geschrieben am: 19.01.2010 06:18:53

Hallo Forum,

ich möchte in einer Tabelle Zahlen addieren.
Mit der Formel =SUMMEWENN(C7:D37;">0") klappt dies.
Nun ist die Anforderung diese Formel für folgende Bedingung zu erweitern:
Summe wenn die Zahl größer als -8 ist.
Im Suchkriterium wird keine negative Zahl akzeptiert.

Kann mir jemand helfen?

Danke schon mal.

Gruß

Ralf

  

Betrifft: AW: Summe Wenn von: Josef Ehrensberger
Geschrieben am: 19.01.2010 07:35:20

Hallo Ralf,

sicher funktioniert das,

=SUMMEWENN(C3:C37;">-8")

Gruß Sepp



  

Betrifft: AW: Summe Wenn von: Ralf
Geschrieben am: 19.01.2010 07:41:35

Hallo Sepp,

nö, das funktioniert ned.
Es ist egal, ob ich Deine Lösung nehme, oder statt -8, -1 oder sonst einen negativen Wert zwischen 0 und -8 nehme, er zählt alle negativen Werte mit. Es sollen aber nur die Werte größer als -8 summiert werden. Genau -8 dann also schon nicht mehr.
Bin etwas verwirrt bezgl. der Rechenweise mit negativen Werten im Excel.

Gruß

Ralf


  

Betrifft: AW: Summe Wenn von: Josef Ehrensberger
Geschrieben am: 19.01.2010 07:46:18

Hallo Ralf,

was soll da nicht funktionieren?
Tabelle1

 CDE
310>-810
4-10<-8 
53>-8 
6-3>-8 
7   

Formeln der Tabelle
ZelleFormel
E3=SUMMEWENN(C3:C7;">-8")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Wie soll das Ergebnis den aussehen?


Gruß Sepp



  

Betrifft: AW: Summe Wenn von: Ralf
Geschrieben am: 19.01.2010 07:48:17

Hallo Sepp,

ich möchte Zeiten summieren, da gibt es scheinbar eine andere Vorgehensweise, als bei Zahlen.
Zellformat: [h]:mm
Wenn das hilft.

Gruß

Ralf


  

Betrifft: AW: Summe Wenn von: Josef Ehrensberger
Geschrieben am: 19.01.2010 07:49:03

Hallo Ralf,

zeig mal, wie eine negative Zeit bei dir aussieht und was du summieren willst.


Gruß Sepp



  

Betrifft: AW: Summe Wenn von: Stephan
Geschrieben am: 19.01.2010 07:38:07

Hallo Ralf,
siehe Beispiel.
=SUMMEWENN(C7:D37;">-8") summiert nur die Zahlen innerhalb des Bereichs, die eben >-8 sind.
Wenn du aber nur das Ergebniss rechnen/anzeigen möchtes, das größer -8 ist, dann siehe Beispiel!

Gruß
Stephan

https://www.herber.de/bbs/user/67297.xls


  

Betrifft: AW: Summe Wenn von: Ralf
Geschrieben am: 19.01.2010 07:45:10

Hallo Stephan,

ah, ich glaube, ich habe den Fehler.
Ich möchte keine Zahlen sondern negative Zeiten summieren.
Die Formel, die Du mir genannt hast, ist ja identisch mit der vom Sepp. Diese Formel funktioniert für Zahlen, aber scheinbar nicht für Zeiten. Gibt es dafür eine Lösung?

Gruß

Ralf


  

Betrifft: AW: Summe Wenn von: Stephan
Geschrieben am: 19.01.2010 07:49:31

soweit mir bekannt ist, gibt es keine negativen Zeiten!
stell am besten eine Beispieldatei ins Forum, damit Dir geholfen werden kann!


  

Betrifft: AW: Summe Wenn von: Ralf
Geschrieben am: 19.01.2010 08:03:48

Hallo Sepp und Stephan,

hier die Beispieldatei:

https://www.herber.de/bbs/user/67299.xls

Ich hoffe damit wird es deutlicher.

Gruß

Ralf


  

Betrifft: AW: Summe Wenn von: Josef Ehrensberger
Geschrieben am: 19.01.2010 08:22:38

Hallo Ralf,

das sind keine Uhrzeiten, sondern Text!

Da fällt mir nur eine Lösung mit Hilsspalte ein.

https://www.herber.de/bbs/user/67300.xls


Gruß Sepp



  

Betrifft: AW: Summe Wenn von: Ralf
Geschrieben am: 19.01.2010 08:36:33

Hallo Sepp,

Text ist mein Beispiel.
In der echten Tabelle setzt sich die Zeit aus der Differenz z. B. von 15:34 - 06:20 zusammen. Das ist dann also schon eine echte Uhrzeit mit Zahlen. Kein Text.

Gruß

Ralf


  

Betrifft: AW: Summe Wenn von: Josef Ehrensberger
Geschrieben am: 19.01.2010 08:39:48

Hallo Ralf,

und wenn du Krank bist, dann schickst du deinen Nachbarn zum Arzt, oder wie?

Lade ein Beispiel hoch, das deiner Tabelle entspricht und beschreibe auch,
was und wo gerechnet werden soll.


Gruß Sepp



  

Betrifft: AW: Summe Wenn von: Ralf
Geschrieben am: 19.01.2010 11:45:11

Hallo Sepp,

ich habe Dir nochmal eine Tabelle angehängt.
Diese Tabelle ist eine temporäre Tabelle, wo aus verschiedenen Tabellen Daten gesammelt werden.
Ich möchte einfach nur die Zeiten in Spalte E, die größer als -8:00 Stunden sind summieren.

https://www.herber.de/bbs/user/67312.xls

Gruß

Ralf


  

Betrifft: AW: Summe Wenn von: Josef Ehrensberger
Geschrieben am: 19.01.2010 12:21:21

Hallo Ralf,

das man 1904-Datumswerte aktiviert sind, sollte man in dem Zusammenhang erwähnen.

=SUMMEWENN(E7:E29;">-0,3333333333")

Gruß Sepp



  

Betrifft: AW: Summe Wenn von: Ralf
Geschrieben am: 19.01.2010 12:41:43

Hallo Sepp,

das habe ich deshalb nicht erwähnt, weil ich gedacht habe, dass man ohne 1904er werte keine negativen Zeiten darstellen kann.
Wie auch immer, jetzt passt es.
Danke für Deine Hilfe.

Gruß

Ralf