Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema SpinButton
BildScreenshot zu SpinButton SpinButton-Seite mit Beispielarbeitsmappe aufrufen

Summenprodukt (bedingt) | Herbers Excel-Forum


Betrifft: Summenprodukt (bedingt) von: Peter
Geschrieben am: 19.01.2010 11:02:07

Liebe Forenbenutzer,

wer kennt eine Formel für ein "bedingtes Summenprodukt". Gemeint ist damit folgendes: Excel soll die Spalte A nach einem bestimmten Wert durchsuchen, wenn dieser gefunden ist, sollen die entsprechenden Werte aus den Spalten B und C multipliziert (nicht addiert wie bei "Summewenn") werden. Am Ende sollen die Ergebnisse der Multiplikation summiert werden.

Vielen Dank für Eure Hilfe.

Gruß, Peter

  

Betrifft: =SUMMENPRODUKT((A2:A11=A13)*B2:B11*C2:C11) von: Matthias5
Geschrieben am: 19.01.2010 11:08:26

Hallo Peter,

hier ein Beispiel:

Tabelle1

 ABC
1BedingungWert1Wert2
2a106
3a54
4b102
5c74
6d98
7b36
8b66
9c96
10a11
11a35
12     
13a96 

verwendete Formeln
Zelle Formel
B13 =SUMMENPRODUKT((A2:A11=A13)*B2:B11*C2:C11)

Tabellendarstellung in Foren Version 4.8

Gruß,
Matthias


  

Betrifft: AW: =SUMMENPRODUKT((A2:A11=A13)*B2:B11*C2:C11) von: Peter
Geschrieben am: 19.01.2010 12:01:17

Vielen Dank, das funktioniert.


Beiträge aus den Excel-Beispielen zum Thema "Summenprodukt (bedingt)"