Microsoft Excel

Herbers Excel/VBA-Archiv

Problem mit Werte kopieren | Herbers Excel-Forum


Betrifft: Problem mit Werte kopieren von: ray
Geschrieben am: 20.01.2010 09:03:50

Hallo,

ich habe in einer Spalte:
=WENN(Y2="";X2;Y2)
jetzt möchte ich das Ergebnis davon als Text in einer anderen Spalte haben.
Durch KOPIERNE/WERTE KOPIEREN
bekomme ich
'EG Mitte

Ich brauche aber EG Mitte (ohne ' )

Wie mach ich das...


Gähnende Grüße aus Hamburg

Ray

  

Betrifft: nicht nachvollziehbar owT von: Rudi Maintaire
Geschrieben am: 20.01.2010 09:09:08




  

Betrifft: genauer erklärt von: ray
Geschrieben am: 20.01.2010 09:19:22

ich habe in Zelle A1 steht:
=WENN(Y2="";X2;Y2)
angezeigt wird in dieser Zelle:
EG Mitte

Das möchte ich jetzt als Text ohne Formelbezug in Zelle B1 haben.

Ich gehe auf A1 klicke auf STRG+C dann gehe ich auf EINFÜGEN/WERTE EINFÜGEN
und bekomme:
'EG Mitte (mit vorgestellen ' )

Ich brauche aber zum weiterverarbeiten nur
EG Mitte

Besser erklärt?

Gruß


  

Betrifft: EINFÜGEN/WERTE EINFÜGEN von: Rudi Maintaire
Geschrieben am: 20.01.2010 10:12:36

Hallo,
kenn ich nicht in XLXP

Bearbeiten-Inhalte einfügen-Werte.

Gruß
Rudi


  

Betrifft: Hab ich doch gemacht. Geht nicht! von: ray
Geschrieben am: 20.01.2010 10:17:57

ot


  

Betrifft: Was steht in Y2??? und wie? oT von: Björn B.
Geschrieben am: 20.01.2010 11:02:34

ohne Text


  

Betrifft: das: =WENN(AD2="EM";"EG Mitte";WENN(AD2="OM";"OG M von: ray
Geschrieben am: 20.01.2010 11:06:24

das und genau so:

=WENN(AD2="EM";"EG Mitte";WENN(AD2="OM";"OG Mitte";WENN(AD2="DM";"DG Mitte";"")))


  

Betrifft: AW: das: =WENN(AD2="EM";"EG Mitte";WENN(AD2="OM";"OG M von: Björn B.
Geschrieben am: 20.01.2010 11:13:16

Hallo,

das kann ich nicht nachvollziehen.
Bei mir funktioniert das.
Ist das in allen Mappen so bei Dir? Oder nur bei der einen Zelle?

Vielleicht hilft mal Excel komplett schließen (also Applikation, nicht nur die Mappe) und wieder öffnen.

Sonst könnte es vielleicht noch was mit Zellenformat zu tun haben.

Teste das mal, wenn das nicht hilft, Mappe hochladen, weil wie gesagt, bei mir funktioniert es.

Gruß
Björn B.


  

Betrifft: Hier die Datei von: ray
Geschrieben am: 20.01.2010 11:28:10

https://www.herber.de/bbs/user/67344.xls


  

Betrifft: bin überfragt... von: Björn B.
Geschrieben am: 20.01.2010 11:42:08

Hallo,

also nachvollziehen kann ich das nicht.
Bei mir ist es genau so.

Wenn ich die Zelle A2 kopiere und in einer neuen Tabelle Werte einfüge, dann klappt es.
Wenn ich z.B. in F11 Werte einfüge, dann klappt es auch.
Das ist schon sehr merkwürdig.

Sorry, kann nicht erkennen, woran das liegt.

Gruß
Björn B.


  

Betrifft: noch offen von: ray
Geschrieben am: 20.01.2010 11:43:48

d


  

Betrifft: was stört dich am '? von: Rudi Maintaire
Geschrieben am: 20.01.2010 12:27:10

Hallo,
' wird doch ignoriert.

Gruß
Rudi


  

Betrifft: AW: was stört dich am '? von: ray
Geschrieben am: 20.01.2010 12:31:38

nicht aber wenn ich den Inhalt der Zelle via VBE auslesen und verarbeiten muß. Daher brauche ich das ohne ' und ich verstehe auch gar nciht, warum Excel den ' macht...


  

Betrifft: nicht aber wenn ich ... von: Rudi Maintaire
Geschrieben am: 20.01.2010 12:42:32

Hallo,

nicht aber wenn ich den Inhalt der Zelle via VBE auslesen

auch dann.

Gruß
Rudi


  

Betrifft: Nö: If Zelle(xy) = "EG..." then... ' = <> ot von: ray
Geschrieben am: 20.01.2010 13:09:40

ot


  

Betrifft: AW: Nö: If Zelle(xy) = "EG..." then... ' = <> ot von: D.Saster
Geschrieben am: 20.01.2010 13:31:31

Hallo,
wenn ich in A1 'Test eingebe (mit ') und dann im Direktfenster Msgbox [A1] kommt Test raus. Ohne '.
B2: =A1="Test" ist WAHR. Ebenso Msgbox [A1]="Test".

Du solltest das ganze Gerümpel mal in eine neue Mappe kopieren und dann sehen, was ist.

Gruß
Rudi


  

Betrifft: ich chk das. Danke mit Gruß von: ray
Geschrieben am: 20.01.2010 13:45:40

ot


Beiträge aus den Excel-Beispielen zum Thema "Problem mit Werte kopieren"