Microsoft Excel

Herbers Excel/VBA-Archiv

SUMME Wert nach erstem Auffinden Kenner | Herbers Excel-Forum


Betrifft: SUMME Wert nach erstem Auffinden Kenner von: Andre
Geschrieben am: 20.01.2010 13:49:46

Hallo Gemeinde,

im Beispiel steht mein Anliegen:

https://www.herber.de/bbs/user/67345.xls

Das Anliegen in Worte zu fassen, bzw. eine griffige Überschrift zu finden ist mir aufgrund fehlender Kenntnisse nicht möglich gewesen.
Hat jemand einen Tipp?

Kurz:
Werte einer Liste werden durch einen Kenner gekennzeichnet.
Die Summen der durch den Kenner betroffenen Zeilen sollen EINMAL zusammengefasst werden und ausgegeben werden.
An den anderen Stellen der Kenner soll keine Gesamt Summiereung stattfinden.

Vielleicht ist es auch nicht einwandfrei ausgedrückt.
Bitte fragt nach.

Jetzt schon mal vielen Dank und Grüße,
Andy.

  

Betrifft: AW: SUMME Wert nach erstem Auffinden Kenner von: Matthias5
Geschrieben am: 20.01.2010 13:55:56

Hallo Andy,

=(ZÄHLENWENN(D$4:D4;D4)=1)*SUMMENPRODUKT((D$3:D$29=D4)*B$3:B$29*C$3:C$29)

Ab dem 2. Vorkommen des Kenners wird 0 angezeigt.

Gruß,
Matthias


  

Betrifft: SUMMENPRODUKT() von: NoNet
Geschrieben am: 20.01.2010 13:59:03

Hallo Andy,

gib in E3 folgende Funktion ein und kopiere diese soweit wie benötigt nach unten :

=WENN(ZÄHLENWENN(D$3:D3;D3)=1;SUMMENPRODUKT(($D$3:$D$29=D3)*($B$3:$B$29)*($C$3:$C$29));"")

Gruß, NoNet


  

Betrifft: AW: SUMME Wert nach erstem Auffinden Kenner von: Rudi Maintaire
Geschrieben am: 20.01.2010 14:02:01

Hallo,
=WENN(D3="";B3*C3;SUMMENPRODUKT($B$3:$B$29*$C$3:$C$29*($D$3:$D$29=D3))*(ZÄHLENWENN($D$3:D3;D3)=1))

Gruß
Rudi


  

Betrifft: AW: SUMME Wert nach erstem Auffinden Kenner von: Andre
Geschrieben am: 20.01.2010 14:06:30

Hallo Matthias5, NoNet und Rudi Maintaire... Klasse.
Mit allen Antworten kann ich etwas anfangen.
100% passt Rudi Maintaire ... hier muss ich nichts mehr "pimpen"
Euch vielen Dank... wow
Ihr seid meine Excel-Helden


Beiträge aus den Excel-Beispielen zum Thema "SUMME Wert nach erstem Auffinden Kenner"