Microsoft Excel

Herbers Excel/VBA-Archiv

istfehler bei Doppel Wenn Funktion? | Herbers Excel-Forum


Betrifft: istfehler bei Doppel Wenn Funktion? von: andy67
Geschrieben am: 26.01.2010 21:18:58

Hallo zusammen,

wie bitte baue ich die Funktion "Istfehler" in dieser Formel ein, damit ich die Ausgabe #Wert ausblenden kann?

=WENN(E7>=1250;E7-B7;WENN(E7<=1250;E7-B7;""))

Danke schonmal

Gruß

andy

  

Betrifft: AW: istfehler bei Doppel Wenn Funktion? von: jockel
Geschrieben am: 26.01.2010 21:29:33

hi andy, die formel ist schon kurios, wegen

WENN(E7>=1250;E7-B7;WENN(E7<=1250;E7-B7;""))

ich habe mal in B7 ein leerzeichen eingegeben, um einen fehler zu provieren, meinst du dann so...:

Tabelle1

 ABCDE
1#WERT!       
2         
3         
4         
5         
6         
7        1255
8         

verwendete Formeln
Zelle Formel
A1 =WENN(E7>=1250;E7-B7;WENN(E7<=1250;E7-B7;""))
A2 =WENN(ISTFEHLER(E7-B7);"";WENN(ODER(E7>=1250;E7<=1250);E7-B7;""))

Tabellendarstellung in Foren Version 5.5



cu jörg


  

Betrifft: AW: istfehler bei Doppel Wenn Funktion? von: andy67
Geschrieben am: 26.01.2010 21:39:35

Hallo Jörg,

danke Deine Lösung funzt aber wieso ist die Formel Kurios? Abenteuerlich zusammengebastelt oder wie meinst Du das? Sie rechnet jedenfalls genauso wie ich möchte, gibt eben nur bei fehlemden Wert ind der Ausgabezelle dieses #Wert aus

Gruß

andy


  

Betrifft: weil jeder wert... von: jockel
Geschrieben am: 26.01.2010 21:46:28

hi andy, ... in E7 deinen anforderungen entspricht, wenn es sich um eine zahl handelt...

... da würde =WENN(ISTZAHL(E7);E7-B7;"") reichen... ... oder sehe ich da was falsch?

cu jörg


  

Betrifft: AW: weil jeder wert... von: andy67
Geschrieben am: 26.01.2010 21:57:58

Hallo Jörg,

ich brauchte(denke ich) die Doppel WENN, weil ich in einer Zelle die Abweichung von einem Maximalwert, bei unter und überschreitung errechnen lassen wollte, was auch prima geklappt hat, ausser die Ausgabe #WERT die mich stört. Die ist mit Deiner Lösung jetzt weg, danke.

Es klappt wunderbar, wohl aber total umständlich oder? Meinst Du das?

Gruß

andy


  

Betrifft: AW: istfehler bei Doppel Wenn Funktion? von: Dirk der Xte
Geschrieben am: 26.01.2010 21:49:00

Hallo andy,

sollte diese Variante =WENN(ISTFEHLER(E7-B7);"";E7-B7) nicht ausreichen?!

Gruß Dirk


  

Betrifft: Logischer Irrtum ? von: NoNet
Geschrieben am: 26.01.2010 23:39:49

Hallo Andy,

Jörgs Einwand ist berechtigt :

Wenn in E7 eine Zahl steht, ist entweder E7 >= 1250 oder E7 <= 1250.
In beiden Fällen wird E7-B7 berechnet - also IMMER !

Sinnvoller wäre (je nach Anforderung) folgende Variante :

=WENN(E7>=1250;WENN(ISTZAHL(E7-B7);E7-B7;"");"")

Oder : =WENN(E7<=1250;WENN(ISTZAHL(E7-B7);E7-B7;"");"")

Gruß, NoNet


Beiträge aus den Excel-Beispielen zum Thema "istfehler bei Doppel Wenn Funktion?"