Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema RefEdit
BildScreenshot zu RefEdit RefEdit-Seite mit Beispielarbeitsmappe aufrufen

Bereich definieren | Herbers Excel-Forum


Betrifft: Bereich definieren von: Ronald
Geschrieben am: 28.01.2010 12:38:57

Hallo Excel-Cracks

In meinem Sheet habe ich es nun geschafft anhand eines Namens in der Spalte A den dazugehörigen Bereich zu finden und festzulegen. Leider geht dies nur wenn ich die Reihenfolge der Namen in Spalte A genauso belasse.

Nun suche ich nach einer Lösung wo ich auch anhand eines Namens in Spalte A den Bereich finde ungeachtet wo dieser Name in der Reihenfolge steht.

Wie gehe ich vor:
In Spalte N hole ich mir den Namen mit dem ich in Spalte A den dazugehörigen Bereich suchen will

Dazu habe ich mal eine Beispieldatei hochgeladen
https://www.herber.de/bbs/user/67587.xls

Danke und Gruss
Ron

  

Betrifft: Sverweis() .. Bereich definieren von: Mike
Geschrieben am: 28.01.2010 12:48:11


Hey Ron,

Du sprichst von Erfolgen in Deiner Datei, doch formeltechnisch ist dort
nicht zu sehen.

In N kannst Du die Summen (die dann vorhanden wären) mittels
Sverweis herholen.


Tabelle1

 ABCDEFGHIJKLMNO
5Zuständig                           
6  KVA2                    Andy Ergebnis25.5
7  KVA1.5                       
8  ÄA6                    Bernd Ergebnis9
9  ÄA3                       
10  Prokekt1                    Doris Ergebnis0
11  Prokekt2                       
12  Ferien3                    …… Ergebnis0
13  Ferien5                       
14  Diverses2                    …… Ergebnis0
15Andy Ergebnis  25.5                       

verwendete Formeln
Zelle Formel
O6 =WENN(ISTNV(SVERWEIS(N6;$A$6:$C$27; 3;FALSCH)); 0; SVERWEIS(N6;$A$6:$C$27; 3;FALSCH))
O8 =WENN(ISTNV(SVERWEIS(N8;$A$6:$C$27; 3;FALSCH)); 0; SVERWEIS(N8;$A$6:$C$27; 3;FALSCH))
O10 =WENN(ISTNV(SVERWEIS(N10;$A$6:$C$27; 3;FALSCH)); 0; SVERWEIS(N10;$A$6:$C$27; 3;FALSCH))
O12 =WENN(ISTNV(SVERWEIS(N12;$A$6:$C$27; 3;FALSCH)); 0; SVERWEIS(N12;$A$6:$C$27; 3;FALSCH))
O14 =WENN(ISTNV(SVERWEIS(N14;$A$6:$C$27; 3;FALSCH)); 0; SVERWEIS(N14;$A$6:$C$27; 3;FALSCH))
C15 =SUMME(C6:C14)

Tabellendarstellung in Foren Version 4.28



Gruss
Mike


  

Betrifft: Ursprung .. Bereich definieren von: Mike
Geschrieben am: 28.01.2010 12:51:31


... hier noch der Link zum ursprünglichen Beitrag: https://www.herber.de/forum/messages/1133298.html

Gruss
Mike


  

Betrifft: AW: Sverweis() .. Bereich definieren von: Ronald
Geschrieben am: 28.01.2010 13:43:49

Hallo Mike

Danke mal für deine Hilfestellung. In der beiliegenden Datei (Link) siehst du mal einen Teil meiner Pivottabelle. Dabei fehlt mir ein Total mit dem ich dann den SWERWEIS machen könnte.

Was muss ich tun um dieses Total in dieses Feld zu kriegen?

Link:
https://www.herber.de/bbs/user/67591.xls

Gruss
Ron


  

Betrifft: Du musst doch nur von: Rudi Maintaire
Geschrieben am: 28.01.2010 14:02:45

für das Feld "Zuständig" die Summierung einschalten.

Gruß
Rudi


  

Betrifft: AW: Du musst doch nur von: Ronald
Geschrieben am: 28.01.2010 14:13:23

Hallo Rudi

Und wie mach ich das?

Gruss
Ron


  

Betrifft: AW: Du musst doch nur von: Rudi Maintaire
Geschrieben am: 28.01.2010 14:20:21

Hallo,
in der Pivotabelle Doppelklick auf den Feldnamen und entsprechend wählen.
(Das was du angehängt hast ist keine Pivot, da statisch.)

Gruß
Rudi


  

Betrifft: AW: Du musst doch nur von: Ronald
Geschrieben am: 28.01.2010 14:33:35

Hallo Rudi

Richtig die hochgeladene Datei sollte nur zeigen wie es bei mir aussieht.
Sorry ich begreife nicht was du meinst... ich klicke in der Pivot-Tabelle auf den Feldnamen ... welcher .... wohin und dann....???

Ich raufe mir schon die Haare ich begreife diese Pivot (noch) nicht.....

Danke für deine Geduld
Ron


  

Betrifft: Doppelklick! von: Rudi Maintaire
Geschrieben am: 28.01.2010 15:21:12

oben auf das grau unterlegte 'Zuständig'
Oder Rechtsklick auf die Spalte in der Pivot-Feldeigenschaften

Gruß
Rudi


  

Betrifft: AW: Doppelklick! von: Ronald
Geschrieben am: 28.01.2010 15:45:07

Hallo Rudi

Besten Dank. Dank deinen Hinweisen lerne ich aktuell sehr viel zum Thema PIVOT.
Nun habe ich meine Summenzahl. Nun muss ich noch die Sache mit dem SVERWEIS versuchen.

Herzlichen Dank.

Gruss
Ron


  

Betrifft: AW: Sverweis() .. Bereich definieren von: Ronald
Geschrieben am: 28.01.2010 16:41:00

Hallo Mike

Hier mein Feedback. Ich konnte nun dank dem Tipp von Dir meinen Wunsch komplett realisieren.
Zuvor musste ich meine Pivot-Tabelle noch entsprechend anpassen, damit ich mit dem SVERWEIS entsprechend auf diese "aufbereiteten" Daten zugreifen konnte.

Danke für deine Hilfe.

Gruss
Ron


  

Betrifft: so .. Bereich definieren von: Mike
Geschrieben am: 28.01.2010 12:49:53


Hey Ron,

nochmals kurz ich: so wie Du das Beispiel darstellt, sind die Grunddaten
mittels Pivot verarbeitet, dort wären ja dann die Total drin, die auch
mittels Sverweis() auswertbar sind.

Gruss
Mike


Beiträge aus den Excel-Beispielen zum Thema "Bereich definieren"