Microsoft Excel

Herbers Excel/VBA-Archiv

Formelsuche | Herbers Excel-Forum


Betrifft: Formelsuche von: Frank H.
Geschrieben am: 28.01.2010 12:51:40

Hallo Zusammen!!!

Ich brauche wieder einmal bei der Erstellung einer Formel Hilfe.

In Spalte A Zeile 24:35 stehen die Monate Januar - Dezember. In Zeile 22 ab Spalte B bis Spalte X stehen Jahreszahlen. Nun möchte ich, dass wenn der Wert aus Spalte AA mit dem Wert aus Spalte A und der Wert aus Zeile 22 (B-X) in Spalte AB übereinstimmen der dazugehörige Wert ausgegeben wird. Ich hoffe ich konnte mich verständlich ausdrücken. Bitte helft und Danke im Voraus!!!

Gruß Frank H.

  

Betrifft: komb. Sverweis() .. Formelsuche von: Mike
Geschrieben am: 28.01.2010 12:54:28


Hey Frank,

mal grundsätzlich wirds einfacher in der Lösungsfindung, wenn Du uns
verräts, wass in AA, AB .. steht.

Aber im Prinzip kannst Du aus der kombinierten Jahres / Monatsfeldern
die Daten mittels Sverweis reinziehen.

Gruss
Mike


  

Betrifft: AW: komb. Sverweis() .. Formelsuche von: Frank H.
Geschrieben am: 28.01.2010 13:01:36

Hallo Mike!!!

Ich steh auf dem Schlauch und tue mich schwer!

In Spalte AA 24:35 stehen wieder die Monate und in Zelle AB 22 steht das Jahr, welches aber veränderbar ist!

Bitte hilf oder alle Anderen!!!

Danke und Gruß!!!


  

Betrifft: einfach .. Formelsuche von: Mike
Geschrieben am: 28.01.2010 13:19:40


Hey Frank,

hier mal "einfach" gelöst:


Tabelle1

 ABCDEFGH
22            Spalte AASpalte AB
23  201020092008      2009
24Januar000    Januar 
25Februar04000    Februar400
26März000    März 
27April03000    April300
28Mai000    Mai 
29Juni000    Juni 
30Juli02000    Juli200
31August000    August 
32September000    September 
33Oktober01000    Oktober100
34November000    November 
35Dezember000    Dezember 

verwendete Formeln
Zelle Formel
B24 =WENN(UND($A24=$G24; B$23=$H$23); $H24; 0)
C24 =WENN(UND($A24=$G24; C$23=$H$23); $H24; 0)
D24 =WENN(UND($A24=$G24; D$23=$H$23); $H24; 0)
B25 =WENN(UND($A25=$G25; B$23=$H$23); $H25; 0)
C25 =WENN(UND($A25=$G25; C$23=$H$23); $H25; 0)
D25 =WENN(UND($A25=$G25; D$23=$H$23); $H25; 0)
B26 =WENN(UND($A26=$G26; B$23=$H$23); $H26; 0)
C26 =WENN(UND($A26=$G26; C$23=$H$23); $H26; 0)
D26 =WENN(UND($A26=$G26; D$23=$H$23); $H26; 0)
B27 =WENN(UND($A27=$G27; B$23=$H$23); $H27; 0)
C27 =WENN(UND($A27=$G27; C$23=$H$23); $H27; 0)
D27 =WENN(UND($A27=$G27; D$23=$H$23); $H27; 0)
B28 =WENN(UND($A28=$G28; B$23=$H$23); $H28; 0)
C28 =WENN(UND($A28=$G28; C$23=$H$23); $H28; 0)
D28 =WENN(UND($A28=$G28; D$23=$H$23); $H28; 0)
B29 =WENN(UND($A29=$G29; B$23=$H$23); $H29; 0)
C29 =WENN(UND($A29=$G29; C$23=$H$23); $H29; 0)
D29 =WENN(UND($A29=$G29; D$23=$H$23); $H29; 0)
B30 =WENN(UND($A30=$G30; B$23=$H$23); $H30; 0)
C30 =WENN(UND($A30=$G30; C$23=$H$23); $H30; 0)
D30 =WENN(UND($A30=$G30; D$23=$H$23); $H30; 0)
B31 =WENN(UND($A31=$G31; B$23=$H$23); $H31; 0)
C31 =WENN(UND($A31=$G31; C$23=$H$23); $H31; 0)
D31 =WENN(UND($A31=$G31; D$23=$H$23); $H31; 0)
B32 =WENN(UND($A32=$G32; B$23=$H$23); $H32; 0)
C32 =WENN(UND($A32=$G32; C$23=$H$23); $H32; 0)
D32 =WENN(UND($A32=$G32; D$23=$H$23); $H32; 0)
B33 =WENN(UND($A33=$G33; B$23=$H$23); $H33; 0)
C33 =WENN(UND($A33=$G33; C$23=$H$23); $H33; 0)
D33 =WENN(UND($A33=$G33; D$23=$H$23); $H33; 0)
B34 =WENN(UND($A34=$G34; B$23=$H$23); $H34; 0)
C34 =WENN(UND($A34=$G34; C$23=$H$23); $H34; 0)
D34 =WENN(UND($A34=$G34; D$23=$H$23); $H34; 0)
B35 =WENN(UND($A35=$G35; B$23=$H$23); $H35; 0)
C35 =WENN(UND($A35=$G35; C$23=$H$23); $H35; 0)
D35 =WENN(UND($A35=$G35; D$23=$H$23); $H35; 0)

Tabellendarstellung in Foren Version 4.28



Gruss
Mike

Gruss


  

Betrifft: AW: einfach .. Formelsuche von: Frank H.
Geschrieben am: 28.01.2010 13:51:02

Hallo Mike!

Da hast du mich leider falsch verstanden, sicher meine Schuld!

Aus der Matrix A22:X35 soll der Wert bei Übereinstimmung in Spalte AB eingetragen werden. Also ich brauche in Zelle AB24 eine Formel, welche vielleicht noch nach unten kopiert werden kann!

Gruß Frank H.


  

Betrifft: AW: einfach .. Formelsuche von: hary
Geschrieben am: 28.01.2010 14:23:54

hallo Frank
meinst Du so? Bereich verkleinert.

Tabellenblattname: Tabelle1

 

A

B

C

D

E

F

G

H

22

 

2001

2002

2003

2004

 

 

 

23

 

 

 

 

 

 

 

2004

24

Januar

1

c

h

w

 

Januar

w

25

Februar

2

a

g

e

 

Februar

e

26

März

3

s

j

r

 

März

r

27

April

4

g

u

t

 

April

t

28

Mai

5

h

k

z

 

Mai

z

29

Juni

6

j

l

z

 

Juni

z

30

July

7

u

o

u

 

July

u

31

August

8

t

i

i

 

August

i

32

September

9

e

u

ik

 

September

ik

33

Oktober

10

u

z

d

 

Oktober

d

34

November

11

w

t

s

 

November

s

35

Dezember

12

q

r

p

 

Dezember

p

36

 

 

 

 

 

 

 

 


Benutzte Formeln:
H24: =INDEX($B$24:$E$35;VERGLEICH(G24;$A$24:$A$35;);VERGLEICH($H$23;$B$22:$E$22;))
H25: =INDEX($B$24:$E$35;VERGLEICH(G25;$A$24:$A$35;);VERGLEICH($H$23;$B$22:$E$22;))
H26: =INDEX($B$24:$E$35;VERGLEICH(G26;$A$24:$A$35;);VERGLEICH($H$23;$B$22:$E$22;))
H27: =INDEX($B$24:$E$35;VERGLEICH(G27;$A$24:$A$35;);VERGLEICH($H$23;$B$22:$E$22;))
H28: =INDEX($B$24:$E$35;VERGLEICH(G28;$A$24:$A$35;);VERGLEICH($H$23;$B$22:$E$22;))
H29: =INDEX($B$24:$E$35;VERGLEICH(G29;$A$24:$A$35;);VERGLEICH($H$23;$B$22:$E$22;))
H30: =INDEX($B$24:$E$35;VERGLEICH(G30;$A$24:$A$35;);VERGLEICH($H$23;$B$22:$E$22;))
H31: =INDEX($B$24:$E$35;VERGLEICH(G31;$A$24:$A$35;);VERGLEICH($H$23;$B$22:$E$22;))
H32: =INDEX($B$24:$E$35;VERGLEICH(G32;$A$24:$A$35;);VERGLEICH($H$23;$B$22:$E$22;))
H33: =INDEX($B$24:$E$35;VERGLEICH(G33;$A$24:$A$35;);VERGLEICH($H$23;$B$22:$E$22;))
H34: =INDEX($B$24:$E$35;VERGLEICH(G34;$A$24:$A$35;);VERGLEICH($H$23;$B$22:$E$22;))
H35: =INDEX($B$24:$E$35;VERGLEICH(G35;$A$24:$A$35;);VERGLEICH($H$23;$B$22:$E$22;))
gruss hary


  

Betrifft: AW: einfach .. Formelsuche von: Frank H.
Geschrieben am: 28.01.2010 14:57:01

Hallo Hary!!!

Perfekt!!! Funzt Super!!! Ich konnte wieder dazu lernen, ein geiles Forum!!!

Schönen Tag noch und besten Dank!!!

Gruß Frank H.