Microsoft Excel

Herbers Excel/VBA-Archiv

Noch mal neu, bin ja lernwillig | Herbers Excel-Forum


Betrifft: Noch mal neu, bin ja lernwillig von: Melanie
Geschrieben am: 29.01.2010 11:48:50

Hallo,

jetzt habe ich es wohl geschafft mit der Darstellung in Foren:

Ich habe folgende Excel Tabelle

Tabelle1

 ABRST
1MaterialArbPlatz Einzelkosten Gesamtkosten  
2         
311300000911211001 95,35 € 166,02 €  
411300000911215001 70,67 €    
511300000931211001 95,35 € 166,02 €  
611300000931215001 70,67 €    
711300001711217501 139,50 € 210,17 €  
811300001711215001 70,67 €    
911300002791217001 24,08 € 44,25 € 155,42 €
1011300002791215501 20,17 € 111,17 €  
1111300002791218001 91,00 €    
1211300002861211501 107,25 € 177,92 €  
1311300002861215001 70,67 €    
1411300002941211501 95,35 € 166,02 €  

verwendete Formeln
Zelle Formel
R3 =SUMME(Q3+O3+M3)
S3 =WENN(A3=A4;R3+R4;"")
R4 =SUMME(Q4+O4+M4)
S4 =WENN(A4=A5;R4+R5;"")
R5 =SUMME(Q5+O5+M5)
S5 =WENN(A5=A6;R5+R6;"")
R6 =SUMME(Q6+O6+M6)
S6 =WENN(A6=A7;R6+R7;"")
R7 =SUMME(Q7+O7+M7)
S7 =WENN(A7=A8;R7+R8;"")
R8 =SUMME(Q8+O8+M8)
S8 =WENN(A8=A9;R8+R9;"")
R9 =SUMME(Q9+O9+M9)
S9 =WENN(A9=A10;R9+R10;"")
T9 =S9+S10
R10 =SUMME(Q10+O10+M10)
S10 =WENN(A10=A11;R10+R11;"")
R11 =SUMME(Q11+O11+M11)
S11 =WENN(A11=A12;R11+R12;"")
R12 =SUMME(Q12+O12+M12)
S12 =WENN(A12=A13;R12+R13;"")
R13 =SUMME(Q13+O13+M13)
S13 =WENN(A13=A14;R13+R14;"")
R14 =SUMME(Q14+O14+M14)
S14 =WENN(A14=A15;R14+R15;"")

Tabellendarstellung in Foren Version 5.5



Nun möchte ich, dass alle Kosten einer Materialnummer in den Gesamtkosten zusammengefasst werden.

vielen dank

Viele Grüße Melanie

  

Betrifft: AW: Noch mal neu, bin ja lernwillig von: Tino
Geschrieben am: 29.01.2010 12:00:18

Hallo,
meinst Du so?

In Zelle D3

=WENN(ZÄHLENWENN($A3:$A$14;$A3)=ZÄHLENWENN($A$3:$A$14;$A3);SUMMEWENN($A$3:$A$14;A3;$C$3:$C$14);"") 
und nach unten kopieren.

Gruß Tino


  

Betrifft: AW: Noch mal neu, bin ja lernwillig von: Melanie
Geschrieben am: 29.01.2010 12:29:12

Hallo Tino,

danke genau so...


  

Betrifft: AW: Doppelt von: Hajo_Zi
Geschrieben am: 29.01.2010 12:01:57

Hallo Melanie,

warum neuer Beitrag, ist im alten schon vorgeschlagen
https://www.herber.de/forum/messages/1134100.html

GrußformelHomepage