Microsoft Excel

Herbers Excel/VBA-Archiv

Zahl letztmals verwendet | Herbers Excel-Forum


Betrifft: Zahl letztmals verwendet von: Michael
Geschrieben am: 31.01.2010 15:45:58

Hallo zusammen,

ich habe eine Frage. Wie kann ich folgenden Sachverhalte per Formel abbilden. Siehe Anhang.

https://www.herber.de/bbs/user/67660.xls

Ich möchte wissen wann die Zahlen 1-9 letztmals verwendet wurden. Die Formel müsste in jeder Zeile jeweils 3 Spalten durchforsten. Ist die Zahl nicht gefunden worden, müsste die Formel nach oben springen und wieder nach der gesuchten Zahl suchen.

z.B.
gesuchte Zahl 1: Antwort 1 Woche
gesuchte Zahl 3: Antwort 0 Wochen etc.

1 2 3
3 4 5

Vielen Dank für Eure Hilfe
Michael

  

Betrifft: AW: Zahl letztmals verwendet von: Tino
Geschrieben am: 31.01.2010 16:18:44

Hallo,
vielleicht so.

 BC
12ZahlLetztmals verwendet vor x Wochen
1314,3
1421,3
1531,3
1642,3
1755,3
1863,3
1975,3
2081,3
2192,3

Formeln der Tabelle
ZelleFormel
C13{=WENN(ZÄHLENWENN($D$2:$F$6;$B13)>0;RUNDEN((HEUTE()-MAX(WENN(($D$1:$F$6=$B13); DATUM($C$1:$C$6;$B$1:$B$6;$A$1:$A$6))))/7;1); "")}
C14{=WENN(ZÄHLENWENN($D$2:$F$6;$B14)>0;RUNDEN((HEUTE()-MAX(WENN(($D$1:$F$6=$B14); DATUM($C$1:$C$6;$B$1:$B$6;$A$1:$A$6))))/7;1); "")}
C15{=WENN(ZÄHLENWENN($D$2:$F$6;$B15)>0;RUNDEN((HEUTE()-MAX(WENN(($D$1:$F$6=$B15); DATUM($C$1:$C$6;$B$1:$B$6;$A$1:$A$6))))/7;1); "")}
C16{=WENN(ZÄHLENWENN($D$2:$F$6;$B16)>0;RUNDEN((HEUTE()-MAX(WENN(($D$1:$F$6=$B16); DATUM($C$1:$C$6;$B$1:$B$6;$A$1:$A$6))))/7;1); "")}
C17{=WENN(ZÄHLENWENN($D$2:$F$6;$B17)>0;RUNDEN((HEUTE()-MAX(WENN(($D$1:$F$6=$B17); DATUM($C$1:$C$6;$B$1:$B$6;$A$1:$A$6))))/7;1); "")}
C18{=WENN(ZÄHLENWENN($D$2:$F$6;$B18)>0;RUNDEN((HEUTE()-MAX(WENN(($D$1:$F$6=$B18); DATUM($C$1:$C$6;$B$1:$B$6;$A$1:$A$6))))/7;1); "")}
C19{=WENN(ZÄHLENWENN($D$2:$F$6;$B19)>0;RUNDEN((HEUTE()-MAX(WENN(($D$1:$F$6=$B19); DATUM($C$1:$C$6;$B$1:$B$6;$A$1:$A$6))))/7;1); "")}
C20{=WENN(ZÄHLENWENN($D$2:$F$6;$B20)>0;RUNDEN((HEUTE()-MAX(WENN(($D$1:$F$6=$B20); DATUM($C$1:$C$6;$B$1:$B$6;$A$1:$A$6))))/7;1); "")}
C21{=WENN(ZÄHLENWENN($D$2:$F$6;$B21)>0;RUNDEN((HEUTE()-MAX(WENN(($D$1:$F$6=$B21); DATUM($C$1:$C$6;$B$1:$B$6;$A$1:$A$6))))/7;1); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!




Gruß Tino