Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert nach Monaten berechnen | Herbers Excel-Forum


Betrifft: Mittelwert nach Monaten berechnen von: Ehbauer
Geschrieben am: 02.02.2010 19:29:40

Servus alle zusammen,

ich habe eigentlich die gleiche frage wie edi. Auch ich benötige einen Mittelwert über mehrere Monate.

"Betrifft: Mittelwert nach Monaten berechnen von: edie Geschrieben am: 08.01.2010 19:01:33"

https://www.herber.de/bbs/user/67091.xls

Meine Monatswerte beziehen sich aber auf verschiedene Jahre. (31.12.2007;31.12.2008;31.12.2009)

=SUMMEWENN(A:A;A3;B:B)/ZÄHLENWENN(A:A;A3)

funktioniert deshalb nicht, da sich das Suchkriterium ändert. Gibt es dazu eine Lösung?
Vielen Dank für die Hilfe.

  

Betrifft: AW: Mittelwert nach Monaten berechnen von: Josef Ehrensberger
Geschrieben am: 02.02.2010 19:42:02

Hallo EH,


meinst du so?


Tabelle1

 ABCDEFGH
1Rohdaten Mittelwert 
2MonateWert1Wert2 MonateWert1Wert2 
3Jan1052 Jan1030 
4Feb1212 Feb910 
5Mrz1543 Mrz1919 
6Apr1722 Apr1516 
7Mai321 Mai2519 
8Jun1665 Jun725 
9Jul169 Jul186 
10        
11Jan1132     
12Feb1311     
13Mrz124     
14Apr1422     
15Mai2211     
16Jun15     
17Jul338     
18        
19Jan107     
20Feb28     
21Mrz3110     
22Apr153     
23Mai2244     
24Jun55     
25Jul61     
26        

Formeln der Tabelle
ZelleFormel
F3{=MITTELWERT(WENN((MONAT($A$3:$A$25)=MONAT($E3))*($A$3:$A$25<>""); B$3:B$25))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



Gruß Sepp



  

Betrifft: AW: Mittelwert nach Monaten berechnen von: jockel
Geschrieben am: 02.02.2010 20:17:40

hi Ehbauer, kannst du mal (d)eine (beispiel)datei hochladen? das würde sicher beim helfen helfen...

cu jörg


  

Betrifft: AW: Mittelwert nach Monaten berechnen von: Ehbauer
Geschrieben am: 03.02.2010 08:48:04

Danke Sepp,

dein Vorschlag hat funktioniert. Gibt es zur Matrixformel noch eine Alternative. Da ich nicht alleine an der Datei
herumdoktere bekomm ich sonst ziemlich oft die Fehlermeldung "#Wert"

Anbei noch einmal eine Beispieldatei mit der Lösung von Sepp
https://www.herber.de/bbs/user/67704.xls

Gruß
Jo


  

Betrifft: AW: Mittelwert nach Monaten berechnen von: Josef Ehrensberger
Geschrieben am: 03.02.2010 09:00:22

Hallo Jo,


bei "Excel gut" solltest du aber wissen, das man Zellen auch sperren kann.



Tabelle1

 ABCDEFG
1Rohdaten Mittelwert
2MonateWert1Wert2 MonateWert1Wert2
3Jan 20101052 Jan10,333330,3333
4Feb1212 Feb9,000010,3333
5Mrz1543 Mrz19,333319,0000
6Apr1722 Apr15,433315,6667
7Mai321 Mai25,333318,6667
8Jun1665 Jun7,333325,0000
9Jul169 Jul18,33336,0000
10       
11Jan 20091132    
12Feb1311    
13Mrz124    
14Apr1422    
15Mai2211    
16Jun15    
17Jul338    
18       
19Jan 2008107    
20Feb28    
21Mrz3110    
22Apr153    
23Mai2244    
24Jun55    
25Jul61    

Formeln der Tabelle
ZelleFormel
F3=SUMMENPRODUKT((MONAT($A$3:$A$25)=MONAT($E3))*B$3:B$25)/SUMMENPRODUKT((MONAT($A$3:$A$25)=MONAT($E3))*(B$3:B$25<>""))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



Gruß Sepp



  

Betrifft: AW: Mittelwert nach Monaten berechnen von: Ehbauer
Geschrieben am: 03.02.2010 09:13:12

servus sepp,

natürlich könnte ich die zelle sperren.
aber ich will es nicht.
gruß
jo


  

Betrifft: AW: Mittelwert nach Monaten berechnen von: Ehbauer
Geschrieben am: 03.02.2010 13:59:45

sepp,
danke für die hilfe
jo


  

Betrifft: warum offen? o.T. von: Josef Ehrensberger
Geschrieben am: 03.02.2010 16:09:23

Gruß Sepp



  

Betrifft: noch ne matrixformel... von: jockel
Geschrieben am: 04.02.2010 00:06:11

ich denke zwar, dass das thema durch ist aber auf dieses beispiel gemünzt geht auch..:

Tabelle1

 ABCDEFG
1Rohdaten Mittelwert
2MonateWert1Wert2 MonateWert1Wert2
3Jan 20101052 Jan10,3330,33
4Feb1212 Feb9,0010,33
5Mrz1543 Mrz19,3319,00
6Apr1722 Apr15,4315,67
7Mai321 Mai25,3318,67
8Jun1665 Jun7,3325,00
9Jul169 Jul18,336,00
10       
11Jan 20091132    
12Feb1311    
13Mrz124    
14Apr1422    
15Mai2211    
16Jun15    
17Jul338    
18       
19Jan 2008107    
20Feb28    
21Mrz3110    
22Apr153    
23Mai2244    
24Jun55    
25Jul61    

Formeln der Tabelle
ZelleFormel
F3{=MITTELWERT(WENN(((REST(ZEILE($1:$23); 8)=1))*ISTZAHL(B3:B25); B3:B25))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



cu jörg eine rückmeldung wäre ganz reizend


  

Betrifft: AW: noch ne matrixformel... von: Jo
Geschrieben am: 04.02.2010 10:27:00

Alles.
Danke noch einmal an alle für die Hilfe


Beiträge aus den Excel-Beispielen zum Thema "Mittelwert nach Monaten berechnen"