Microsoft Excel

Herbers Excel/VBA-Archiv

Negativer Wert korrekt darstellen (SAP) | Herbers Excel-Forum


Betrifft: Negativer Wert korrekt darstellen (SAP) von: F. Jordan
Geschrieben am: 03.03.2010 13:45:41

Hallo zusammen

Listen aus dem SAP stellen das Minus-Zeichen ans Ende der Zahl.
Beispiel 50.10- statt -50.10.

Wie kann ich am einfachsten korrigieren? Habe derzeit eine Liste mit mehr als 100 Korrekturen.

Gruss
Frédéric

  

Betrifft: AW: Negativer Wert korrekt darstellen (SAP) von: Renee
Geschrieben am: 03.03.2010 13:51:18

Hi Freéderic,

Probier mal:

=WENN(RECHTS(A1;1)="-";-WECHSELN(A1;"-";"");--A1)

GreetZ Renée


  

Betrifft: AW: Negativer Wert korrekt darstellen (SAP) von: F. Jordan
Geschrieben am: 03.03.2010 13:57:41

Hallo Renée

Gute Idee, aber bei sehr vielen Einträgen wäre VBA einfacher. Vielen Dank dennoch für die Idee.

Gruss
Frédéric


  

Betrifft: Dann mach's doch so (mit Recorder)! orT von: Luc:-?
Geschrieben am: 04.03.2010 01:27:22

Gruß Luc :-?


  

Betrifft: AW: Negativer Wert korrekt darstellen (SAP) von: Ramses
Geschrieben am: 03.03.2010 13:54:28

Hallo

Das Makro in ein VBA-Modul deiner Arbeitsmappe kopieren oder in die PERSONL.XLS
Die Tabelle mit den Werten auswählen und starten

Sub correct_SAP_Minus()
    Dim myC As Range
    For Each myC In ActiveSheet.UsedRange
        If Right(myC, 1) = "-" Then
            myC = "-" & Left(myC, Len(myC) - 2) * 1
        End If
    Next
End Sub


Erstellen eines Makros

http://www.online-excel.de/excel/singsel_vba.php?f=113

Gruss Rainer


  

Betrifft: AW: Negativer Wert korrekt darstellen (SAP) von: F. Jordan
Geschrieben am: 03.03.2010 13:56:51

Hallo Rainer

Das ist klasse, vielen Dank.

Gruss
Frédéric


  

Betrifft: AW: Negativer Wert korrekt darstellen (SAP) von: Randolf
Geschrieben am: 03.03.2010 14:39:49

Hallo Frédéric,

evtl. musst du mit dem Punkt das Gleiche mache.

Gruß
Randolf


  

Betrifft: AW: Negativer Wert korrekt darstellen (SAP) von: Randolf
Geschrieben am: 03.03.2010 14:24:32

Hallo Frédéric,

Du kannst die Funktion =WECHSELN() benutzen.

Gruß
Randolf


Beiträge aus den Excel-Beispielen zum Thema "Negativer Wert korrekt darstellen (SAP)"