Wichtig -Problem bei Wenn Funktion



Excel-Version: 8xl
nach unten

Betrifft: Wichtig -Problem bei Wenn Funktion
von: Sarah
Geschrieben am: 29.04.2002 - 15:11:51

Hallo VBA Freaks,
ich habe ein Problem und kommenicht weiter.
Wenn die das Auto blau oder Rot und der Kilometer stand größer ist als 50000km dann verkaufe sonst behalten. wie kann ich das realisieren.
Mein Vorschlag
Dim vfarbe as Variant
Dim kmstand as Double
If vfarbe ="rot" or vfarbe="Blau" and kmstand > "50000" then
Cells(12,3)="Verkaufen"

nach oben   nach unten

Re: Wichtig -Problem bei Wenn Funktion
von: Daniel P
Geschrieben am: 29.04.2002 - 15:29:30

Hallo Sarah, Klammern setzten und Zahl nicht als String! If (vfarbe ="rot" or vfarbe="Blau" ) and kmstand > 50000 then Daniel

nach oben   nach unten

Re: Wichtig -Problem bei Wenn Funktion
von: Mike
Geschrieben am: 29.04.2002 - 15:44:28

Ist zwar kein VBA-Skript, funktioniert aber genausogut =WENN(ODER(A1="ROT";A1="BLAU");WENN(B1>=50000;"Verkaufen";"Behalten");)

nach oben   nach unten

Re: Wichtig -Problem bei Wenn Funktion
von: Mike
Geschrieben am: 29.04.2002 - 15:54:01

Es fehlte noch ein Argument, Sorry =WENN(ODER(A1="ROT";A1="BLAU");WENN(B1>=50000;"Verkaufen";"Behalten");"Behalten")

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Wichtig -Problem bei Wenn Funktion"