Problem mit WENN....



Excel-Version: Excel 2000
nach unten

Betrifft: Problem mit WENN....
von: Stephan B
Geschrieben am: 06.05.2002 - 07:59:42

Hallo liebe Forumer !

Habe ein Probelm mit einer Wenn-Funktion !

Wenn in Zelle A1 ein Wert steht, soll automatisch ein Marko
gestartet werden.

Ich habe folgende Formel gefunden, die aber nicht funktioniert :

=WENN(A1<>0;PERSONL.XLS!_ZZ_markieren;"")
Was mache ich falsch? Es liegt bestimmt an der Eingabe des Markos ! Wie muss die richtige Eingabe lauten ?



nach oben   nach unten

Re: Problem mit WENN....
von: Holger Levetzow
Geschrieben am: 06.05.2002 - 08:07:08

meines Wissens geht das nicht!

Holger


nach oben   nach unten

Re: Problem mit WENN....
von: Stephan B
Geschrieben am: 06.05.2002 - 08:47:31

Hallo Holger

Habe diese Formel aus dem Excel-Archiv !

Die war von Herrn Hans Herber.

Sie stand wie folgt im Archiv :

=WENN(A1<>0;MEIN_MARKRO;"")

Muss also irgendwie funktionieren !

Vielleicht weiss ja noch jemand Rat, was ich bei meiner
abgewandelten Formel falsch mache !

nach oben   nach unten

Re: Problem mit WENN....
von: Josef B
Geschrieben am: 06.05.2002 - 21:37:39

Hallo Stephan

Eine Formel kann kein Makro starten, aber eine Funktion ausführen. Diese Funktion kann wiederum ein Makro aufrufen.
Die Funktion ist so aufgebaut und ruft das abhängige Makro auf:
Function MEIN_MAKRO()
MakroStart_Makro
End Function
Sub MakroStart_Makro()
"DeinCode"
End Sub

von Ramses (Rainer)

MfG josef

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Problem mit WENN...."