gibts die Fu: Mittelwertwenn?



Excel-Version: 8.0 (Office 97)

Betrifft: gibts die Fu: Mittelwertwenn?
von: rainer
Geschrieben am: 27.05.2002 - 13:53:05

Hallo! Ich bin auf der Suche nach einer Funktion, die Mittelwertwenn entspricht (analog zu Summewenn oder Zählenwenn). Aufgabe ist: Wenn in einem best Bereich in Spalte A ein bestimmter Wert drin steht, soll der Mittelwert der Zahlen aus Spalte B berechnet werden. Leerzeichen sollen beim Mittelwert ignoriert werden.
Habt ihr da eine Idee?
Gruß Rainer
  

Re: gibts die Fu: Mittelwertwenn?
von: Andreas
Geschrieben am: 27.05.2002 - 15:34:35

Hallo Rainer,

hier mal eine Beispiel-Array-Formel (deswegen mit STRG+SHIFT+ENTER abschließen!!!):
=MITTELWERT(WENN(A1:A10="A";WENN(NICHT(ISTLEER(B1:B10));B1:B10;" ");" "))

Wenn in Spalte A der Wert A steht, dann wird der Wert in Spalte B in die Mittelwertberechnung aufgenommen!

Viel Spaß,
Andreas

  

Re: gibts die Fu: Mittelwertwenn?
von: Heinz
Geschrieben am: 27.05.2002 - 16:09:46

Hallo Rainer,

Das Problem ließe sich auch mit den Funktionen Summewenn(....)/Zählenwenn(...) lösen
Gruß Heinz