Microsoft Excel

Herbers Excel/VBA-Archiv

ABC | Herbers Excel-Forum


Betrifft: ABC von: Peter
Geschrieben am: 10.01.2012 15:15:42

Guten Tag

In meiner Excel-Tabelle frage ich mit der Formel in C2, den Wert ab, der folgende Bedingungen erfüllt:
- Datum in Spalte A stimmt mit demjenigen in Zelle A2 überein
- String in Spalte B stimmt mit demjenigen in Zelle B2 überein
- sofern Bedingung 1 und 2 zutreffend, wird aus Spalte C der höchste Wert übernommen

Nun möchte ich die Formel erweitern, und zwar sollte falls das gesuchte Datum nicht vorhanden ist, das nächst tiefere Datum berücksichtigt werden. In der Zelle G2 sollte der Wert aus G9 stehen.

Gibt es eine Möglichkeit, dieses zusätzliche Erfordernis in dieser Formel einzubauen?

Danke für jeden Hinweis.

Gruss, Peter

https://www.herber.de/bbs/user/78345.xlsx

  

Betrifft: Nachtrag: Mehrfach-Bedingung von: Peter
Geschrieben am: 10.01.2012 15:20:17

Liebes Forum
Hier noch die fehlenden Informationen und Entschuldigung für den sinnlosen Betreff.
Formel in C2: {=MAX(WENN((_AAA=A$2)*(_BBB=B$2);_CCC))}
Die gelben Spaltenbereiche sind benannt mit _AAA, resp. _BBB, resp. _CCC (linke Seite),
_EEE, resp. _FFF, resp. _GGG (rechte Seite)
Gruss, Peter


  

Betrifft: AW: Nachtrag: Mehrfach-Bedingung von: Peter
Geschrieben am: 10.01.2012 15:47:37

Hallo Forum
Glück gehabt: ich habe es doch noch geschafft!
Matrix-Formel in G2: {=MAX(WENN((_EEE=SVERWEIS(E$2;_EEE;1;2))*(_FFF=F$2);_GGG))}
Gruss, Peter