Microsoft Excel

Herbers Excel/VBA-Archiv

Summe Wenn | Herbers Excel-Forum


Betrifft: Summe Wenn von: Andreas Müller
Geschrieben am: 17.01.2012 07:13:27

Hallo Excelgemeinde,

brauche wieder mal Hilfe aus dem super Forum.
Habe eine super Formel zum Sumieren von Daten aber in diesem Anwendungsfall geht es leider nicht
so wie ichs mir denke.
Möchte gern in Spalte C die Summe stehen habe wie ich es in der Spalte D dargestellt habe.
Würde mich über Hilfe freuen.
=WENN(A3<>A4;SUMMEWENN(A:A;A3;B:B);"")
Hänge ein Beispiel an.
https://www.herber.de/bbs/user/78469.xls

Gruß Andreas


  

Betrifft: AW: Summe Wenn von: Josef Ehrensberger
Geschrieben am: 17.01.2012 07:42:30


Hallo Andreas,

so?

Tabelle1

 ABC
2T-NrStückzahlSumme Stück
3110 
425 
537 
6455
7599
868 
924 
1017 
1113 
1222 
136513
143411
1525 
161424
1727 
1829 
192335

Formeln der Tabelle
ZelleFormel
C3=WENN(ZÄHLENWENN($A$3:A3;A3)=ZÄHLENWENN($A$3:$A$19;A3); SUMMEWENN($A$3:$A$19;A3;$B$3:$B$19); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: SUMMEWENN an letzter Position von: WF
Geschrieben am: 17.01.2012 07:57:55

Hi Andreas,

in D3:
=WENN(ZÄHLENWENN(A4:A$99;A3)>0;"";SUMMEWENN(A$3:A$99;A3;B$3:B$99))
runterkopieren

Die Summierung der T-Nr. 3 in Zeile 5 in Deinem Beispiel ist wohl falsch. Konsequenterweise müsste die in Zeile 14 erfolgen.

Salut WF