Microsoft Excel

Herbers Excel/VBA-Archiv

Sommenprodukt mit Oder?? | Herbers Excel-Forum


Betrifft: Sommenprodukt mit Oder?? von: DirkR
Geschrieben am: 17.01.2012 01:27:51

Hallo Experten!

Ich habe folgendes Problem, bei dem Ich einfach nicht weiter komme und Hilfe benötige!

Ich habe hier ein vereinfachtes Beispiel gebastelt. In Wirklichkeit geht es um 5000 Zeilen:
https://www.herber.de/bbs/user/78468.xls

Ich möchte ab Spalte J die Eingaben in den Spalten C bis H analysieren.
Das klappt auch soweit ganz gut bis zur Spalte L (mit Sommenprodukt)

Nun kommt (für mich) das kniffelige daran.

Ich möchte z. B. in Zelle M6 die Anzahl haben, die in 2012 in den Spalten E oder F oder G oder H ein X haben. In dem Beispiel habe ich das Ergebnis, das rauskommen soll in Spalte N eingetragen.

Ich hoffe, dass ich mich nicht zu kompliziert ausgedrückt habe und hoffe auf eure Hilfe.
Gruß DirkR

  

Betrifft: {=Summenprodukt ()} von: Matthias L
Geschrieben am: 17.01.2012 06:39:49

Hallo Dirk

Tabelle1

 BCDEFGHIJKLM
5 mw1234  mw1-4
62012X X    2012203
72012X XX   2013014
82013 XXXXX 2014112
92014X      2015000
102014 X  XX     

Formeln der Tabelle
ZelleFormel
M6{=SUMMENPRODUKT(($B$6:$B$10=$J6)*($E$6:$H$10="X"))}
M7{=SUMMENPRODUKT(($B$6:$B$10=$J7)*($E$6:$H$10="X"))}
M8{=SUMMENPRODUKT(($B$6:$B$10=$J8)*($E$6:$H$10="X"))}
M9{=SUMMENPRODUKT(($B$6:$B$10=$J9)*($E$6:$H$10="X"))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: @Matthias, warum doppelte Array-Formel? o.T. von: Josef Ehrensberger
Geschrieben am: 17.01.2012 07:37:41

« Gruß Sepp »



  

Betrifft: keine Ahnung ;o) von: Matthias L
Geschrieben am: 17.01.2012 07:53:00

Hi Sepp

Hatte wohl noch nen Krampf in li. Daumen und li. Zeigefinger (von der Kaffeetasse) ;o)
Natürlich gehts ohne zweite Arrayformel, also Formel ganz normal eintragen

Danke fürs Korrigieren

Gruß Matthias


  

Betrifft: AW: {=Summenprodukt ()} von: DirkR
Geschrieben am: 18.01.2012 03:02:40

Hallo Matthias,

danke für deine Antwort. Ich habe leider erst jetzt Zeit gefunden ins Netz zu gehen.
Leider ist dein lösungsansatz nicht ganz das, was ich habe möchte.

Bei deiner Formel zählt er alle Xe in dem Jahr. z.B. im Jahr 2012 sind es 3 Xe in den Spalten E:H.
Eigentlich sollte aber 2 rauskommen und nicht 3.

Wenn z.B.: in Zeile 6 das Jahr 2012 ist und in den Spalten 1-4 nur ein Kreuz steht oder 2 oder 3 oder 4, dann soll in Zelle M6 1 rauskommen. Kommt dies in den nächsten Zeilen wieder vor, dann soll genauso gerechnet werden.
Am Beipiel 2012 sind es dann 2
Gruß DirkR


  

Betrifft: AW: {=Summenprodukt ()} von: Josef Ehrensberger
Geschrieben am: 18.01.2012 04:48:39


Hallo Dirk,

Tabelle1

 BCDEFGHIJKLM
5 mw1234  mw1-4
62012X X    2012202
72012X XX   2013011
82013 XXXXX 2014111
92014X      2015000
102014 X  XX     

Formeln der Tabelle
ZelleFormel
M6=SUMMENPRODUKT(($B$6:$B$10=J6)*(VERGLEICH($E$6:$E$10&$F$6:$F$10&$G$6:$G$10&$H$6:$H$10;$E$6:$E$10&$F$6:$F$10&$G$6:$G$10&$H$6:$H$10;0)=ZEILE($1:$5)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: {=Summenprodukt ()} von: DirkR
Geschrieben am: 19.01.2012 00:29:13

Hallo Sepp,

vielen Dank für deine Antwort.
Leider funktioniert die Formel nicht so richtig.

Ich habe die Testarbeitsmappe noch einmal hochgeladen mit einer genaueren Darstellung:
https://www.herber.de/bbs/user/78502.xls

Zur Erklärung:
- Pro Zeile = 1 Person
- In den Spalten C:D wird das geschlecht angegeben
- In den Spalten E:H werden bei der Person vier verschiede Dinge angekreuzt
- wenn auch nur eines angekreuzt wird (mit X) dann soll das quasi wie positiv zählen bei der Pesrson
- Alle positiven Personen sollen dann noch in dem Jahr addiert werden

Ich hoffe auf Hilfe!!!

Gruß DirkR


  

Betrifft: AW: {=Summenprodukt ()} von: Josef Ehrensberger
Geschrieben am: 19.01.2012 07:57:32


Hallo Dirk,

aber jetzt;-))

Tabelle1

 BCDEFGHIJKLMN
5 mw1234  mw1-41-4
62012X XXXXpositiv20122122
72012X     negativ20131011
82012 X   Xpositiv20140111
92013X  X  positiv20150000
102014 XX   positiv     

Formeln der Tabelle
ZelleFormel
M6{=SUMME(($B$6:$B$10=J6)*(MMULT(1*(ISTLEER($E$6:$H$10)); ZEILE($1:$4)^0)<4))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: DANKE SEPP!!! von: DirkR
Geschrieben am: 20.01.2012 02:36:25

Hallo Sepp,

super!!!!!!!!!
Jetzt funzt es! :-)
Vielen Dank!

Gruß DirkR


  

Betrifft: AW: {=Summenprodukt ()} von: DirkR
Geschrieben am: 20.01.2012 04:36:20

Hallo Sepp,

ich hoffe ich erscheine nicht nervig, aber kannst du mir die Formel erklären????
Ich habe in der nachfolgenden Datei die Spalten anzahl auf 7 erweitert und den ganzen Bereich um 3 Zeilen nach oben geschoben:
https://www.herber.de/bbs/user/78525.xls

Die Formel habe ich auch angepasst. Sie scheint auch zu funktionieren:
=SUMME(($B$3:$B$7=M3)*(MMULT(1*(ISTLEER($E$3:$K$7)); ZEILE($1:$7)^0)<7))

Der Teil mit *(MMULT(1*(ISTLEER($E$3:$K$7)); ZEILE($1:$7)^0)<7) verstehe ich nicht wirklich????
Gruß DirkR


  

Betrifft: AW: {=Summenprodukt ()} von: Josef Ehrensberger
Geschrieben am: 20.01.2012 07:33:26


Hallo Dirk,

Vielleicht wird's so klarer.

Tabelle1

 DEFGHIJKLMNOPQ
21              
22  x         =MMULT(1*(ISTLEER(E22:F22));ZEILE($1:$2)^0) 
23            =MMULT({1.0};{1;1}) 
24            1 
25              

Formeln der Tabelle
ZelleFormel
P24=MMULT({1.0};{1;1})


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4










« Gruß Sepp »



  

Betrifft: AW: DANKE!!! von: DirkR
Geschrieben am: 21.01.2012 01:32:37

Hallo Sepp,

danke für die Erklärung.
Werde damit noch experimentieren!!!
Gruß DirkR


Beiträge aus den Excel-Beispielen zum Thema "Sommenprodukt mit Oder??"