Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert bilden | Herbers Excel-Forum


Betrifft: Mittelwert bilden von: MG
Geschrieben am: 17.01.2012 23:54:20

Hallo zusammen,

wie bekomme ich aus den drei Wochen für jedes Produkt einen GesamtMittelwert? (angehängte Datei)

Wichtig ist:
- es sollen nur je Woche die Daten von Mo bis Freitag zur Mittelwertermittlung herangezogen werden
- wenn in der Zelle 0 steht, dann ebenfalls in die Mittelwerterrechnung einbeziehen
- wenn in der Zelle nichts steht, dann nicht gleich 0 setzen und somit nicht in Mittelwertberechnung einbeziehen
-zudem soll in der Formel überprüft werden, ob alle Tage in der Zeile 4 dem Monat des ersten Freitags
entsprechen, um sicherzugehen, dass die Mittelwerte aus dem Monat errechnet werden, nicht den KWs.

Ich habe schon rumprobiert, aber ich bekomme es nur hin die erste Woche zu berechnen,
da ich in die Formel nur den Bereich 5B bis 9B, wie bekomme ich mehrere Abschnitte in eine Formel).

https://www.herber.de/bbs/user/78479.xls

Danke und Gruß

Monte

  

Betrifft: AW: Mittelwert bilden von: Josef Ehrensberger
Geschrieben am: 18.01.2012 00:47:30


Hallo Monte,

Übersicht

 ABCDEFGH
2 MODIMIDOFRSASO
3 1
4 02. Jan03. Jan04. Jan05. Jan06. Jan07. Jan08. Jan
5Produkt 1543 144
6Produkt 25555555
7Produkt 36666666
8Produkt 48888888
9Produkt 510999999
10        
11        
12 Ø      
13Produkt 19,43      
14Produkt 211,33      
15Produkt 324,13      
16Produkt 413,67      
17Produkt 516,27      
18        

Formeln der Tabelle
ZelleFormel
B13=SUMMENPRODUKT((MONAT($B$4:$V$4)=MONAT($B$4-REST($B$4-2-5;7)+7*1-1))*(REST($B$4:$V$4;7)>1)*B5:V5)/SUMMENPRODUKT((MONAT($B$4:$V$4)=MONAT($B$4-REST($B$4-2-5;7)+7*1-1))*(REST($B$4:$V$4;7)>1)*ISTZAHL(B5:V5))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: Mittelwert bedingt von: Erich G.
Geschrieben am: 18.01.2012 00:48:25

Hi,
meinst du das so?
(Die Formel in B13 kannst du in die Zellen B13:D17 kopieren, die Formel aus E13 nach unten.)

 ABCDE
11 Woche 
12Produkt / Woche (Mo-Fr)123gesamt
13Produkt 13,41112,89,0666667
14Produkt 25121711,333333
15Produkt 361353,424,133333
16Produkt 48141913,666667
17Produkt 59,214,824,816,266667

Formeln der Tabelle
ZelleFormel
B13{=MITTELWERT(WENN(INDEX($B$5:$V$9;ZEILE(A1); 7*SPALTE(A1)-6):INDEX($B$5:$V$9;ZEILE(A1); 7*SPALTE(A1)-2)<>""; INDEX($B$5:$V$9;ZEILE(A1); 7*SPALTE(A1)-6):INDEX($B$5:$V$9;ZEILE(A1); 7*SPALTE(A1)-2)))}
E13{=MITTELWERT(WENN((INDEX($B$5:$V$9;ZEILE(A1); 1):INDEX($B$5:$V$9;ZEILE(A1); 21)<>"") *(REST(INDEX($B$4:$V$4;;1):INDEX($B$4:$V$4;;21); 7)>1) *(MONAT(INDEX($B$4:$V$4;;1):INDEX($B$4:$V$4;;21))=MONAT($F$4)); INDEX($B$5:$V$9;ZEILE(A1); 1):INDEX($B$5:$V$9;ZEILE(A1); 21)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Die Wochendurchschnitte stehen da nur zum leichteren Nachrechnen, brauchst du evtl. gar nicht.
Du hattest nur nach "gesamt" gefragt.
Passt das?

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: Mittelwert bedingt - 2. Versuch von: Erich G.
Geschrieben am: 18.01.2012 01:02:00

Hi,
nachdem Sepp mich auf den Boden geholt hat, hier mein 2. Versuch:

 ABCDEF
4 Mo 02.01Di 03.01Mi 04.01Do 05.01Fr 06.01
5Produkt 1543 1
6Produkt 255555
7Produkt 366666
8Produkt 488888
9Produkt 5109999
10      
11 Woche  
12Produkt / Woche (Mo-Fr)123gesamt 
13Produkt 13,251112,89,4285714 
14Produkt 25121711,333333 
15Produkt 361353,424,133333 
16Produkt 48141913,666667 
17Produkt 59,214,824,816,266667 

Formeln der Tabelle
ZelleFormel
B13{=MITTELWERT(WENN(INDEX($B5:$V5;;7*SPALTE(A1)-6):INDEX($B5:$V5;;7*SPALTE(A1)-2)<>""; INDEX($B5:$V5;;7*SPALTE(A1)-6):INDEX($B5:$V5;;7*SPALTE(A1)-2)))}
E13{=MITTELWERT(WENN(($B5:$V5<>"")*(REST($B$4:$V$4;7)>1)*(MONAT($B$4:$V$4)=MONAT($F$4)); $B5:$V5))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Den 5.1. habe ich wie Sepp ausgeleert - damit man einen Effekt der Bedingung sehen kann.

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


Beiträge aus den Excel-Beispielen zum Thema "Mittelwert bilden"