Microsoft Excel

Herbers Excel/VBA-Archiv

Platzbelegung | Herbers Excel-Forum


Betrifft: Platzbelegung von: otto1
Geschrieben am: 19.01.2012 00:46:19

Hallo und guten Abend,
ich grüße die Runde der Excel-Experten. Und die möchte ich bei einem, zumindest für mich, z.Zt. nicht lösbaren Problem um Hilfe bitten.
Vorgegeben ist ein „Datum von“ und ein „Datum bis“ (z.B. 01.07.2011 (B2) – 30.06.2012 (C2). In den folgenden Spalten ist jeweils ein Monat angegeben (z.B. Juli 2011 (D1), August 2011 (E1), September 2011 (F1), Oktober 2011 (G1) ….Juni 2012 (O1).
Ich suche jetzt eine Formel, die automatisch in die Zeile 2 der Monatsspalten eine „1“ schreibt, also bei jedem Monat, der in den Zeitraum vom 01.07.2011 bis 30.06.2012 fällt.
Die Tabelle besteht aus mehreren hundert Zeilen mit unterschiedlichen Zeiträumen wie etwa
01.07.2011-30.06.2012, hier soll eine „1“ jeweils in der Zeile 2 der Monatsspalten Juli 2011 … Juni 2012 stehen
15.07.2011-14.07.2012, hier soll eine „1“ jeweils in der Zeile 2 der Monatsspalten Juli 2011 … Juli 2012 stehen
01.08.2011-31.08.2011, hier soll eine „1“ jeweils in der Zeile 2 der Monatsspalten August 2011 … August 2012 stehen
01.08.2011-30.11.2011 usw.
01.08.2011-31.07.2012
01.08.2011-31.07.2012
01.08.2011-31.07.2012
01.08.2011-31.07.2012
15.08.2011-14.08.2012
15.08.2011-31.08.2012
25.08.2011-24.08.2012, hier soll eine „1“ jeweils in der Zeile 2 der Monatsspalten August 2011 … August 2012 stehen
01.09.2011-22.12.2011, hier soll eine „1“ jeweils in der Zeile 2 der Monatsspalten Sept. 2011 … Dezember 2011 stehen
01.09.2011-31.08.2012
Ich hoffe, ich habe das Problem deutlich/verständlich genug beschreiben können.

Kennt jemand eine Lösung? Ich würde mich freuen.

Vielen Dank schon mal und Gruß
otto1

  

Betrifft: AW: Platzbelegung von: Reinhard
Geschrieben am: 19.01.2012 01:04:40

Hallo Otto,

das wird aber ein bißchen eng in Zeile 2.
Lade mal eine aussagekräftige Beispielmappe hoch.

Gruß
Reinhard


  

Betrifft: AW: Platzbelegung von: otto1
Geschrieben am: 19.01.2012 01:21:28

Hallo Reinhard,
vielen Dank erstmal für die schnelle Reaktion.
Entschuldigung, da habe ich was falsch angegeben mit den Zeilen.
Die weiteren Daten sollen natürlich eine Zeile weiter nach unten stehen.
Ich versuche mal, eine Tabelle hochzuladen. Ich hoffe, das klappt:
https://www.herber.de/bbs/user/78503.xls


Gruß
Otto1


  

Betrifft: AW: Platzbelegung von: hary
Geschrieben am: 19.01.2012 02:00:55

hallo Otto
eine Moeglichkeit. Formel kopierbar.

Tabelle1

 ABCDEFGHIJKLMNOP
1BeginnEndeJul 11Aug 11Sep 11Okt 11Nov 11Dez 11Jan 12Feb 12Mrz 12Apr 12Mai 12Jun 12Jul 12Aug 12
201.07.201130.06.2012111111111111   
315.07.201114.07.20121111111111111 
401.08.201131.08.2011  1                       

verwendete Formeln
Zelle Formel Bereich
C2 =WENN(UND(C$1>=DATUM(JAHR($A2);MONAT($A2);1);C$1<=$B2);1;"") 

Tabellendarstellung in Foren Version 5.30


gruss hary


  

Betrifft: AW: Platzbelegung von: otto1
Geschrieben am: 19.01.2012 02:31:28

Hallo hary,
der erste Test mit Deiner Formel hat wunderbar geklappt.
Ich bin mir da ganz sicher, dass es die richtige Lösung für mein Problem ist.
Ich sage vielen, vielen Dank.
Gruß
otto1