Microsoft Excel

Herbers Excel/VBA-Archiv

Formel Nr.2 !!!! | Herbers Excel-Forum


Betrifft: Formel Nr.2 !!!! von: Snewi
Geschrieben am: 24.01.2012 15:08:58

Hallo,

danke für die schnelle Hilfe hier im Forum! Ein Problem habe ich noch! Undzwar habe ich werte die immer
eine 1 eine 9 oder ein 0 am Ende haben!
Wenn also 0,301 dann soll

>0,30
angezeigt werden, wenn 0,299 dann <0,30 und wenn 0,300 dann >=0,30!

Wie mache ich das?

Gruß

  

Betrifft: AW: Formel Nr.2 !!!! von: CitizenX
Geschrieben am: 24.01.2012 15:33:27

Hi,

so?

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
10,299<30
20,301>30
30,300>=30

ZelleFormel
B1=WAHL(SUMMENPRODUKT(((--RECHTS(A1;1))={0.1.9})*SPALTE(A1:C1));">=";">";"<")&30
Diese Tabelle wurde mit Tab2Html (v2.4.0) erstellt. ©Gerd alias Bamberg
Grüße
Steffen


  

Betrifft: AW: Formel Nr.2 !!!! von: CitizenX
Geschrieben am: 24.01.2012 15:42:47

Hi,

besser so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
10,299<30
20,301>30
30,300>=30
40,489<50
50,401>40
60,400>=40

ZelleFormel
B1{=WAHL(MAX(((--RECHTS(A1;1))={0.1.9})*SPALTE(A1:C1));">=";">";"<")&RUNDEN(A1;1)*100}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.0) erstellt. ©Gerd alias Bamberg
Grüße


  

Betrifft: Ist nicht wirkl besser, Citizen X, lies dir ... von: Luc:-?
Geschrieben am: 24.01.2012 16:55:12

…doch noch mal die Fragestellung durch, bevor du unnütz weiter laborierst! ;-)
Gruß Luc :-?


  

Betrifft: Das geht m.Formel, leider nicht als Format, ... von: Luc:-?
Geschrieben am: 24.01.2012 15:33:48

…Snewi,
weshalb dann daraus TEXT wird:
=TEXT(zahl;WENN(REST(zahl*1000;100)=0;"≥";WENN(REST(zahl*1000;100)<50; ">";"<"))&"0,00")
Gruß Luc :-?


  

Betrifft: AW: Das geht m.Formel, leider nicht als Format, ... von: Snewi
Geschrieben am: 25.01.2012 07:36:05

Das ist mein ergebnis Luc! Ist nicht ganz korrekt!

0,301	>0,30
0,301	>0,30
0,301	>0,30
0,301	>0,30
0,301	>0,30
0,301	>0,30
0,301	>0,30
0,251	<0,25
0,251	<0,25
0,251	<0,25
0,251	<0,25
0,500	≥0,50
0,500	≥0,50
0,500	≥0,50
0,680	<0,68
0,680	<0,68
0,680	<0,68



  

Betrifft: AW: Das geht m.Formel, leider nicht als Format, ... von: Josef Ehrensberger
Geschrieben am: 25.01.2012 07:50:09


Hallo Snewi,

Tabelle1

 ABCD
1    
20,299 <0,30 
30,300 >=0,30 
40,301 >=0,30 
50,399 <0,40 
60,400 >=0,40 
70,401 >=0,40 
8    

Formeln der Tabelle
ZelleFormel
C2=WENN(A2>=RUNDEN(A2;2); ">=";"<")&TEXT(RUNDEN(A2;2); "0,00")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Das geht m.Formel, leider nicht als Format, ... von: Snewi
Geschrieben am: 25.01.2012 07:56:08

Hi,
das passt auch nicht!

0,301	≥ 0,30
0,301	≥ 0,30
0,301	≥ 0,30
0,301	≥ 0,30
0,301	≥ 0,30
0,301	≥ 0,30
0,301	≥ 0,30
0,251	≥ 0,25
0,251	≥ 0,25
0,251	≥ 0,25
0,251	≥ 0,25
0,500	≥ 0,50
0,500	≥ 0,50
0,500	≥ 0,50
0,680	≥ 0,68
0,680	≥ 0,68
0,680	≥ 0,68
Wollte ja wenn wie die Zahlen oben links sind wenn die 1 am Ende dann > wenn eine 9 dann kleiner und wenn eine 0 dann >=!

Gruß


  

Betrifft: AW: Das geht m.Formel, leider nicht als Format, ... von: Josef Ehrensberger
Geschrieben am: 25.01.2012 08:03:46


Hallo Snewi,

dann halt so.

Tabelle1

 ABCD
1    
20,299 <0,30 
30,300 >=0,30 
40,301 >0,30 
50,399 <0,40 
60,400 >=0,40 
70,401 >0,40 
8    

Formeln der Tabelle
ZelleFormel
C2=WENN(A2=RUNDEN(A2;2); ">=";WENN(A2<RUNDEN(A2;2); "<";">"))&TEXT(RUNDEN(A2;2); "0,00")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Das geht m.Formel, leider nicht als Format, ... von: Snewi
Geschrieben am: 25.01.2012 08:22:39

jetzt klappt es !!! Danke

Eine Frage hätte ich noch, wenn ich dann diese Formel benutze:

=WENN(ISTFEHLER(WENN(J15=RUNDEN(J15;2); "≥ ";WENN(J15 "))&TEXT( _
RUNDEN(J15;2); "0,00"));"";WENN(J15=RUNDEN(J15;2); "≥ ";WENN(J15 "))&TEXT(RUNDEN(J15;2); "0,00"))
wie kann ich dann zusätzlich noch eine 0 ausblenden wenn die Ausgangszahl 0 ist?

gruß


  

Betrifft: AW: Das geht m.Formel, leider nicht als Format, ... von: Josef Ehrensberger
Geschrieben am: 25.01.2012 08:34:59


Hallo Snewi,

=WENN(ODER(J15=0;ISTFEHLER(...




« Gruß Sepp »



Beiträge aus den Excel-Beispielen zum Thema "Formel Nr.2 !!!!"