Microsoft Excel

Herbers Excel/VBA-Archiv

Rang-Formel | Herbers Excel-Forum


Betrifft: Rang-Formel von: Tom
Geschrieben am: 03.02.2012 16:37:26

Hallo Experten,

habe folgendes Problem:

In der Spalte A stehen in den Zeilen 1 bis 10 unterschiedliche Länder, die nicht sortiert sind

Beispiel:

Australien
Deutschland
Spanien
Spanien
Deutschland
Deutschland
Australien
Spanien
Deutschland
Deutschland

in der Spalte B finden sich jeweils Werte dazu.

Jetzt bräuchte ich, wenn bspw. in C1 Deutschland als Variable eingegeben wird, eine Formel, die für die Rangberechnung nur die in Spalte B angeführten Werte und Eintrag Deutschland in Spalte A heranzieht, bei Eingabe von Spanien in C1 nur die Einträge von Spanien, ...

Zum besseren Verständnis habe ich auch eine einfache Tabelle mit den Zielergebnissen beigelegt.

https://www.herber.de/bbs/user/78720.xlsx

Wäre super, wenn mir jemand weiterhelfen könnte.

Vielen Dank!
Tom

  

Betrifft: AW: Rang-Formel von: Hajo_Zi
Geschrieben am: 03.02.2012 16:43:41

Hallo Tom,

ich habe mich jetzt an denn Beitrag gehalten und nicht die Datei.
=INDIREKT(ADRESSE(VERGLEICH(C1;A1:A11;0);2))

GrußformelHomepage


  

Betrifft: AW: Rang-Formel von: Tom
Geschrieben am: 03.02.2012 16:54:31

Hallo Hajo,

danke für die rasche Antwort.

Leider funktioniert die Formel noch nicht bzw. vielleicht habe ich diese auch nicht richtig eingefügt.

Frage: Muss ich diese Formel noch mit Rang kombinieren?
Jedenfalls kommt bei mir beim Kopie der Formel in meine Tabelle (Spalte C) immer der selbe absolute Betrag, der in Spalte B steht, als Formelergebnis heraus und nicht der Rang.

LG
Tom


  

Betrifft: AW: Rang-Formel von: Hajo_Zi
Geschrieben am: 03.02.2012 17:13:32

Hallo Tom,

im Beitrag Stand es wuird in C1 eingegeben und dafgür ist die Formel.

Gruß Hajo


  

Betrifft: AW: Rang-Formel von: Uwe (:o)
Geschrieben am: 03.02.2012 16:49:47

Hallo Tom,
so ganz erschließt sich mir Deine Absicht nicht. Mal abgesehen davon, dass in Deiner Beispieldatei in C1 schon "Zielergebnis" steht.
Eine einfache SUMMEWENN-Formel á la:
=SUMMEWENN(A2:A11;C1;B2:B11)
müsstest Du ja mit Excel gut, selber hinbekommen. Was hat da noch "Rang" zu suchen?
Vielleicht kannst Du mir ja auf die Sprünge helfen?

Gruß
Uwe
(:o)


  

Betrifft: AW: Rang-Formel von: Tom
Geschrieben am: 03.02.2012 16:59:14

Hallo Uwe,

das Zielergebnis habe ich manuell eingefügt, dieses sollte durch eine entsprechende Formel automatisch berechnet werden können.

Beispiel:

Australien kommt in meiner Liste 2x vor, einmal in B2 (Wert 300), einmal in B9 (Wert 600); in C2 sollte nun als Ergebnis 2 herauskommen, da es, was Australien betrifft, der 2.größte Wert ist. In C9 sollte als Ergebnis 1 angeführt werden, da es der höchste Wert für Australien ist ...

Hoffe, dass das nun etwas verständlicher formuliert ist ...

Vielen Dank
Tom


  

Betrifft: AW: Rang-Formel von: Josef Ehrensberger
Geschrieben am: 03.02.2012 17:02:25


Hallo Tom,

Tabelle1

 ABC
1LandBetragZielergebnis
2Australien3002
3Deutschland5002
4Deutschland4003
5Spanien3004
6Deutschland2504
7Spanien3703
8Spanien5002
9Australien6001
10Spanien5501
11Deutschland7001

Formeln der Tabelle
ZelleFormel
C2=SUMMENPRODUKT(($A$2:$A$11=A2)*($B$2:$B$11>B2))+1


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Rang-Formel von: Tom
Geschrieben am: 03.02.2012 17:06:05

Hallo Josef,

perfekt! Genau das habe ich gesucht!

Vielen Dank für die rasche Lösung!

Danke auch an alle anderen für die Antworten, leider habe ich das anfangs nicht ganz verständlich formuliert :-).

Tom