Microsoft Excel

Herbers Excel/VBA-Archiv

Stunden Array | Herbers Excel-Forum


Betrifft: Stunden Array von: stefan
Geschrieben am: 12.02.2012 14:54:12

Hallo Excel und VBA Profis,

ich brauch eure Hilfe in dem sheet was ich als beispiel hochgeladen habe
geht es um den stunden nachweis für Mitarbeite ein Mitarbeiter hat mehrer eintäge
ich brauche immer nur eine zeile pro mitarbeiter wo die stunden summiert werden
dann die krankstunden und urlaubstunden training auch noch zu jedem dieser einträge gibt es einen code

könnt ihr mir bitte helfe ;)

https://www.herber.de/bbs/user/78876.xlsx

Danke

  

Betrifft: AW: Stunden Array von: Andre´
Geschrieben am: 12.02.2012 15:07:07

Hallo Stefan,

ein Fall für Pivot: https://www.herber.de/bbs/user/78877.xlsx


MFG Andre


  

Betrifft: AW: Stunden Array von: stefan
Geschrieben am: 12.02.2012 15:29:47

Hallo Andre,

danke für die schnelle Lösung

aber ich brauche die rohdaten so weil es danach als pivot grundlage dient.

_Hast du ne Idee ?


Gruß


  

Betrifft: AW: Stunden Array von: Andre´
Geschrieben am: 12.02.2012 17:34:34

Hallo Stefan,
versteh nicht ganz was Du meinst.
Gib uns mal ein Bsp. wie es aussehen soll anhand Deiner Daten, am besten als Datei!

MFG Andre


  

Betrifft: AW: Stunden Array von: stefan
Geschrieben am: 12.02.2012 19:21:14

Hallo Andre sorry das ich mich erst so spät melde

habe ein bsp in tabelle zwei abgelegt

vielen dank im voraus

https://www.herber.de/bbs/user/78885.xlsx

Gruß


  

Betrifft: AW: Stunden Array von: Andre´
Geschrieben am: 12.02.2012 19:37:19

Hallo Stefan,

meinst Du so: https://www.herber.de/bbs/user/78886.xlsx


MFG Andre


  

Betrifft: VBA Lösung von: Tino
Geschrieben am: 12.02.2012 18:48:09

Hallo,
meinst Du so?

https://www.herber.de/bbs/user/78883.xlsm

Wenn Du die Namen schon hast, müsste es auch mit =Summewenn() gehen.
In etwa so

 ABCDEFG
1MATrainingUrlaubkrankSonntagStundenVerspätet
2Helga_Zwei0,0013,2014,400,0092,000,00

Formeln der Tabelle
ZelleFormel
B2=SUMMEWENN(Tabelle1!$H:$H;$A2;Tabelle1!J:J)
C2=SUMMEWENN(Tabelle1!$H:$H;$A2;Tabelle1!K:K)
D2=SUMMEWENN(Tabelle1!$H:$H;$A2;Tabelle1!L:L)
E2=SUMMEWENN(Tabelle1!$H:$H;$A2;Tabelle1!M:M)
F2=SUMMEWENN(Tabelle1!$H:$H;$A2;Tabelle1!N:N)
G2=SUMMEWENN(Tabelle1!$H:$H;$A2;Tabelle1!O:O)


Gruß Tino


  

Betrifft: AW: VBA Lösung von: stefan
Geschrieben am: 12.02.2012 19:26:49

Hallo

ich hbe mal ein beispiel drangehagen so soll es aussehen


https://www.herber.de/bbs/user/78885.xlsx


vielen dank


Gruß


  

Betrifft: AW: VBA Lösung von: Tino
Geschrieben am: 12.02.2012 19:46:34

Hallo,
welche Spalten spielen bei der Zusammenfassung eine Rolle.
Team, MA , Geschäft ... ?

Gruß Tino


  

Betrifft: AW: VBA Lösung von: stefan
Geschrieben am: 12.02.2012 20:01:23

Hallo Tino

der Code entscheiset ob bezahlt oder nicht

der Ma muss dem richtigem Team zugeordnet werden

dem Datum und dem geschäft


vielen Dank


  

Betrifft: AW: VBA Lösung von: Tino
Geschrieben am: 12.02.2012 20:54:09

Hallo,
ok. es werden die Daten summiert die in den Spalten
Datum, Geschäft, Team, MA und Code gleich sind.
Dies kannst Du evtl. in dieser Zeile entsprechend anpassen.
strCrit = ArrayData(n, 5) & ArrayData(n, 7) & ArrayData(n, 8) & ArrayData(n, 9)
die Zahl steht für die entsprechende Spalte.

https://www.herber.de/bbs/user/78887.xlsm

Gruß Tino


Beiträge aus den Excel-Beispielen zum Thema "Stunden Array"