Microsoft Excel

Herbers Excel/VBA-Archiv

Bedarf für Zutaten pro Woche | Herbers Excel-Forum


Betrifft: Bedarf für Zutaten pro Woche von: Heiner
Geschrieben am: 17.02.2012 11:38:43

Hallo Zusammen,
ich versuche den Bedarf von Zutaten für Artikel pro Woche zu ermitteln.
Bekannt sind Bedarf der Artikel pro Woche sowie %-Anteil der Zutaten pro Artikel.

Summenprodukt bringt mir für eine Zutat in Woche 1 eine Ergebnis, leider für alle anderen Zutaten/Wochen nicht.

Kann mir das mal jemand "auf die Sprünge" helfen?

Beispieldatei anbei.
Grüße aus CLP
Heiner

https://www.herber.de/bbs/user/78965.xlsx

  

Betrifft: AW: Bedarf für Zutaten pro Woche von: jojo
Geschrieben am: 17.02.2012 13:01:49

https://www.herber.de/bbs/user/78967.xlsx

geht doch auch einfacher, oder hab ich es falsch verstanden


  

Betrifft: AW: Bedarf für Zutaten pro Woche von: Heiner
Geschrieben am: 17.02.2012 13:16:24

Hallo JoJo,

die Orginaltabelle hat ca. 200 Artikel und 50 Zutaten.
Da wird das mit deiner Formel nicht gehen.

Sorry, hatte ich vergessen zu schreiben, das Orginal größer ist.

Gruß
Heiner


  

Betrifft: AW: Bedarf für Zutaten pro Woche von: Christian
Geschrieben am: 17.02.2012 13:36:00

Hallo Heiner,
als Vorschlag folgende Matrixformel zum Testen:

Formel in "Zutatenbedarf" B2:

{=SUMME(INDEX('Anteile Zutaten'!$B$2:$G$6;'Anteile Zutaten'!B$2:B$6;VERGLEICH($A2; 'Anteile Zutaten'!$B$1:$G$1;0))*Artikelbedarf!B$2:B$6) }

Setzt voraus, dass die Reihenfolge der Artikel (A-E) in beiden betroffenen Tabellen gleich ist und ebenso die Reihenfolge der Zutaten wie in deinem Bsp.

Gruß
Christian


  

Betrifft: AW: Bedarf für Zutaten pro Woche von: Heiner
Geschrieben am: 22.02.2012 11:15:02

Hallo Christian,

danke für die Formel.

Ich bin am Testen, bis jetzt klappt es noch nicht,, gebe aber Info wenn ich es hin bekommen hab.

Gruß
Heiner