Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn



Excel-Version: 9.0 (Office 2000)

Betrifft: Zählenwenn
von: Ralf
Geschrieben am: 28.05.2002 - 15:32:36

Hallo Excel - Experten,

ich habe in einer Spalte 251 Zahlen untereinander stehen
( Tagesumsätze von 2001 ). Wie kann ich es am einfachsten
bewerkstelligen, zu sagen: zähle mir die ersten 100 z.B.
und addiere mir diese ???

Ich wäre für jeden Hinweis dankbar.
Mit freundlichen Grüßen
Ralf

  

Re: Zählenwenn
von: JoJO
Geschrieben am: 28.05.2002 - 15:45:44

AutoFilter - Top10 (in Deinem Fall Top 100) und nach der letzten Zelle (deiner Daten) =teilergebnis(3;A1:a251) ... hier kann man Summen bilden oder Stück zählen

  

Re: Zählenwenn
von: Ralf
Geschrieben am: 28.05.2002 - 15:53:11

Hallo Jojo,

vielen Dank für Deinen Lösungsvorschlag

Gruß
Ralf


  

Nachfrage
von: Martin Beck
Geschrieben am: 28.05.2002 - 16:44:27

Hallo Ralf,

möchtest Du die Summe der "ersten" 100 Zellen (wie Du geschrieben hast), also z.B. =SUMME(A1:A100), oder die Summe der 100 höchsten(!) Werte in den 251 Zellen? Die Autofilterlösung liefert letzteres.

Gruß
Martin Beck

  

Summe der ersten 100 ohne Leerzellen
von: WF
Geschrieben am: 28.05.2002 - 17:05:17

Hi Martin,

Summe(A1:A100) wäre ja wohl zu einfach; - ich vermute, gewünscht ist die Summe der ersten 100 Zellen, die nicht leer sind.

Das funktioniert mit der Array-Formel:
{=SUMME(A1:INDIREKT("a"&KKLEINSTE(WENN(A1:A1000<>"";ZEILE(1:1000));100)))}

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.

trapp, trapp, trapp, trapp, trapp, brrrrr
WF


http://www.excelformeln.de/
die ultimative Formelseite

  

Re: Summe der ersten 100 ohne Leerzellen
von: Martin Beck
Geschrieben am: 28.05.2002 - 17:09:07

Hallo WF,

tja, ich weiß es nicht, aber vielleicht verrät uns Ralf ja noch, was er eigentlich erreichen will.

Gruß
Martin Beck


  

Re: Summe der ersten 100 ohne Leerzellen
von: Ralf
Geschrieben am: 29.05.2002 - 07:31:31

Hallo Martin und WF,

noch kurz zum Hintergrund der Frage. Ich habe eine Spalte
A, in der die Tagesumsätze 2002 stehen (gestern war der
100. Arbeitstag) und jetzt möchte ich diese Summe mit
der Summe der ersten 100 Arbeitstage von 2001 vergleichen.
WF hat es schon richtig vermutet.
Aber vielen Dank für Eure Mühe.

Mit freundlichen Grüßen aus dem Teutoburger Wald
Ralf