eig. Funktion zu SVERWEIS



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: eig. Funktion zu SVERWEIS
von: AxelG
Geschrieben am: 04.06.2002 - 14:40:17

Hallo Forum,

ich brauche Eure Hilfe, da ich bei folgendem Problem nicht weiter komme:
ich habe ein Kalenderblatt als Wiedervorlage generiert, keine Jahre, nur Tage und Monate.

in D2 steht:
=WENN(ISTFEHLER(sSVERWEIS(C2;geb_dat;2;FALSCH));"";sSVERWEIS(C2;geb_dat;2;FALSCH))

in D32 steht:
=WENN(ISTFEHLER(sSVERWEIS(C32;geb_dat;2;FALSCH));"";sSVERWEIS(C32;geb_dat;2;FALSCH))

es ist der Januar.

geb_dat ist der Bereich über den per sSVERWEIS, eigene Funktion ( im Forum gefunden ) mehrere Treffer überSVERWEIS in eine Zelle geschrieben werden sollen, wenn in der Terminliste mehrere Termine auf einen Tag fallen.

Der code zur Funktion:

Function sSVERWEIS(strName As String, rngBereich As Range) As Variant
Dim rngAct As Range
Dim strErgebnis As String
Dim si As Integer
Dim bv As Boolean
si = 2
bv = False
Application.Volatile
For Each rngAct In rngBereich.Columns(1).Cells
If rngAct = strName.si.bv Then
strErgebnis = strErgebnis & rngAct.Offset(0, 1) & Chr(10)
End If
Next rngAct
sSVERWEIS = Left(strErgebnis, Len(strErgebnis))
End Function

leider bleiben alle Zellen leer, was mache ich falsch,

Dank im voraus

AxelG

nach oben   nach unten

Re: eig. Funktion zu SVERWEIS
von: Hans Hofmann
Geschrieben am: 04.06.2002 - 16:01:06

Hallo,

Es kann sich unmöglich um die gleiche Funktion handeln.
Anzahl Übergabeparameter ist unterschiedlich?
strName.si.bv istUngültiger Bezeichner
Außerdem solls um Datum gehen und nicht um String.
Im überigen ist alles was mit
Application.Volatile
arbeitet grundsätzlich bedenklich - ich halte es sogar für Murks.

Gruß HW


nach oben   nach unten

hilft auch nicht weiter, :-(
von: AxelG
Geschrieben am: 04.06.2002 - 16:07:09

Danke für die Antwort,
nur leider weiß ich jetzt immer noch nicht wie ich mehrere Werte über sverweis in eine Zelle bekomme, wenn ich Formeln wie:
=WENN(ISTFEHLER(sSVERWEIS(C2;geb_dat;2;FALSCH));"";sSVERWEIS(C2;geb_dat;2;FALSCH))
benutze,
nach oben   nach unten

Re: hilft auch nicht weiter, :-(
von: Hans W. Hofmann
Geschrieben am: 04.06.2002 - 21:30:59

Denk halt auch einmal nach!
Was soll
sSVERWEIS(C2;geb_dat;2;FALSCH)
mit
Function sSVERWEIS(strName As String, rngBereich As Range) As Variant
zu tun haben. Das sind völlig verschiedene Funktionen.

Gruß HW


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "eig. Funktion zu SVERWEIS"