Microsoft Excel

Herbers Excel/VBA-Archiv

Addition von Zeilen



Excel-Version: 10.0 (Office XP)

Betrifft: Addition von Zeilen
von: Florian
Geschrieben am: 05.06.2002 - 04:25:17

Hallo!

Ich moechte in einer Tabelle die Spalteneintraege in verschiedenen Zeilen miteinander addieren. Im meinem kleinen Beispiel moechte ich z.B. alle Daten der gruenen Autos zusammenzaehlen, auch wenn das wenig Sinn macht! ;)

Beispiel:
Auto Farbe Preis Zylind. Km
Audi blau 3000 4 300.000
BMW rot 4000 4 250.000
BMW gruen 5000 6 100.000
:
:
VW rot 2000 4 50.000
VW gruen 3000 6 150.000

Mein problem besteht in einer Liste mit rund 700 Zeilen und ich moechte gleiche Zeilen miteinander addieren. Per Hand ist das natuerlich muehsam.
Die SUMMEWENN funktioniert nicht weil das Krterium keine Zahl ist.
Wenn mir dabei irgendeiner helfen koennte waere ich wirklich dankbar, da ich gerade im Praxissemester bin und mir eine Menge arbeit ersparen moechte!

Thx folks!

Florian

##################
Sorry, er scheint sich die Tabs nciht zu merken, zumindest nicht in der Vorschau. Das oben soll eine Tabelle sein!
##################

  

Re: Addition von Zeilen
von: Hans W. Herber
Geschrieben am: 05.06.2002 - 05:38:30

Hallo Florian,

bezüglich der Tabellendarstellung sieh Dir bitte die Seite zum Forums-Menüpunkt "Features" an.

Wenn Du 2 oder mehr Kriterien nutzen möchtest, verwende Folgende Matrixfunktion:
=SUMME((A1:A700="Audi")*(B1:B700="grün")*C1:C700)

Matrixformeln sind in der Bearbeitungsleiste kenntlich an den sie umgebenden geschweiften Klammern und werden mit der Tastenkombination STRG+UMSCHALT+EINGABE ohne diese Klammern eingegeben.

Das Thema Matrixformeln wurde im Excel-Tutorial 2001 ausführlich behandelt.

hans

  

Re: Addition von Zeilen
von: Florian
Geschrieben am: 05.06.2002 - 07:20:27

Vielen Dank fuer die ueberaus schnelle Hilfe!

Mein Beispiel war ein wenig ungluecklich, da mein original-Fall nur ein Suchkriterium braucht, vergleichbar mit dem alten Beispeil, die Farbe.
Schreibe ich die Formal um auf

=SUMME((B1:B700="grün")*C1:C700)

kommt beim Ergebnis 'null' obwohl es eine Summe ergeben sollte.
Was mache ich falsch?

  

Re: Addition von Zeilen
von: Hans W. Herber
Geschrieben am: 05.06.2002 - 07:46:50

Hallo Florian,

bei einem Kriterium verwende SUMMEWENN:
=SUMMEWENN(B:B;"grün";C:C)

hans

  

Re: Addition von Zeilen
von: Florian
Geschrieben am: 06.06.2002 - 05:00:03

Das funktioniert, das ist richtig.
Ich moechte es aber gleichzeitig auf mehrere Spalten in einer Zeile anwenden, wahrscheinlich muss ich dann wieder eine Array-Formel draus machen, nicht?

Perfekt waere es allerdings, wenn das so angewendet werden koennte, das Excel mit die alten Zahlen in einem EIntrag ersetzt und das ueberfluessige loescht.
Ich wuerde gerne ein Bild von meiner Datei hochladen, damit es verstaendlicher wird - besteht die Moeglichkeit?

Aber ansonsten vielen vielen Dank!

Gruss
Florian


  

Re: Addition von Zeilen
von: Hans W. Herber
Geschrieben am: 06.06.2002 - 07:25:22

Hallo Florian,

nicht unbedingt eine Arrayformel, Du kannst die einzelnen Spalten-Ergebnisse auch addieren, indem Du die Formeln aneinanderreihst.

Das was Du unter "perfekt" verstehst, ist allerdings ganz etwas anderes. Formeln können nicht in anderen Zellen Werte verändern. Hier hilft nur eine VBA-Programmierung.

Bilder können nicht auf den Server geladen werden. Du kannst es allerdings auf Deinen laden und einen Verweis dorthin erstellen.

hans


 

Beiträge aus den Excel-Beispielen zum Thema "Addition von Zeilen"