Microsoft Excel

Herbers Excel/VBA-Archiv

Reseltat ausblenden



Excel-Version: 9.0 (Office 2000)

Betrifft: Reseltat ausblenden
von: Martin
Geschrieben am: 06.06.2002 - 11:48:10

Hallo

Ich habe folgende Formel:

=WENN(F16-E16=0;G16+H16+I15;G16+H16+I15-$K$3)

Nun möchte ich das wenn F16-E16 Null ergibt das Resultat ausgeblendet wird also einfach nicht sichtbar ist die Formel aber trotzdem angewant wird.

Danke im Vorraus

  

Re: Reseltat ausblenden
von: Coach
Geschrieben am: 06.06.2002 - 11:54:05

Hallo Martin,

am besten über benutzerdefinierte Zahlenformate (0;-0;) oder Optionen ("Nullwerte anzeigen") deaktivieren definieren.

Gruß Coach


  

Re: Reseltat ausblenden
von: Martin
Geschrieben am: 06.06.2002 - 12:00:10

Hallo Coach

Das Problem ist es ergibt ja nicht Null habe es vieleich falsch erklärt. Noch mal die Formel

=WENN(F16-E16=0;G16+H16+I15;G16+H16+I15-$K$3)

Also wenn die Formel G16+H16+I15 angewant werden muss weil F16-E16 Null ergibt dann sollte das Resultat ausgebledet werden und das ist nie 0.

Gruss


  

Re: Reseltat ausblenden
von: Kl@us-M.
Geschrieben am: 06.06.2002 - 12:09:36

Hallo Martin,
versuchs mit der bedingten Formatierung: Formel ist =$F$16-$E$1&=0, Schriftfarbe = Hintergrundfarbe Deiner Zelle
Gruss
Klaus-Martin
  

Re: Reseltat ausblenden
von: Coach
Geschrieben am: 06.06.2002 - 12:15:49

Hallo Martin,

man kann die Formel so vereinfachen
=G16+H16+I15-WENN(F16=E16;0;$K$3)

Und mit folgendem Ereignis-Makro im Modul der entsprechenden Tabelle das Zahlenformat (hier für A1) dynamisch ändern:
Private Sub Worksheet_Calculate()
If (Range("F16").Value = Range("E16").Value) Then _
Range("A1").NumberFormat = ";;;" Else Range("A1").NumberFormat = "0;0;0;"
End Sub

Ohne VBA ginge es mit der bedingten Formatierung, indem man die Schriftfarbe der Zelle auf die Hintergrundfarbe einstellt.

Gruß Coach


 

Beiträge aus den Excel-Beispielen zum Thema "Reseltat ausblenden"