Kommando rückgabe

Informationen und Beispiele zu den hier genannten Dialog-Elementen:


Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Kommando rückgabe
von: Rolf
Geschrieben am: 07.06.2002 - 17:21:31

Hi,Leute
ich habe ein Problem
ein Makro Calculate() ruft nach Bedingung
ein Sub PlayIt() auf
ExecuteExcel4Macro ("SOUND.PLAY(, ""C:\Windows\Media\BaBaBa.wav"")")
End Sub
Die Musik wird zwar abgespielt jedoch kommt
das Kommando nicht mehr zum Makro Calculate()und bleibt haengen
wie kann mann das erreichen das Kommando an Calculate zurueck
kommt
Rolf
Rolf
nach oben   nach unten

Re: Kommando rückgabe
von: Ramses
Geschrieben am: 07.06.2002 - 22:20:31

Hallo Rolf,

füge diesen Code in ein Modul ein:




nach oben   nach unten

Re: Kommando rückgabe
von: an Ramses
Geschrieben am: 08.06.2002 - 18:57:44

Hi,Ramses
dein Makro arbeitet sehr gut es braucht aber manuele
Betaetigung -klicken auf Button "OK".
Die Sache were perfekt wenn Bedingung "WAHR" in ZELLE "A1"
diesen Klick ausloeste.
Is es moeglich?
Rolf

nach oben   nach unten

Re: Kommando rückgabe
von: Ramses
Geschrieben am: 08.06.2002 - 20:09:11

Hallo Rolf,

das geht nur über einen Umweg.
Erstelle im VB-Editor in einem Modul eine Function

Jetzt kannst du in der Zelle deiner Wahl eine WENN-Bedingung einbauen:

=WENN(A1=1;CallWave();"")

Wenn jetzt in A1 eine 1 eingetragen wird, geht das Spektakel los :-)

Gruss RAiner

nach oben   nach unten

Re: Kommando rückgabe
von: an Ramses
Geschrieben am: 09.06.2002 - 12:49:41

Hi,Ramses
es klappt wie geschmiert
Du hast mir SEHR geholfen DANKE!
Da ich grade am Draht bin- Frage:
Ist es moeglich Prioritaeten zu setzen
zum Beispiel:nach der abarbeitung aller Makros
einer Mappe nur dann nach Bedingung die
Aenderungen automatisch speichern?
Rolf
 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Datenbankfunktion"