Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn / #NV



Excel-Version: 10.0 (Office XP)

Betrifft: Zählenwenn / #NV
von: Markus
Geschrieben am: 08.06.2002 - 09:56:59

Hi Leute

Habe folgende Probleme!

1. Ich möchte aus einem Dienstplan Urlaub und Krank auslesen und nach Ermittlung auf einen SVERWEIS verweisen .
Meine Formel lautet
=ZÄHLENWENN(A1;"K";SVERWEIS($G$1:$H$2;2)
aber leider funktioniert das nicht!?!?! Kann man ZÄHLENWENN + SVERWEIS überhaupt mischen oder gibt es da eine bessere Möglichkeit.


2. Wie bekomme ich #NV aus einer Zelle, gibt es auch hierfür eine Möglichkeit.


Danke für eure Hilfe
Markus

  

Re: Zählenwenn / #NV
von: Ramses
Geschrieben am: 08.06.2002 - 10:23:08

Hallo Markus,

ich denke die Kombination ist nicht sinnvoll, weil mit Zählenwenn erhältst du ja eine zahl als Rückgabewert.
Ausser du willst abhängig von der Anzahl Kranktage eine meldung ausgeben.
Dann ist deine Syntax aber grundsätzlich falsch:

=SVERWEIS(ZÄHLENWENN(A1:A100;"K");$G$1:$H$2;2;FALSCH)

Für Zählenwenn musst du schon einen Bereich angeben den er addieren soll, sonst zählt er ja nur immer eine Zelle :-))

Der Bereich G1:H2 liefert dann deine Rückgabewerte
2 aus der zweiten Spalte
FALSCH sucht den ganzen Bereich und erwartet keine Sortierung

  

Re: Zählenwenn / #NV
von: Markus
Geschrieben am: 08.06.2002 - 10:53:51

Hi Ramses

Danke erst einmal für deine Hilfe. Die Sache ist noch nicht ganz ausgestanden. Die Idee ist wie du schon angemerkt hast folgende. Ich muß eine feste Zahl der Krasnkheitstage haben die ich mit einer bestimmten Std. Zahl multiplizieren möchte; deshalb kann ich nur mit Zahlen und nicht mit falsch und Wahr arbeiten. Hast du vieleicht noch eine Idee?!??!

DAnke Markus


  

Warum dann Sverweis ?
von: Ramses
Geschrieben am: 08.06.2002 - 11:51:31

Ich gehe davon aus, dass der Fragesteller mit den Funktionen, über die er Informationen haben will, einigermassen Bescheid weiss.

=ZÄHLENWENN(A1:A100;"K")*Deine Anzahl Stunden

Wahr und Falsch hat mit den Berechnungen in SVERWEIS nichts zu Tun. Schau dazu bitte mal in der Hilfe nach der grundsätzlichen Funktion von SVERWEIS nach.

Gruss Rainer

  

Re: Warum dann Sverweis ?
von: Markus
Geschrieben am: 10.06.2002 - 20:03:01

Hi Rainer

Die Funktion ist mir klar; aber was mache ich wenn ich unterschiedliche Stunden im Krank habe, Teilzeitkräfte zum Beispiel oder Stundenkräft bei denen rechne ich immer mit anderen Stunden. Hast du einen Tipp

Gruß Markus