Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema InputBox
BildScreenshot zu InputBox InputBox-Seite mit Beispielarbeitsmappe aufrufen
Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

nach Datum selektieren | Herbers Excel-Forum


Betrifft: nach Datum selektieren von: Ralph
Geschrieben am: 25.07.2012 09:14:47

Hallo Forum,

ich bin mir sicher, das mir einer von den Profis hier helfen kann.
Habe die datei unten angehängt und in der Datei alles mit rot gekennzeichnet, was ich gerne hätte.

Tausend dank im Voraus
Ralph

https://www.herber.de/bbs/user/81153.xlsm

  

Betrifft: AW: nach Datum selektieren von: UweD
Geschrieben am: 25.07.2012 10:48:15

Hallo

hier mal ein Makro:

Sub Liste()
    On Error GoTo Fehler
    Dim TB1, TB2, Datum As Date
    Dim SP%, LR1&, LR2&, LRa&, LRd&, LRg&, i&
    Set TB1 = Sheets("Anreisen")
    Set TB2 = Sheets("Gästeliste")
    SP = 1 'Spalte A
    Datum = InputBox("welches Datum", "Gästeliste erzeugen", Format(Date, "dd.mm.yyyy"))
    Application.ScreenUpdating = False
    TB2.Range("G1").Value = Datum
    LR2 = TB2.Cells.SpecialCells(xlCellTypeLastCell).Row
    TB2.Range("A8:I" & LR2).ClearContents 'reset
    With TB1
        LR1 = .Cells(Rows.Count, SP).End(xlUp).Row 'letzte Zeile der Spalte
        LRa = 8: LRd = 8: LRg = 8
            For i = 2 To LR1
            If .Cells(i, 3) = Datum Then 'Anreise
                TB2.Cells(LRa, 1) = .Cells(i, 2)
                TB2.Cells(LRa, 2) = .Cells(i, 5)
                TB2.Cells(LRa, 3) = .Cells(i, 6)
                LRa = LRa + 1
            ElseIf .Cells(i, 4) = Datum Then 'Abreise
                TB2.Cells(LRd, 4) = .Cells(i, 2)
                TB2.Cells(LRd, 5) = .Cells(i, 5)
                TB2.Cells(LRd, 6) = .Cells(i, 6)
                LRd = LRd + 1
            ElseIf .Cells(i, 3) < Datum And .Cells(i, 4) > Datum Then 'bleibt
                TB2.Cells(LRg, 7) = .Cells(i, 2)
                TB2.Cells(LRg, 8) = .Cells(i, 5)
                TB2.Cells(LRg, 9) = .Cells(i, 6)
                LRg = LRg + 1
            End If
        Next i
    End With
    Err.Clear 'nur bei XL 2007 benötigt
Fehler:
    If Err.Number <> 0 Then MsgBox "Fehler: " & Err.Number & vbLf & Err.Description: Err.Clear
    Application.EnableEvents = True
    Application.DisplayAlerts = True
End Sub
Die Summen im Blatt über Formeln:

B6 : =SUMME(B8:B200;C8:C200)
E6 : =SUMME(E8:E200;F8:F200)
H6 : =SUMME(H8:H200;I8:I200)


Gruß UweD


  

Betrifft: AW: nach Datum selektieren von: Ralph
Geschrieben am: 25.07.2012 14:53:01

Hallo Uwe,

entschuldige bitte das ich mich erst jetzt melde.

Heb es ausprobiert.
einfach nur geil geil geil ( entschuldigung)
tausend dank

Ralph


Beiträge aus den Excel-Beispielen zum Thema "nach Datum selektieren"