Microsoft Excel

Herbers Excel/VBA-Archiv

addieren WENN(UND... | Herbers Excel-Forum


Betrifft: addieren WENN(UND... von: werner
Geschrieben am: 27.07.2012 19:41:26

Hallo Forum,

ich benötige bei folgendem etwas Hilfe.

Beispiel;
Die Zahlen welche in den Feldern der Spalte A eingegeben werden, werden in den Feldern der Spalte B summiert. Formel hierzu =WENN(UND(R9<>"";Q10<>"");R9+Q10;"").

Nun möchte ich, dass ein Summieren auch dann erfolgt, wenn in der Spalte A ein oder mehrere Felder leer bleiben. Und genau das bekomme ich nicht hin.

https://www.herber.de/bbs/user/81182.xlsm

Vielen Danke für die Hilfe
Werner

  

Betrifft: AW: addieren WENN(UND... von: Josef Ehrensberger
Geschrieben am: 27.07.2012 19:52:27


Hallo Werner,

Arbeitsplan

 AB
11212
22335
3  
4  
54580
6  

Formeln der Tabelle
ZelleFormel
B1=WENN(A1<>"";SUMME($A$1:A1); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: addieren WENN(UND... von: werner
Geschrieben am: 29.07.2012 01:08:57

Hallo Sepp

Danke für Deine Hilfe.

Nun habe ich versucht die Formel zu modifizieren; jedoch ohne Erfolg.

In den Zellen der Spalte H werden Texte eingegeben.
In den Feldern der Spalte A sollen die Textzeilen fortlaufend nummeriert werden in denen ein Text eingegeben wird.

https://www.herber.de/bbs/user/81191.xlsm

Mit der von mir eingesetzten Formel funktioniert das nicht wie gewünscht.

Würdest Du mir bitte nochmal helfen?

Gruß
Werner


  

Betrifft: AW: lfd. Nummer von: hary
Geschrieben am: 29.07.2012 06:33:37

Hallo Werner

Work schedule

 ABCDEFGH
1No.CodeWork task
21            cvcv
32            cvcv
43            cvcv
5               
64            cvcv
75            df
86            er

verbundene Zellen
B1:G1

verwendete Formeln
Zelle Formel Bereich
A2 =WENN(H2="";"";ANZAHL2($H$2:H2)) 
A3 =WENN(H3="";"";ANZAHL2($H$2:H3)) 
A4 =WENN(H4="";"";ANZAHL2($H$2:H4)) 
A5 =WENN(H5="";"";ANZAHL2($H$2:H5)) 
A6 =WENN(H6="";"";ANZAHL2($H$2:H6)) 
A7 =WENN(H7="";"";ANZAHL2($H$2:H7)) 
A8 =WENN(H8="";"";ANZAHL2($H$2:H8)) 

Tabellendarstellung in Foren Version 5.30


gruss hary


  

Betrifft: AW: lfd. Nummer von: Werner
Geschrieben am: 29.07.2012 11:21:20

Hallo Zusammen,

für die rege Unterstützung zur Lösungsfindung, und dem Aufzeigen diverser Lösungsmöglichkeiten, bedanke ich mich bei allen Helfern.


Gruß
Werner


  

Betrifft: oder: =WENN(H3<>"";MAX($A$2:A2)+1;"") von: Matthias L
Geschrieben am: 29.07.2012 09:32:14

Hallo

Work schedule

 ABCDEFGH
1No.CodeWork task
21      cvcv
32      cvcv
43      cvcv
5        
64      cvcv
75      df
86      er

Formeln der Tabelle
ZelleFormel
A3=WENN(H3<>"";MAX($A$2:A2)+1;"")
A4=WENN(H4<>"";MAX($A$2:A3)+1;"")
A5=WENN(H5<>"";MAX($A$2:A4)+1;"")
A6=WENN(H6<>"";MAX($A$2:A5)+1;"")
A7=WENN(H7<>"";MAX($A$2:A6)+1;"")
A8=WENN(H8<>"";MAX($A$2:A7)+1;"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: AW: oder: =WENN(H3<>"";MAX($A$2:A2)+1;"") von: hary
Geschrieben am: 29.07.2012 09:40:09

Hallo Matthias
Hatte ich auch erst,aber wenn H2 leer ist muss A2 immer haendisch bearbeitet werden.
Oder halt so.

Work schedule

 ABCDEFGH
2               
31            cvcv

verwendete Formeln
Zelle Formel Bereich
A2 =WENN(H2="";"";1) 
A3 =WENN(H3<>"";MAX($A$2:A2)+1;"") 

Tabellendarstellung in Foren Version 5.30


gruss hary


  

Betrifft: Ja hary, so ist es besser thx :-) owT von: Matthias L
Geschrieben am: 29.07.2012 09:48:14




  

Betrifft: Veto :-) von: Reinhard
Geschrieben am: 29.07.2012 09:48:17

Hallo Hary,

A2: =WENN(H2<>"";MAX($A$1:A1)+1;"")

Gruß
Reinhard


  

Betrifft: AW: Veto :-) von: hary
Geschrieben am: 29.07.2012 09:54:38

Moin Reinhard
stimmt ;-)
gruss hary


Beiträge aus den Excel-Beispielen zum Thema "addieren WENN(UND..."