Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

größer als 15.11. des aktuellen Jahres | Herbers Excel-Forum


Betrifft: größer als 15.11. des aktuellen Jahres von: Andy
Geschrieben am: 12.08.2012 20:20:59

Hallo,

wie muss ich meine Formel abändern um einen Datumsvergleich machen zu können?
In A1 steht ein bestimmtes Datum. In B3 soll 'Ja' oder 'Nein' erscheinen, je nachdem ob das Datum in Zelle A1 größer, also später als der 15.11. des aktuellen Jahres ist.

If Range("a1").value ="> als 15.11. des aktuellen Jahres" then
Range("b3").value ="JA"
Else
Range("b3").value ="Nein"  
End if
Gruß Andy

  

Betrifft: AW: größer als 15.11. des aktuellen Jahres von: Matthias L
Geschrieben am: 12.08.2012 20:31:37

Hallo

ohne VBA

Tabelle1

 AB
115.11.2013 
2  
3 Ja

Formeln der Tabelle
ZelleFormel
B3=WENN(A1>DATUM(JAHR(HEUTE()); 11;15); "Ja";"Nein")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: hier eine VBA-Variante von: Matthias L
Geschrieben am: 12.08.2012 21:05:48

Hallo

bezieht sich hier aufs aktive Tabellenblatt,

Dim Mydate$
Mydate = "15.11." & Year(Date)
If IsDate(Range("A1")) Then
   If Range("A1") <> CDate(Mydate) Then
    If Range("A1") > CDate(Mydate) Then
     Range("B3") = "Ja"
    Else
     Range("B3") = "Nein"
    End If
    Else
     Range("B3") = "Gleich"
   End If
Else
   MsgBox "kein Datum in A1"
End If
Gruß Matthias


  

Betrifft: Nach dem 15.11. des aktuellen Jahres von: Erich G.
Geschrieben am: 12.08.2012 23:40:17

Hi,
wie wäre es damit?

 AB
120.12.2011Nein
214.11.2012Nein
315.11.2012Nein
416.11.2012Ja
520.12.2012Ja

Formeln der Tabelle
ZelleFormel
B1=WENN(JAHR(A1+46)>JAHR(HEUTE()); "Ja";"Nein")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Und in VBA:
Sub Nach1511()
   Cells(3, 2) = IIf(Year(Cells(1, 1) + 46) > Year(Date), "Ja", "Nein")
End Sub
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: Danke! von: Andy
Geschrieben am: 12.08.2012 23:40:53

Danke für die Lösung!


  

Betrifft: Danke! von: Andy
Geschrieben am: 12.08.2012 23:41:27

Danke für die Lösung!


Beiträge aus den Excel-Beispielen zum Thema "größer als 15.11. des aktuellen Jahres"